Ropieee not recognising screen not showing up in Roon

Done. Please see feedback 6b30fe5583c30b99.

Thanks,
Drew

Basically the same problem @Robert_Brace had initially: you’re screen is just not detected during installation.

There’s not much I can do, besides suggesting that you check connections and try again.

Drew, one of the things that happened with me is that the pi lost power during my initial boot process, which I think stopped Ropieee doing all it’s updates. Reflashing the image and leaving it until you see Ropieee Running on the LCD wored for me. After initial power on, just leave it alone for 30 mins to allow Ropieee to do it’s stuff.

Yeah, that’s actually a good advise. RoPieee takes quite some time installing when you have a touchscreen (it installs additional software), so just ‘let it be’. The green LED should show a steady beat of 1Hz when RoPieee is done installing.

Hope this helps!

Ah - I had installed ropieee before I got the touchscreen. Perhaps the additional software never got installed? The touchscreen case makes it inconvenient to access the microSD card (have to take things apart), but I have extra SD cards, so it’s worth burning another one and trying…

Thanks,
Drew

Ok. That’s the problem. Touchscreen detection only happens during installation.

I’m confident it will work if you install from scratch.

Regards,

Harry -
Thanks. I flashed another micro-SD card tonight, and let Ropieee run through its setup. We’re now halfway there: Ropieee recognized the screen, but alas no album art yet: an empty black square, and album/artist listed as unknown. The Roon extension is enabled; what else am I missing?

Thanks,
Drew

PS: I wish I had gotten a screenshot, but my Ropiee (both old and new installs) is having a lot of updates fail because the lock file isn’t getting removed presumably from the previous update. That’s /var/…/pacman/… something.

I had that as well, this post should help

Bob

@Robert_Brace beat me to it, but it’s probably because you did not configured the zone in the web interface and left it to ‘unknown’.

Thanks,

Yes. It’s all working now. Thanks to both of you for all the help!

1 Like

I’ve a slightly different problem, but with the same effort.

Mine gets all the way through the load and even then displays ‘Welcome To Ropieee’ but then goes blank.

It’s clearly a config issue as I’ve had it working before, but could someone list me the things I need to check. Incidentally each morning and because it checks during the night I see a digital clock displayed.

Regards

Make sure the extension is (or still is ?) enabled in ROON.

Sure is, and all the names are the same.

So… it goes blank?

Ok. Can you show me the list of packages on the ‘information’ tab?

Thanks

Here you go. Oddly the clock came back this evening

Package Version
ropieee 20170927-1
ropieee-version 058-1
ropieee-web 20170928-1
linux-raspberrypi-dsd 4.9.50-1
qt5-base-ropieee 5.9.1-50
qt5-declarative-ropieee 5.9.1-52
ropieee-remote 20170928-1
ropieee-touchui 20171002-1

Though it might not mean anything , the network does not display the IP address data, only that DHCP is in use.

might that mean that the ROON extension can’t communicate with the endpoint ?

no that’s not the problem. Can you send me feedback (it’s on the ‘advanced’ tab)?
And furthermore: are you familiair with SSH?

Sent cf3b40061a9e6786

SSH just about.:slight_smile:

Hmmm… not received anything… can you retry?

ok @ian_frost,

Sorry for this annoying thing. I think I’ve solved this issue, but it requires you retry from scratch. Make sure internet is connected during installation.

Thanks!