Running Roon via Wine on Linux

Just updated to Wine 6.0 on Manjaro. Had to install Gecko.
Seems to work fine.

Just updated to Roon 1.8 and most is working. What i really mis is the the menu on top when “settings” is selected - se screendump
It is like this no matter the selected screen size and fullscreen

I have exactly the same problem, what I already mentioned in another thread. It seems to be a general Windows problem and has nothing to do with Wine. Roon is working on a solution.

Didn’t se the other posting. Looking forward to an update

Sorry. I have added a link to my previous post.

I’m running Bodhi Linux 5.1.0 (this distro is built on top of Ubuntu (18.04)).

I have installed Wine 6.0 and all prereqs for the script, executed the script, rebooted the machine and Roon is encountering a “serious error and needs to close” as soon as it opens.

Does anyone have any hints on what to do next to troubleshoot? Anyone else having this issue?

System information:
Wine build: wine-6.0
Platform: x86_64
Version: Windows 7
Host system: Linux
Host version: 5.4.0-65-generic

OK! It is working!

Changed a couple settings.

  1. Ran winecfg from the CLI - changed the default operating system from Windows 7 to Windows 10.

  2. Edited my so that it reads as follows:



if [ 1 -eq 1 ]
env WINEPREFIX=/home/zaid/my_roon_instance wine /home/zaid/my_roon_instance/$
env WINEPREFIX=/home/zaid/my_roon_instance wine /home/zaid/my_roon_instance/$

  1. Updated the display scaling in my Bodhi linux from Settings → Look → (changed from 1.2 x to 1.0x so that it wouldn’t do any weird scaling)

  2. Rebooted the system

Posting this in case it helps anyone else get up and running. I love that this works! Thanks all above for creating the script and advising on these fixes!


1 Like

Again I only want the client interface on Ubuntu in Wine. The server is in Linux native and I am happy to do some control on Android.

Note I had to add spaces to the URLs cause I am a new user. (edited from below comments)
Latest everything accept wine in windows 7 mode… I am sure that is safe… my ubuntu feels so dirty now…

Ubuntu 21.04 Roon 1.8 wine dev release 6.X
‘wget -nc https :// dl winehq org /wine-builds/winehq.key’ SPACES!
sudo apt-key add winehq.key
sudo add-apt-repository 'deb https :// dl winehq org /wine-builds/ubuntu/ hirsute main SPACES!
sudo apt update
sudo apt install --install-recommends winehq-devel
‘wget https :// raw githubusercontent com /Winetricks/winetricks/master/src/winetricks’ SPACES!
chmod +x winetricks
winetricks -q win7
./bin/winetricks renderer=gl
…/bin/winetricks -q dotnet40
…/bin/winetricks -q dotnet48
Installed all font packages. (probably not required but less thinking)

Ran the wineinstaller from the windows explorer
‘env WINEPREFIX=/home/USER/.wine wine /home/USER/.wine/drive_c/users/USER/Local\ Settings/Application\ Data/Roon/Application/Roon.exe’

Running on a 4K display.

Installed font packages. But still not quite right.

So Roon exits but wine hangs and doesn’t exit cleanly unless I type ctrl C. Then I get "01c8:err:ntdll:RtlpWaitForCriticalSection section 000000000A7F2D60 “?” wait timed out in thread 01c8, blocked by 0104, retrying (60 sec)

^C01e0:fixme:console:default_ctrl_handler Terminating process 100 on event 0
01e4:fixme:console:default_ctrl_handler Terminating process 20 on event 0
01e0:err:mscoree:expect_no_runtimes Process exited with a Mono runtime loaded."

Hi @Christopher_Schafer and welcome to the community forum.

I would highly recommend to follow the install instructions and use the script from roon-on-wine.

1 Like

Yeah but I run Ubuntu… Cause I am lazy. I will read the script… Some good setting adjustments in there I didn’t do. Yeah some of those commands in the script are no longer supported in ubuntu latest. I did do the .NET 4.0 install. And the openGL setting with ./bin/winetricks renderer=gl . I also moved my wine config to Win 7 which is depressing but whatever.

It should also work on Ubuntu. Just try it.

Oh and these last step broke Roon. So the script totally doesn’t work on Ubuntu 21.04. Well maybe from a clean install i don’t know but it has now made things worse…

OK so reinstalling the lastest .NET fixed the crash I was getting and it looks like the windows 7 setting does cleanly exit now. So all good. I will edit the above post.


Posting an update for newer wine version:

OS: Artix Linux x86_64
Kernel: 5.13.4-artix1-1
Wine: wine-6.13

I believe that newer wine versions have changed the path to Roon.exe. I updated the generated script locally to:

env WINEPREFIX=/home/rahul/my_roon_instance wine '/home/rahul/my_roon_instance/drive_c/users/rahul/AppData/Local/Roon/Application/Roon.exe' -scalefactor=1

(Change your $HOME directory accordingly of course)

And it now works flawlessly again!

On a new Ubuntu 22.04 LTS install, a few modifications were necessary:

After installing wine and winetricks:

apt-get install wine winetricks

The following path needs to be changed in the startup script:

env WINEPREFIX=$PREFIX wine $PREFIX/drive_c/users/$USER/AppData/Local/Roon/Application/Roon.exe

(from fix(script): correct AppData for wine-7.6 · RoPieee/roon-on-wine@8ef7524 · GitHub )

In my case it needed to be changed to:

$PREFIX/drive_c/users/$USER/Local\ Settings/Application\ Data/Roon/Application/Roon.exe"

I also had to manually create/fix the desktop launcher file. I ended up with:

#! /usr/bin/env xdg-open

[Desktop Entry]

@spockfish, I owe you more beer / scotch it seems. The debt is extensive.

1 Like

Screenshot from 2022-09-21 21-33-35

This used to auto update when a new version of Roon desktop was released, it does not like version 2.0 for some reason. I am running the Windows desktop on Pop OS with Wine.

Actually, can we just get a native Linux version please?

See this thread… you need a 64 bit Wine prefix.

1 Like

That worked, thank you.

I also had to install cabextract e.g.

sudo apt-get install cabextract

Also had to change the script “” in my home directory

This line

env WINEPREFIX=/home/jason/my_roon_instance wine /home/jason/my_roon_instance/drive_c/users/jason/AppData/Local/Roon/Application/Roon.exe -scalefactor=2


env WINEPREFIX=/home/jason/my_roon_instance wine /home/jason/my_roon_instance/drive_c/users/jason/Local\ Settings/Application\ Data/Roon/Application/Roon.exe -scalefactor=2

This line

env WINEPREFIX=/home/jason/my_roon_instance wine /home/jason/my_roon_instance/drive_c/users/jason/AppData/Local/Roon/Application/Roon.exe


env WINEPREFIX=/home/jason/my_roon_instance wine /home/jason/my_roon_instance/drive_c/users/jason/Local\ Settings/Application\ Data/Roon/Application/Roon.exe

You will need to adjust the changes to match your home directory.