S.M.S.L. Sanskrit 10th MK II AK4493-based USB DAC won't work with Roon via RoPieee

Core Machine (Operating system/System info/Roon build number)
Core - Lenovo i5 Laptop with SSD connected via Ethernet; Music - stored on Synology DS415+ NAS, also on Ethernet

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Ethernet - Synology Router

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
S.M.S.L. Sanskrit 10th MK II DAC via USB from Raspberry Pi4 running stable RoPieee

Description Of Issue
Hi - hoping Harry or someone else can help me out with this. I am trying to use this DAC with RoPieee / Roon.

This AKM AK4493-based DAC will not connect to Roon. The device It does not show up under “Audio” at all. This device has a 2nd USB port for power - I have tried adding power this way - no help. I have successfully used other USB DACs with this same endpoint.

The problem is NOT the DAC - I tried using it in my desktop PC and it works fine.
Here is my feedback ID - 04f8b156412d8c91.

Is there a known issue with AK4493-based DACs?
Can you please help troubleshoot this issue?

Thanks very much - I really hope this can be remedied.

Hi @meinhard57,

As more people are reading this thread, first I want to address a misconception:

This is a false assumption, unless the desktop PC you’re talking about runs Linux.
The way USB DAC’s are driven on Windows vastly differs from how this works on Linux (which is what RoPieee is using), so yeah. You can have a DAC that works on a desktop PC with Windows but fails miserably on a Linux system.

That being said, I think that this might not be your issue: the logs show a very frequent message saying ‘Cannot enable. Maybe the USB cable is bad?’. So I suggest you look into this first. And how is the DAC powered?


1 Like

Thank you for the quick response, @spockfish. You are correct, I am using a Windows 10 machine, not Linux. The DAC works fine there, but unfortunately will not be used there. It is powered by USB. I have tried about 4 different USB cables, all to no avail. Is there anything else I can try? Thanks, Bob

@spockfish - Hi Harry, before you look into this any further - I have decided to return this DAC, as this is just too much hassle. Thanks for the quick response and excellent support you provide for RoPieee. Bob

Why did you post this over on ASR without determining what the actual issue is?

Buyer beware - this DAC will not work with Linux as part of a Roon endpoint.

Man, that brings back memories of win-modems. So many hardware corners are cut to save a few cents and it’s fixed in software; proprietary software…

Hi Tony - I updated my post over there after it was pointed out to me that it did work with Linux under certain circumstances. My profuse apologies for posting it in haste out of frustration. I think my updated post is actually correct - “That DAC will not work with DietPi or RoPieee as a Roon Endpoint.” Saying it did “not work with Linux” was not correct.

1 Like

Hi, just a shame that there was no resolution for those looking to use this DAC with RoPieee, as it measure very well and is inexpensive.
Did you try the fix suggested over at ASR in the following post, or had you already sent the DAC back?

@Anthony_B - Yes, I did try that. I actually spent hours trying to get it to work on either RoPieee or DietPi. I have a “medium” tolerance for frustration, I guess. I just ran out of steam on it. One good thing that came out of it was that I learned a little bit about DietPi in the process. So, as an interim solution, I am using the DAC built into the Pi4 in that room now with Roon. Temporary solution, but it works, actually.

Hi @meinhard57,

Couldn’t help my self and looked into it a bit more.
I’ve pushed an update to the beta channel that might fix this. might, as I obviously don’t have the device.

So if you’re not entirely fed up with it you could give that a shot. Switching to the beta channel can be done from the ‘advanced’ tab in the web interface.



@spockfish - Harry - thank you very much for doing this. Maybe I will revisit using that product. The solution I am trying now is also not working well. I will report back if I do decide to try it again. :slight_smile: Bob

Hey Harry. I was going to pull the trigger on this DAC, so if you hear any positive news on it working with Ropieee, maybe you could post here? Thank you.

Good news…I got the unit working with Riopeee, with no issue. Whatever fix you implemented @spockfish, it worked.

Hmm - @spockfish -> looks like I bailed out too soon on this DAC. Thanks for looking into this and @waka_jawaka, thanks for verifying that it works now!!!

1 Like

@spockfish @waka_jawaka I wanted to post an update on this topic - I repurchased this DAC (after trying out a Topping E30 that had some issues) and find that it now works perfectly with Ropieee via USB. Thank you VERY much Harry for making this possible. Very pleased with my setup now!

Glad to have helped! Happy listening!

@meinhard57 sorry to grab this up, but please could you tell me if you use Ropieee Beta to get the Sanskrit to work ?

@erho - I am using the RoPieee stable release and it works fine. Are you having issues?

no, works like a charm here, have you set “force volume” in Ropieee settings at on or off?


“Force Volume” is OFF.

1 Like