Sample rate issue help

I am using Macbook Air + USB cable + Lyngdorf DAC 3400
My Roon ver is 1.6

Mac OS X El Capitan 10.11.6
On Roon settings I made sure that the “System output” max sample rate is up to 96kHz

I am having an issue with the playing quality from my Roon.
I am using Tidal + Roon and no matter the quality of the song that I am playing, I always get the same sample rate which is 44.1 kHz.

On the other hand, when I play the same songs from Tidal directly and ONLY the sample rate changes according to the song and goes up to 96000 kHz!
I see the changes on my DAC (Lyngdorf 3400).

Here is a thread on your device have you seen it, no idea if it will help.

@support @dylan @Peter_Neirinck
This is really frustrating!
The strange thing that Tidal can do it and change the sample rate automatically with no issues at all. However, using Roon + Tidal the sample rate is always the same.
So there is no point in using Roon + Tidal to play higher quality songs.

Hello @KWT,

Can you please post a screenshot of the Signal Path while there is music playing and also include in this screenshot the album sample rate details? Also, why are you using System Output to play back to the Lyngdorf, does it not show up as a USB ASIO/WASAPI device in Roon Settings -> Audio tab?



Hello Noris,

What do u mean by “why are you using System Output to play back to the Lyngdorf”?
What are my options?

Here are the screenshots:
This is the path when played through Roon

This is what I see the Lyngdorf when played through Roon

This is what I see on the Lyngdorf when played through TIDAL only

The song is MASTER quality


Hey KT,

@noris wants to see a screenshot of Settings > Audio window in Roon. Here is where System Output is Enabled.

You generally don’t want to use System Output. Look for the Lyngdorf and Enable it. Then you should select it in the Zone Picker at the bottom right of the screen.

Can you post the screenshot of the Audio window for us to see?

Cheers, Greg

Hello @Greg and @Noris,

Here is the Audio menu

Why there are 2 Lyngdorf???


It looks like the top one is connected to the Mac via USB and the other one indicates it’s Roon Ready and it connected to your network via network cable or wifi.

I’d use the Roon Ready Zone. Type in a name and select that zone. Play something and post a screenshot.

Cheers, Greg

1 Like

Hello @Greg

I am assuming that the Roon ready device will get the music through wifi right?

I don’t want to use wifi, I want to get the highest possible quality, this is why I asssune USB from Mac to Lyngdorf is the best route, right?

U want me to post a pic of what?

Thanks a lot for the help and support

@KWT I don’t recall the 3400 having wireless so the LAN cable is probably connected. If your Mac is connected via LAN too then you don’t need to worry about Wifi. But WiFi should easily support the max rate for the 3400.

You should put in names for both the Usb and network connected entries. Then you can play to one or the other and determine which sounds best. I would disable the system output too.

I think another pic of the audio path is what was being requested.

Been looking at the 3400 locally here but it’s rather expensive. Be interested to hear your thoughts by Private message if you prefer on the room correction performance of the unit too.

1 Like


Non of the mac either the Ltngdorf are LAN connected. Both are connected to the same wifi network. The Lyngdorf does have wireless.

Plz send me a private message to discuss the Lyngdorf, it is phenomenal!



I better read up the manual on the 3400 then.

Let your ears tell you what sounds best…worry less about the connection variables and use what sounds best to you.

wifi connection is as good as lan. ( of course it depend on your router)Enable your roon ready lyngdorf 3400 in: settings- audio- and give the zone a name, then it will play the best possible resolution: 1 x USB B (≤384kHz/32bit, ≤DSD128, DXD) never use your system output.
or usb, enable lyngdorf audio A/S and give the zone a name, but i am not sure why it not roon ready, maybe when you enable it it will recognize it as roon ready.
And in roon remember to close all dsp settings.

Hello @KWT,

It seems that you’re on your way here to make the changes for the DAC to support the higher sample rates.

As @wizardofoz mentioned, I would perform a test between the Roon Ready implementation and the USB implementation and choose the one which sounds better to you, but I would not advise using System Output for critical listening as this sends the audio to the Operating System mixer and then the system forwards the audio to the DAC while the other two modes (USB and Roon Ready) are communicating with the DAC itself.

After you make the change and if you’re still having issues with the sample rate on USB or Roon Ready just post some screenshots and we can take another look. Thanks!

– Noris

I am glad to inform you that the issue was resolved and now Roon is able to change the sample rate on my amp with no issues. This happened after I removed my source (macbook) as an output.

I attached a pic of the new path, could you plz check if everything is right?

What is the authentication and MQA core???

BUT now I am encountering a totally different issue!
Some songs (all the times) stops after a while at the same spot and gives me this message (see pic) and then skips to the next song!

Hello @KWT,

That Signal Path looks as expected since you are playing an MQA track from TIDAL. MQA Core decoding is Roon performing the first MQA unfold, you can read more about this here:

For the second issue that you noted that some songs skip through, is there any common pattern to this?

  • Is this just for higher-resolution files or just any files from TIDAL?
  • Does local media play as expected?
  • Does the same issue occur if you connect the Macbook via Ethernet instead of WiFi?
  • What is your network setup like? Please list the model/manufacturer of your router.
  • Does you network meet our Networking Best Practices Guide



  • Is this just for higher-resolution files or just any files from TIDAL?
    It happens with random music tracks (same tracks everytime) from Tidal (80% of tracks). It doesn’t matter higher resolution or not, it happens to different resolution tracks.

  • Does local media play as expected?
    If I play music directly from Tidal everything is fine.

  • Does the same issue occur if you connect the Macbook via Ethernet instead of WiFi?
    I don’t have Ethernet at all!

  • What is your network setup like? Please list the model/manufacturer of your router.
    It is the Home Hub 3000 by Sagemcom. It is supplied by my internet provider Bell Allient.

Do you see anything wrong with the path in the image?

Hi KWT, I think Noris meant, do you have any issues if you play files that on are your Macbook’s Hard Drive; nothing to do with Tidal.

It looks perfectly fine to me.

I assume that internet comes into your home to the Home Hub, then you are wireless to the Macbook. the Lyngdorf is connected via USB to the same MacBook. Correct?

If so, I think the request was to plug the macbook directly into the Home Hub as a test using an ethernet cable, and see if the problem continues. If it does not, then we know that the WiFi is the issue

1 Like


I managed to solve the issue by changing the Macbook Air and use MacBook Pro. I have no idea why the Macbook Air is the reason behind the “skipping” behaviour while using roon. Now with the Macbook Pro there is no track skipping anymore and no slow connection issues.

I attached few pics of my device settings. Can you plz have a look and let me know if there is anything wrong with my settings. I want to reach the best sound quality.

It looks good to me. Enjoy the music!