Scheduled Backup to NAS fails

ROCK on Intel NUC8i7

I am a new roon user (have bough lifetime sub). I have configured an automatic backup for 3 AM to a NAS drive. The first manual backup succeeded ok, so know the path is configured correctly. However the scheduled backups fail saying the destination wasn’t available. I’m pretty sure this is because I have the NAS configured to spin down the hard drives when not in use; therefore at 3 AM it takes 20 seconds or so for the drives to spin up and become available, by which time ROCK has already declared the backup a failure. Is it possible to configure how long/how many attempts the automatic backup tries before giving up?

Draytek router, Netgear PoE switches, Ruckus managed multiple Wi-Fi WAPs

ROCK and NAS are both hardwired to the same network switch.

Hello @Tennant,

Thanks for the report here. As far as I know there’s no way to configure ROCK to auto-retry a failed backup but to gather some more info here, I have a few follow up questions:

  • Can you please post a screenshot of your Roon Backup settings?
  • What kind of hard drive do you have? What is the model/manufacturer?
  • What Roon Remotes are you using to control ROCK?


NAS is a Netgear ReadyNAS 314 running ReadyNASOS 6 (build 6.9.5). It has four drives configured as a RAID 5 array and the drives are set to spin down after 45 mins of no activity.

The roonDBbackup SMB share has been exclusively created for the ROCK backups and is currently configured as anonymous access (ie no authentication required)…all other shares on the NAS have security configured and so cannot be accessed by ROCK.

Room Remotes are iPhone and iPad, both on latest version of iOS.

As you can see from the screen grab, if I do a manual backup when I know the NAS drives are already up to speed it backs up fine; it is the scheduled backup in the early hours that fails with “Backup directory not available”.

Note this is similar behaviour to Windows. If I try and access one of the shares on the NAS when the drives are spun down then Windows will initially fail to open the share. However if I then immediately try again to open the same share it will then open successfully as the drives have spun up to speed.

Hi @Tennant,

Thanks for letting me know the additional info. I spoke to the team and this is how Roon works, if the backup destination doesn’t respond in time, adding auto-retry or a longer timeout would fall more in the feature requests section of Roon rather than intended behavior.

One other suggestion I have that may help here – you mentioned that the timeout window is 45 minutes, what if you were to set two Roon backups one next to each other, for example you can trigger one scheduled backup to run at 3:55AM (which will fail) and then have the regular backup occur at 4AM (which will have already spun up the disks). Does that help?


You could tell your ReadyNAS to not spin-down the disks for the backup time (much easier when you change to a weekly backup schedule instead of your actual 10 days).

As far as I can see though I can’t set an absolute date (eg 1st of the month, or every Sunday) for scheduled backups, only an interval (ie every 10 days). Therefore won’t the two backups get out of sync relative to each other when the first one fails and re-schedules itself for the next day?

I know I COULD set the disks not to spin down on certain days; but the whole reason I do that is because the NAS can be heard in bedrooms at night if disks are spinning (in addition to power saving).

I COULD schedule the backups for during the day, but that might interfere with when roon is being used.

Neither of these options are therefore desirable.

So it must be the manual then that is on fault as it states (and shows) that you can set days and times (like e.g.: don’t spin down Sundays between 4 and 5 am). :man_shrugging:

You can schedule when you want spin down to occur if there is no activity; but you can’t schedule when you want ‘spin up’ to occur. So if I set “don’t spin down Sundays between 4 and 5 am” the disks will only remain spinning for that hour if they were already spinning at/before 4 AM; if that makes sense?

“Ideal” solutions would be either:

  • roon allows absolute schedules to be configured; so two weekly schedules could be set 5 minutes apart
  • roon allows a configurable time for automatic reschedule after a failed backup, eg 5 minutes rather than 1 day; with a maximum number of attempts
  • roon automatically makes X immediate retries for a failed schedule where X is configurable

In the meantime I can do manual backups!

Additional options might be:

  • If you have storage attached to your ROCK, you could backup there locally and create a backup job on the NAS to pull the backup from the ROCK share instead of pushing a backup from ROCK to the NAS.
  • You could plug a USB memory stick (no disk, no spin down) into your NAS and use it as your roonDBbackup SMB share.
  • Use Roon’s Dropbox integration for backup. If I remember correctly, ReadyNAS has an option to sync content with Dropbox.

Hi @Tennant,

Yes this makes sense, but I have not extensively tested how backups are set to retry. If you make a weekly backup by setting it to once every 7 days, when the first one fails, does the second one actually work? It would be good to test this and actually confirm.

These all would fit under Feature Requests rather than current intended behavior.

Our product team and developers keep a close eye on that category, so that’s definitely the best place to propose a change like this and get feedback from the Community.

In the meantime, I would try using @Blackjack’s suggestion here:


Hmmm…unless I’m doing something wrong, it appears you can only schedule a backup on the hour, so I can’t configure a second backup to be 5 past the hour?

Hi @Tennant,

You appear to be correct here. I am taking a closer look and it seems that you can only schedule the backups on the hour, so my theory regarding setting it up 5 minutes before and after won’t pan out, sorry.

My only follow-up here would be to try to use the USB memory stick or Dropbox as a backup location for the Core, and submit the backup changes as feature request.


I had a similar problem on my Synology NAS and solved it by scheduling “power on” in the task scheduler for 5 mins before Roon. I don’t know if this is possible on yours.

EDIT actually any task would do - just something to wake up the disks.

Interesting thought. Yes that would probably work; except the ReadyNAS, like roon, only allows scheduled events to be triggered on the hour. Therefore I would need to set the ‘power on’ at 3 AM with roon backup set at 4 AM. I would also need to extend the ‘idle time’ for spin down to over 60 minutes to ensure they didn’t spin down between 3 AM and 4 AM; which would result in the disks spinning for over two hours in the middle of the night; not to mention all the other times they will be spinning for longer when idle.

For now I’ve changed the backup to 9AM in the morning…at that time the disks will be more likely to be spinning owing to other activity; and hopefully won’t be a popular time for wanting to use roon! I’ll submit a feature request for more flexible/configurable backup options.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.