Schiit Yggdrasil problem when using exclusive mode

Roon Version 1.3 (build 259) stable (64bit)
Window 10
Gigabyte Laptop i7 16gb ram
music is stored in hard drive

pc->USB cable->Schiit yggdrasil

I can play music when I disable exclusive mode.

With exclusive mode on, every time I click the play button an error message occured ‘Transport :playback_error_endpoint_device_init_failed’

Are you using the built in windows usb class compliant driver? If so try turning off event style delivery, roon doesn’t like it or at least it didn’t last time I tried it.

whether Use Event Driven Mode on or off same message occured.

Works fine here.

here’s some logs

/01 23:52:47 Trace: [yggdrasil] [zone] Playing TransportItem
09/01 23:52:47 Trace: [yggdrasil] [Inactive] [LOADING @ 0:00] Symphonie Nr. 5 c‐Moll, op. 67: I. Allegro con brio - Carlos Kleiber
09/01 23:52:47 Trace: [musicpowerstate] music is playing, preventing idle sleep
09/01 23:52:48 Trace: [tidal/http] GET => Success
09/01 23:52:48 Trace: [tidal/http] GET => Success
09/01 23:52:48 Trace: [tidal/http] GET => Success
09/01 23:52:48 Trace: [tidal/http] GET => Success
09/01 23:52:48 Info: [yggdrasil] [zoneplayer] Playing:
09/01 23:52:48 Info: [yggdrasil] [zoneplayer] Queueing:
09/01 23:52:49 Info: [yggdrasil] [zoneplayer] Open Result (Playing):Result[Status=Success]
09/01 23:52:49 Info: [yggdrasil] [zoneplayer] Starting playback
09/01 23:52:49 Trace: [prebuffer] ready 149940/441000 (34%) @ 0/442 sec
09/01 23:52:49 Trace: [yggdrasil] [zoneplayer/raat] StartStream Sooloos.Broker.Transport.RaatZonePlayer+Endpoint: StreamFormat(channels=2, bitspersample=16, samplerate=44100, isdts=False) => StreamFormat(channels=2, bitspersample=16, samplerate=44100, isdts=False) streamid=433045703
09/01 23:52:49 Info: SETUP FORMAT StreamFormat(channels=2, bitspersample=16, samplerate=44100, isdts=False)
09/01 23:52:49 Trace: [Yggdrasil Gen 5] [raatclient] SENT [6]{“request”:“setup”,“format”:{“sample_type”:“pcm”,“sample_rate”:44100,“bits_per_sample”:16,“channels”:2,“sample_subtype”:“none”}}
09/01 23:52:49 Trace: [Yggdrasil Gen 5] [raatclient] GOT [6] {“status”:“DeviceInitFailed”,“message”:“RAAT__OUTPUT_PLUGIN_STATUS_DEVICE_INIT_FAILED”}
09/01 23:52:49 Trace: [yggdrasil] [Inactive] [PLAYING @ 0:00] Symphonie Nr. 5 c‐Moll, op. 67: I. Allegro con brio - Carlos Kleiber
09/01 23:52:49 Trace: [yggdrasil] [zoneplayer/raat] device init failed. stopping stream
09/01 23:52:49 Info: [audio/env] [zoneplayer -> stream] All streams were disposed
09/01 23:52:49 Info: sleep 0ms after flush
09/01 23:52:49 Warn: Track Stopped Due to DeviceInitFailed
09/01 23:52:49 Info: [audio/env] [zoneplayer -> stream -> endpoint] All streams were disposed
09/01 23:52:49 Trace: [yggdrasil] [zone] Suspend
09/01 23:52:49 Trace: [yggdrasil] [Inactive] [STOPPED @ 0:00] Symphonie Nr. 5 c‐Moll, op. 67: I. Allegro con brio - Carlos Kleiber
09/01 23:52:49 Info: [audio/env] [zoneplayer] All streams were disposed
09/01 23:52:49 Info: Alert: Transport: playback_error_endpoint_device_init_failed

Hi @YEONTAEK_CHUNG ---- Thank you for the report and sharing your feedback with us. Both are appreciated!

Moving forward, my assumption is that you have the GEN 3 driver installed for the Yggdrasil. Since noticing this behavior, have you tried to reinstall the driver?


A Shout out from the peanut gallery:

Please keep in mind, previous drivers should be removed before new drivers loaded. This can prevent some issues from occurring.

1 Like

Mine is gen 5.
When I plugged in, Win 10 automatically found the driver.
I tried to find the latest driver on Schiit homepage but automatically found driver is the lastest, so other driver on the homepage couldn’t be installed.

Hi @YEONTAEK_CHUNG ---- Thank you for the follow up and I appreciate the clarification.

I see that Win10 found the driver automatically as cited on Schiit’s website :thumbsup: A curious thing though, and due forgive my ignorance as I do not have one of these DACs in front of me to test with currently :innocent: but I see that for the Yggdrasil the Schiit website also mentions the following:


There has been some mention of needing to use older/specific drivers in some systems for the Gen5 boards over on Head-FI, mostly with Win7 or server 2012. I have not installed the Gen5 board in mine yet so i cant say for sure.

I tried drivers on their website, but win 10 says current driver is uptodate so they could’t be installed

You may need to uninstall the device and remove the drivers that way.
Then follow the install instructions from the Schiit site to install the new/different drivers.

It’s not possible to follow their instruction.

Although I removed the device and deleted the driver, connecting the device with usb cable automatically use the usb 2.0 audio driver inside win 10 so setup program couldn’t install the driver from Schiit’s site.

EVEN i reinstalled Win 10, same situation…

You have to brute force install the driver manually from the package that schiit provides using the device manager. It will probably moan that it’s not compatible, but upon reboot you should then be able to run the actual installer from schiit.

Once the the default windows driver gets installed it’s a real bugger switching back as you found out.

If I remember correctly when I did the drivers last time (not Gen 5 but earlier drivers when I went from Uberfrost to YGGY and then also when they updated drivers) I had to start eh install first then connect the DAC when it couldn’t find it. On my laptop I had to use the brute force method by ignoring the warnings. I think at one point I even had to delete all the USB ports from device manager to make sure the drivers were all gone. Can be a real pain sometimes.

I just ordered the Gen5 board, so when it gets here i will install it and test out a few things to see what i see…

Although I installed the driver with add legacy hardware in device manager menu, after i installed the driver, win 10 driver showed up and the driver I installed couldnlt work with warning.

I tried every methods with drivers, and it still doesn’t work.

with Tidal exclusive mode or foobar wasapi event, the dac works perfectly fine, only roon doesn’t work when exclusive mode on

After force installing the driver did you reboot and then run the schiit installer to get it to clean itself up and install properly.

I did reboot after force installing the driver and run the schiit installer to clean up and reinstalled.

I even tried everything on their site (gen2,5 for gung nir win 7,8 10 gen 3 yggy win 7,8,10…) only one driver 1.03(for modi2, bifrost…)doesn’t show warning message on win 10 device manager but still doesn’t work with roon. tidal or foobar exclusive mode is working with 1.03 driver.

I tried to update 1.03 driver manually on win 10 device manager with other drivers but win 10 says already installed driver is the optimal so couldn’t update the driver.

I may need to buy an roon bridge something like sotm sms-200 or give up

Contact Schiit and don’t let them dismiss you so easily. I have a yggy, but have not upgraded to Gen5 yet. One wonders if there is any real Sq difference if using Roon-> microrendu -yggy. I have.had many conversations with Nick some good and some not so much. I do not know if you have tried to call Schiit, but reach out and let us know the result.