Screeching noise heard when trying to play music after powering on Chord M-Scaler that is connected to Roon Nucleus+

Roon Core Machine

Roon Nucleus + running Roon Server Software Version 1.8 (build 1021) on Operating System Version 1.0 (build 227) and Roon Labs Software Version 1.0 (build 12).

Networking Gear & Setup Details

No Network Gear Involve - Roon Nucleus+ is connected to Chord M Scaler via USB.

Connected Audio Devices

Chord Electronic M Scaler connect to Roon Nucleus+ via USB.
Chord Dave DAC connected to M Scaler via dual BMC cables.

Number of Tracks in Library

6,500 Tracks

Description of Issue


Powering up my M Scaler after a power failure or it has been powered off, a high pitch screeching noise, that faintly sounds like the music, is heard mostly through the system’s left channel. This issue has happened almost every time the power is turned on to the M Scaler. After much trial and error doing things like power on & off various components, I have found most reliable solution is to pause/stop the playback of the song/music and restart the song/music.

Initially I thought the issue was between the M Scaler and DAVE DAC. I have been working with Chord Electronics support and they suspect there is a USB synchronization between the Nucleus+ and the M Scaler. They suggested setting the “playback delay” to 1,500 ms to see if it would resolve the issue. I couldn’t find a Roon parameter named “playback delay” but did find “resync delay” and have set it to 1 & 1/2 seconds. It didn’t resolve this issue (Note that this change did resolve another issue of some songs when played starting playing a second on so into the song.)

Hoping that you might have some insights as to what is happening and possible solution.

Thank you for your help,

Try connecting it to a different computer running Roon as an endpoint and see if the behavior is the same or different.

I experience the same problem.

Similar Set-Up
Roon Nucleus + running Roon Server Software Version 1.8 (build 1105) on Operating System Version 1.0 (build 227) and Roon Labs Software Version 1.0 (build 12)

My Previous Setup Details

Roon Nucleus → To Chord M Scaler via USB, To Chord Dave DAC via dual BNC cables

To fix the high pitch screeching noise, I would do the same, pause the song playing / find a different music resolution, play, play, pause, in no particular order, and then it would play correctly. I agree, this would also always happen when I would power up the M-Scaler and Dave. During power cycles, it would happen more often than not happen.

I added this new chain and have not had the issue yet, only tested for 2 days, but so far, so good. Pulled all BNC cables and reconnected them. Added new chain of hardware below.

Roon Nucleus is connected to SRC-DX via USB, Chord M Scaler is connected SRC-DX via Dual BNC Cable, Chord Dave is connected via Dual BNC.

Peter & Tom - thank you both for your replies and sharing your insights.

FYI - Cord’s belief is that M Scaler’s galvanic isolation on the USB input is causing the Nucleus to not “lock in” correctly sometimes when the components are initially connected.

As suggested adding a bridge or similar between the components or using a different hardware as the Roon server can solve the problem.

So adding another component (minimizing the components between source & music is the goal - right) OR changing my server both bothers me. Hoping that there may be another solution.

I have had exactly this problem except it happened when the output of my Lumin U2 mini was fed directly to my Dave via USB. The Lumin/Dave combination was unresponsive to volume control (already configured in the Lumin app & Roon) I thought it would blow up my speakers but i digress.
The problem isn’t specifically related to the Rock, with the Core-Lumin-Mscaler-Dave configuration all is fine.

I have just had the same “screeching sound” on left channel problem with the Core-Lumin-Mscaler-Dave configuration after powering up all devices.
Once again maximum volume with no control, amazingly the speakers appear to have survived :flushed:

Is it connected this way instead of BNC 1-2 on Dave?

BNC 1 on M Scaler to BNC 3 on Dave bottom

BNC 2 on M Scaler to BNC 4 on Dave top

Thanks Peter, I dd try 3/4 had no problems then reversed to 1/2 with no problems until today, I’ve swapped back and see what happens.
It’s certainly seems to be related to power/sync problems. It’s also strange that there’s no control of volume so it must be full output from Dave and means a rapid power down off the power amp to save my tweeters.


It seems that a common communication on the thread is Nucleus/Core to M-Scaler via USB. Has anyone tried Nucleus/Core via Ethernet to a streaming unit like Lumin, then USB to M-Scaler, then dual BNC, or single BNC/Spidf to your DAC? I’m trying to help because I would not like to have any issues with my system either.

Hi @David_Walp ,

Were you able to resolve this issue? Have you had a chance to try out Peter’s suggestions yet?

Hi @noris,

I have not tried Peter’s solution. A cabling issue on my system (aka my BMC cables are very short).

@PixelPopper - Since you reverted to using 3/4 DAVE’s inputs. If so, has it worked without exception? (aka is it time I replace my too short BMC cables and use the 3/4 inputs).

My current workaround is when powering up the DAVE initial set the input to OPT1 and then switch to Dual BMC 1-2 after few seconds. It has worked every time I have remembered to do it (need to get in the habit of setting the input to OPT1 before powering off the DAVE)

Thanks all, for the discussion on this topic

Hi @David_Walp BNC 3-4 appeared to work but i cant be 100% certain as my playback on the main system is infrequent. However, I was in p.m. discussion with Peter on this matter and he kindly sent me a firmware update to try out which has resolved the problem.

I’m not sure if the change has been included in subsequent firmware updates but basically it allowed a little more time for the mscaler & dave to get in sync with each other.

@wklie may wish to add to my comments.

Hi @PixelPopper,

Thank you for your quick response.

Quick question - the firmware update was for the Nucleus? Right?

I believe that my Nucleus is on the most recent firmware stable release, and I still see the problem if I forget and don’t used my OPT1 workaround. Thus suspect the firmware update may not have been widely released yet.

If correct, my GUESS to what is going on is that the M-scaler to DAVE connection initialization time is “long”. Using the 3/4 BNC connection or my hack of starting on OPT1, allows for a little more time for the M-scaler to DAVE connection initialization to complete. A firmware fix, adding short delay, to allow a little more time for M-Scaler to DAVE to complete initialization before sending audio signal potentially makes a lot makes sense. Just a GUESS

No, Peter is the firmware lead for Lumin, so the firmware update was for the Lumin U2 mini. You might be able to resolve the problem by using BNC 3 & 4 and/or changing the power-up sequence.

Thanks Paul

1 Like

Finally, was able to rearrange the equipment so that the BMC cables from M-Scaler could reach the DAVE’s BNC 3 & 4 connectors. Sadly, No Joy. Still heard the screeching on left channel.

Presumably you tried powering up Dave, after a few seconds Mscaler, therefore allowing them to synchronise before powering your amplifier (for speaker protection).
My issues seemed to be due to powering up dave/mscaler simultaneously.

Yes, the M-Scaler was power up before the DAVE.

I meant the other way around, it’s worth a try…

Finally got time to move the cables back to Inputs 3 & 4 on the DAC and tried turning the DAC on first & the M-Scaler second. Unfortunately. that didn’t work. BUT then I powered off the DAC and powered it back on with doing anything with M-scaler. That worked! SO maybe there is magical, reproducible sequence of steps, I have not found it yet…

1 Like