Scrobbling issues with Qobuz


I’m trying Roon 1.6 (build 390) stable (64bits), I find the quality very very good, but I have a problem:

I have scrobble issue
When scrobbling with Tidal or my Local files, there are no problems.
But when playing songs from Qobuz, the scrobble are counted twice and marks different times for the second scrobble (whereas I only played the file once)!

Waiting for your answer…
Thank You
Thierry Margairaz

1 Like

Just an FYI. Using the @ prefix in titles isn’t supported in Discourse. It doesn’t flag anything.

Using the @ support flag in a new Support post is redundant. All new Support posts are read by the Support team. The flag is best used if an existing post hasn’t received attention.

Do you have scrobbling separately activated in your Qobuz account ?

Yes, because I use qobuz on my smartphone (when i’m out of home)
Do I have to desactivate and activate every time I use the Qobuz’s own application?
Thank you for your answer

I hope not. But I think we’ve narrowed down why it’s happening. Let’s flag @support now to see if anything can be done.

Hey @Thierry_Margairaz – I understand the issue, but I’m not sure yet how we can resolve this.

I’ll need to discuss this with our team, and likely with Qobuz as well since it seems like their Last.FM implementation doesn’t quite work with ours, since both end up scrobbling the same plays when logged in :frowning:

For now, you can log out of Last.FM in Roon or stream in Roon with a different profile, if you don’t want to log Qobuz out of Last.FM

Thanks for report here!

Thank you for your answer and your concern.
For now , I’ll activate and desactivate the scrobble on Qobuz.
I hope there is a another solution in the future; in that case let me know!


Any updates on this one? I just connected my Qobuz account & I’m seeing duplicates as well (and the duplicate seems to be tagged as 5 hours ago, which I’m guessing is because I don’t have a time zone set somewhere in Qobuz).

1 Like

I just want to keep this topic alive, I’d really love for this to be fixed. I’m For now I just only having scrobbling enabled in Roon since I don’t listen to music often outside of my house. It would be great to track scrobbles from my phone as well!

1 Like

+1’ing the importance of having this issue fixed here too!

Think the only proper fix would be what is suggested on this feature request (go vote all of you who want to see a solution!) :arrow_right: Toggle Scrobbling by Service – i.e. having a toggle for using on Roon per service & local files.

On the bare minimum, Roon should’ve added a note to the configuration screen warning about this! I just messed a full year of stats due to this issue since I had no idea it’s a thing, eventhough this has been flagged here several years ago…

Oh btw, at least according to my tests, it’s the scrobbles coming in from Qobuz that have the incorrect time stamp – Roon seems to be reporting the play time correctly. Looks like a timezone issue to me at Qobuz.