Set "Radio" feature to "Off" by default

I never want random tracks to begin playing after my current playlist runs out.

It’s terribly distracting to be swathed in the fine reverie / afterglow of “Kind of Blue” (for example), and to be suddenly assaulted by some Kenny G track (or anything else, really).

I know you can turn off Radio in the queue view, but that only lasts until you next restart Roon (I think).

Could you guys implement a preference to default Radio to “off” rather than “on”? Or at least have it remember our preference?

1 Like

On mine when it’s switched off it stays off all the time.

Radio is an attribute of the Queue. It can be on or off for each Queue (a Queue is different from a Zone to enable a stream to be sent to a group of Zones).

Are you finding that the Radio setting in a Queue is not persistent but is reverting to Play after being toggled off ? If so then we’ll ask the devs to investigate because that sounds like a bug.

Yes, it turns on and off. Often, I find after an upgrade or a creating a new Zone, it’s back “on”. I’d really rather it just default to “off” rather than have to go in and turn it off every time I turn around :confused:


Thanks John.

This is the right place to ask to change the default and the devs will see that request.

It’s usual for a new zone to have Radio on, as that’s the current default which you would like changed.

However, I don’t think Radio should be reverting to On after a new build. I’ll keep an eye out but if you see it happening, start a post in Support and we’ll get the devs to check whether it’s a bug to be squashed.

I second that request. I’m not totally uninterested in trying out “radio” occasionally but I’d rather have it off unless specifically set.


Whilst I use radio frequently to play music whilst I’m doing other things I’d also prefer Radio to be a conscious decision rather than a default behaviour.


I agree, default Radio to Off.


Get it off for me as well, comes up with “on” every time i change an endpoint… Maybe a possibiliy to turn it off for all queues. When a record is ended, I expect silence, not somebody pushing music on me…


Hi, is there any official update on this topic? Like the others in this thread I find it very jarring to listen to an album then have some unplanned music play. When listening to an album (which is my 99% use case) I never want to be in radio mode.

In addition Roon does not remember my zones when I … (I don’t know exactly why Roon doesn’t remember my zones but that’s not really the point here). This means new zone, default setting of “Radio on” is enabled. So for almost every session of listening to music, I need to turn off the Radio setting after I’ve been annoyed at having some music play after listening to an album.

Please make radio mode off by default in all cases. Or at least give us a setting that allows us to set the radio to off in all cases.



1 Like

The crappy radio function turned it self on again after the last update, as ot does after each update. I’m expexting my stereo to be quiet after I’m finished playing a CD, even from a streaming product. This is so annoying that I might cancel my subscription!

Please set this function to default off, or give us a radio button in the setup section to disable radio altogether. Will never use it, and its freakin irritating!

1 Like

Radio only switches back on if you set up a new audio zone and it certainly has not switched back on my upgrade.

1 Like

Making Radio Off the default solves the reverting issue and is the right thing to do anyway.

Regardless of personal preference, it is in all of our best interests for Tidal to remain a healthy business, and for the internet to operate in as efficient and consistent a manner as possible. The Radio function increases Tidal’s cost of doing business and adds a load on the isps. It makes no sense to incur these when the cause is neither helpful or desired.

If Tidal had been paying attention they would have insisted that Off was the default setting in the first place.

1 Like

setting the auto-start radio off once should keep it off for that zone.

can someone give us instructions on how they get it to come back on?

Danny, the problem is not that the setting is “sticky” for each zone - it’s that if you add a new zone, or delete / re-add a zone, etc., the default is always “on”, which is rather disconcerting for many of us.

I quite frequently change my setup (as many as 2-3 times / month, with various streamers, DACs, etc, coming in and out of my system), and every single time I have to remember to go in and turn off the darned “radio”, because I never want that in my system :stuck_out_tongue:

So I think what we’re all asking for is the option to set the default to “off” instead of “on”, globally.

1 Like

@jhwalker, I understand your use case, but my question was directed at @Are_Kjersem’s experience.

The pesky Radio Default appears to still be “On” with no way to permanently and globally toggle it Off. Ok, I get it, there is a Radio Function built into ROON, yea, now I want to shut it “Off” until – in the unlikely chance – I ever need or want it!

If the Global Radio Off feature has been implemented, where might the Global “Off” switch be found?

1 Like

Turn Off Radio globally, Please! It’s like I am playing several albums by the same artist, then in the middle of that artist it starts to play someone else, like what the heck is that? and why is it playing someone else that I didn’t select, annoying and jarring at times. Well at least it’s usually in the same genre.

1 Like

I also find the random Radio assault highly annoying. Any update on globally disabling?

1 Like

I know - so many people have complained about this, I still don’t understand why they won’t set “off” as the default . . . or at least give us a choice in the settings!