Setting Roon backup destination as OSX from ROCK

I did set up scheduled backups via dropbox but storage capacity ran out quickly. As I do not want to upgrade the dropbox account I tried to add another backup destination but failed so far. I have ROCK running on an Intel NUC and what I wanted to do is to add a backup folder on my iMac (running on High Sierra) on which the Roon Control is installed. The only folders presented to me in the backup settings section are the folders containing my music files that are stored on my Synology NAS - but that’s not where I want to store the library backups. I therefore tried to set up my iMac as a network share using the smb-path (smb://networkadress_iMac/share). Notification says always “Invalid network path”. Any idea what to try next?
Thanks and cheers, Christoph

Hello @didnauri,

Thanks for contacting support, I’d be happy to assist here. Can you please let me know how you shared the folder in your iMac? Have you turned on “Windows File Sharing”? Have you inputted your correct username/password/workgroup when setting up the backup location?

This thread provides a good overview of how the setup should look like:

Please let me know if you have any questions after taking a look at those instructions.


In Roon you need to turn the slashes around as Rock is Linux there fore try this
\\networkadress_iMac\share and add in username and password that is required.

thanks for responding so quickly. I followed the instructions in the thread. Unfortunately it’s still not working - see attached jpeg:

thank you, too! Tried this also - in vain:

same message after I changed the direction of the last slash

Hello @didnauri,

Do you by any chance have any firewalls active on your Mac that could be preventing a connection from the ROCK? Apps such as “Little Snitch” or “Bullguard”?

Also, are you certain that you have your full name as the username to access the Mac and can you please post a screenshot of your sharing settings on the Mac? The sharing settings should look something like this:

Please let me know this information when possible.


no firewalls active as far as I know.
Yes, my username is my full name.
Sharing settings:

Could there be a problem because the destined folder is not on the hard drive I have my MacOs running on? I have two hard drives running in the iMac - one flash disc running the OS and another regular one for storage.The latter is the one I wanted to store the backups on.
Thanks, Christoph

Hi Christoph,

A couple of things:

In the above, try:

smb:// Backup
smb://admins-iMac.local/roon Backup

Use same Username and Password as above.

If you still have issues, please post a screenshot after clicking Options in this screenshot:

Cheers, Greg

1 Like

Thanks, Greg. Will try that on friday (not at home until then).

Hi Greg, it finally worked after I activated the “share-with windows”-option - see picture:

I used the smb-destination you gave me in your last reply. Thanks a lot!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.