Setting up laptop for control and output, having trouble connecting to core [Resolved, Windows Update]


I’m trying to set up a Windows 10 laptop as a control and output device. I was successful downloading the software and getting it set up when my laptop was connected to my router via Ethernet. I was able to access the core and play a couple files. But when I take my laptop to another room, now connected to the same network by WiFi, it cannot locate the core. I tried a couple times, even rebooted the laptop, but still the same…via Ethernet everyting is fine, via WiFi (strong signal strength) it cannot connect to the core.

Strange thing though, even when connected by WiFi, I can use the laptop’s file browser to access my music streamer/server (Roon core and music files reside on it), so it’s obvious both the laptop and streamer/server are connecting through the network with the laptop on WiFi. So why can’t Roon on my laptop see it?

BTW, my iPad and iPhone via WiFi are having no trouble connecting to the core.

Any idea what’s going on here?

Different subnets, probably. Roon presently is designed to work across only a single subnet. By chance, are you using a provider issued modem/router combo?


Thanks for the quick reply.

I am not using a provider issued modem or router. I purchased each separately.

Also, when I open Roon on the laptop (on WiFi) and it’s stuck on “Looking for Remote Libraries”, I can open Roon on my iPad and see the laptop as an available zone and even stream music to it.

I’m so confused.

Is Windows on your laptop running a firewall ? If so, try disabling it and seeing if that makes a difference. If it is the firewall then you will need to add Roon.exe and RAATserver.exe to your whitelist.

As part of the Roon installation process, it asked me if I would like to allow Roon access through the firewall (I said yes). I can see that that the Roon file you mentioned is in the firewall’s list of permitted apps. Even so, I did try it with the firewall off, but that made no difference.

It’s just bizarre to me why it would work fine when on Ethernet, but not on WiFi…same network, same router, all other WiFi devices acces Roon core/remote libraries no problem.

I’m very much sure you are on different subnets for your wifi and LAN. Your router may well be handling the visibility to the shares for your music. But Roon will not communicate over this path if its 2 different subnets.

You should have your wifi setup to get DHCP addresses assigned by the router LAN interface it is connected to.

A detailed description of the network setup would assist those offering help to give some things to try.

Fist thing is to detail the IP address assigned to your core and what your laptop is being given.

The firewall on the Core should be turned off too…as this too could cause something to be blocked. At least for troubleshooting purposes.

Eek! I have no clue how to check those things. Is there step by step instructions somewhere? I believe I have Fing on my iPad. Will this give me the info I need?

The streamer, a Salkstream III, that the core and music files reside on has no firewall.

The laptop running Windows 10 can be connected to the Router (Netgear N300 WNR2000v2) via Ethernet (which works) or WiFi (doesn’t work as described in my post).

The Salkstream III is connected directly to the router via Ethernet. I control the the core using an iPad mini 2 and an iPhone 6s.

With Fing you should be able to see the Core device (windows?) and the laptop all on the same network ideally. again make sure all firewall are off.

Firewalls might permit a remote like iPad or iPhone but perhaps not a windows client.

Still if its working on a LAN connection then it certainly points to a networking issue as most likely.

Sorry, I should have mentioned, the core and my music collection reside on the Salkstream streamer which Linux based. Does this make a difference?

What should I look for in Fing?

Hi @Saturn94 ---- Thank you for the report and continued feedback, both are appreciated!

When you are performing the proposed test with FING, make sure that the core machine (Salkstream streamer), iPad/iPhone remotes, and the Win10 remote (on WiFi) are all active. FING will show all available devices on the network, so the idea with this test is to confirm if the Win10 remote shows up. If it doesn’t while on Wifi, this strongly suggests (as others have mentioned) that it is on a different Wifi subnet.


Thanks for the clarification. I’m not that computer savvy, so bear with me.

I’ll give that a try tonight and report back.

I tried poking around in the settings on the laptop, but I don’t see anything that looks like this. How do I do this?

@Saturn94 please identify that you have the same SSID setup for the Windows 10 remote laptop. Sorry I am traveling now and don’t have access to a windows pc to give you the specific steps.

What were the FING results?

My apologies, I don’t understand what SSID setup is or how to check it.

I pulled up Fing, and I can see the laptop as well as my other devices. I see IP addresses but nothing about “subnet”.

I did confirm RAATserver.exe and Roon.exe are on the allowed list for the firewall.

Oddly, tonight sometimes Roon on the laptop is connecting via WiFi to the core and the music files, sometimes not (or takes a long time). It’s not consistent.

More odd behavior…it started playing ok, but when I selected another album to play the display just quickly ran through all the tracks on the album without playing anything.

Maybe this laptop just isn’t up to the task? It’s a small older laptop I use to use to run Logitech Media Server.

Hi @Saturn94,

Can you describe the specs for your laptop ? The recommended minimum hardware to run Roon is an Ivy Bridge i3.

Can you set out the IP addresses for your server and laptop. That will tell us whether they are on the same subnet.

Running through the album tracks can occur if relevant codecs are missing from the operating system. Are you using an N or KN version of Windows 10 ? If so then you will need to download the Media Feature Pack

1 Like

Hi @Saturn94 ---- Thank you for touching base here, the follow up is appreciated!

Continuing forward, at your earliest convenience please take a few minutes to review the questions asked in @andybob 's post above, as your answers will help determine what the next “steps” should be here in addressing these behaviors you are experiencing with the mentioned laptop.


I’ll do my best to answer your questions.

Laptop specs:
Windows 10 Home
HP Pavilion x360 Convertible
Intel Pentium CPU N3700 @ 1.6GHz
Memory 4 GB
64 bit Operating System x64 based processor

“Set out” the IP addresses? You mean list them here?
Laptop is

Not sure about the server. The name doesn’t appear, but there are 3 generic devices listed. The server is none of the named devices, so it must be one of these generic devices:

Does this help?

Btw, I’m doing this kind of as an experiment to see if Roon would work on my laptop. However, I don’t use the laptop much at all, so if it doesn’t work out, it’s no real loss. The vast majority of the time I use my iPad or iPhone and my main AV system.

Hi @Saturn94,

The Pentium N3700 is well under minimum recommended spec for Roon. See this comparison. This will result in an unpredictable and unsatisfactory user experience.

Read the thread title.

The laptop is not connecting to the core. Logically, thus, the laptop is not the core. And the minimum recommended specs do not apply the same to a remote.


The minimum requirements are directed to running Roon either as a Core or a Remote. A Core may be more intensive but a Pentium N3700 will struggle as a Remote.