Setting up Marantz SR7015

Hi.

I am using ROCK with an Intel NUC and connecting by Ethernet (but also have a WiFi connection available).

I just installed a Marantz SR7015. Even though Marantz’s Web site shows it as Roon Tested, the device appears in Roon’s settings only as an AirPlay 2 device, not in the Roon Tested section.

As a result, I can’t seem to enable surround sound. How do I connect it as a Roon Tested device?

Thanks.

Hi Andrew,

Try connecting it via HDMI from the NUC.

1 Like

Hi. The NUC is in a different room, unfortunately. Can it work by Ethernet?

Only via AirPlay.

Some of our customers use a Lumin D2 to output to Marantz and Denon AV receivers.

I believe that only Roon Ready, rather than Roon Tested, devices can connect via ethernet (or wifi).

Thank you. I did manage to connect to the Marantz through AirPlay, but Roon is reporting that it is down-converting from DSD 64 to PCM 352.8 kHz to 44.1 kHz and then remixing from 5.1 to 2.0. (Please see the below screenshot.) Yet I hear audio in more than two channels. Is it safe to assume that Roon is playing the same content in each channel and not delivering the right content to particular channels? If so, is there a way to get it to put the right content in each channel? I appreciate your help.

That is 100% normal and expected.

You are doing surround upmix from two channel in the Marantz.

Assuming you don’t buy another piece of multi-channel Roon Ready hardware, you will have to use HDMI. Even then you’ll still see DSD to PCM conversion, which is not a real issue because your Marantz internally converts DSD to PCM too.

1 Like

Sorry about posting twice. I wasn’t sure my first post was in the right forum.

I have my NUC in another room and have connected it directly to my main switch. I made the move there because Roon disconnected often when connected to a cheaper switch that is in the same room as the Marantz. I have since replaced that cheaper switch with a more-robust switch. So I think I have two options:

  1. Move the NUC back to the same room as the Marantz, try to connect the two by HDMI, and connect the NUC to the new switch.

  2. Use an Ethernet-to-HDMI adaptor. If that option would work, I would prefer it simply because Roon is no longer disconnecting since I moved it and connected it directly to the main switch. Would the adaptor option work, though? If so, would I have to buy two (one to go from NUC to main switch and another to go from switch near Marantz to Marantz)? And would you recommend any adaptor models?

Finally, would making the connection though option 1 or 2 disable the NUC’s regular Ethernet connection to my LAN or alter the NUC’s regular functionality with Roon? I use that Ethernet connection with Roon to play music to Bluesound devices throughout the house, one of which is in the same room as the Marantz. That Bluesound device connects to a stereo amplifier by digital coaxial and to the LAN by Ethernet. And then I have the Marantz handling the surround sound, except for the main left and main right, which go to the stereo amplifier and use the bypass feature.

Thanks for your help.

You would have to connect to the SR7015 via HDMI or optical Toslink in order to get surround sound. AFAIK, surround sound is not possible via Airplay over the network.

I’ve merged into this dedicated topic, so all the history is together.

To update: I have moved the NUC to the same room as the Bluesound Node 2i and the Marantz and have connected the NUC by Ethernet to a local (robust) switch, which is also connected by Ethernet to the Node 2i and the Marantz. In addition, I have connected an HDMI 2.1 cable from the NUC’s protected HDMI port (it has two HDMI ports, one of which is labeled “protected”).

Unfortunately, Roon is still reporting that it is playing the surround sound to all speakers in 2.0. In Roon, I have selected the Marantz, rather than the Node 2i, as the play device. Roon still shows the Marantz as connected by AirPlay, despite the presence of the HDMI cable. I am not sure what I need to do to get Roon to recognize that the NUC is connected to the Marantz by HDMI. They are both still also connected by Ethernet over the network, of course.

Roon does show five HDMI devices (which I assume must be related to the NUC) as “Connected to Core”: HDA Intel PCH HDMI 0, 1, 2, 3, and 4. I tried connecting to 0, 1, 2, 3, and 4, and Roon shows that each is playing to it, but I hear no sound. When I configured it in advanced options, I made it 5.1, and now it no longer shows a remix from 5.1 to 2.0, but I still don’t hear any sound. I have no idea how to get the sound to play through the Marantz. I have the HDMI cable running from the NUC’s “protected” HDMI port to the Marantz’s CD port. And I also tried connecting to the NUC’s other HDMI port.

Does anyone know what I can do to make the surround work? It seems like the Node 2i supports some kind of surround sound (Dolby?). Could I get the surround music to work through the Node?

Thanks for your help.

Another update: in Marantz’s menu, I made the CD port’s input HDMI only. I then saw the NUC’s display on my TV. I then used Roon to switch to the NUC’s HDMI 0 port. No sound. Then I switched to HDMI 1 port, and the music began playing. Roon is no longer showing any conversion from 5.1 to 2.0, so I assume that means that it is playing genuine surround sound.

Unfortunately, I am getting another glitch: if I use the Sony TV remote to shut off the TV (I don’t want the NUC’s display of text to burn in to my TV), the TV then pops back on and displays video from my Apple TV. If I turn off the TV again, it pops back on with the NUC’s output on the TV. I can never keep the TV off. I am guessing that the NUC’s sending of audio to the Marantz through the HDMI port is forcing the Marantz to awaken the TV.

Is it possible to play music while keeping the TV off?

Also, what is the best option to allow Roon to control the volume? I have DSP sound control enabled, but I don’t know whether using DSP impairs sound quality.

Thanks for your help.

For toslink to transmit surround sound, it has to be either lossy AC-3 5.1 or lossy DTS 5.1. Given the signal path showing a multichannel DSD source, for this to work it would require Roon Core to be able to do AC-3 or DTS encoding (I believe it does not).

2 Likes

Thanks for the clarification… :+1:

1 Like

I have a bad experience with this type of product. I’d recommend using fiber HDMI for long lengths instead.

2 Likes