Setting up NUC as ROCK

Core Machine (Operating system/System info/Roon build number)
NUC8i3BEH, 250GB M.2 SSD and 16GB RAM.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Description Of Issue
I have downloaded the file to update the BIOS and put that on a USB stick. When I boot the NUC with the USB stick connected I get to a screen that says Checking Media Presence…

Media Present… Start PXE over IPv4. After a while it then shows A bootable device has not been found.

I have tried two different USB sticks to the same result.

@support Why am I not getting the F7 prompt?

Note sure this is Roon support question as its to do with the NUC and not Roon or RoonOS. But I am sure someone in the community will pop along and help you out.

I was able to update the BIOS (I think). If I simply push the power button I end up at the “No bootable devive detected” stage. I have to push and hold the power button for a few seconds (light turns blue then orange) and then I am able to access the function keys, F2 takes me to the BIOS settings. Is this normal behavior? Thanks.

Pressing F2 during boot up is what you must do to enter BIOS for Intel motherboards. Other manufacturers use different keys.

@Rugby Thank you for your reply. I have gradually worked my way through all of the problems that I have encountered until now. I am trying to restore my database from a backup, but ending up with no albums etc. in my library after the restore. I am also getting an error that my storage location in not available. The path to my NAS was originally set up using the path name rather than IP address as recommended, which is now not recognized by ROCK. If I enter the NAS location using the IP address, Roon begins to import my library from scratch. Running the restore process resets the path to using the NAS name, resulting in the unavailable error. How do I restore my database?

After restoring a database edit the location for your old music library and point it to the new one. It will import it but it relinks it all and keeps all your play history and analysis. I worried about this when I switched mine but I just had to leave it and it worked. Switching to Linux sometimes friendly names for devices such as Nas work after a while, does on my network they dont seem to work for a little while or just stick to using ip

OK. One more dumb question: how do I edit the location. From Storage I select edit from the 3 dot menu but I can’t find anyway to actually edit the location, only add a new one. Is this what I should do, remove old address and create the new one from scratch?

You should be able to edit an exisiting one. You might have to disable it first. Sorry not at home so cant check myself

You can either temporarily disable the old location, and add a new one, or as @CrystalGipsy said, edit the old one - after selecting edit, choose browse, and if necessary add network share

Nothing I tried was successful. I finally had to enter the new path for my NAS using the IP address and Roon appears to be doing a complete from scratch import of my library. I could not edit or disable the “old” path as Roon could not see it. Other people have reported that after the v. 175 ROCK update, Roon could no longer find their NAS with the name instead of IP address, this sounds like a similar issue.

Thanks for your post. It has been a very frustrating afternoon trying to set up this ROCK. I did one last year and did not have anywhere near the number of problems as today.

Ahh yes, that would have complicated matters. So just add a new one then, as you did. Pleased you have sorted it out. Now wait for Roon to relink everything as it should recognise that the new music files are indeed the old ones.

PS is your NAS a Synology?

1 Like

I hope so…:grimacing:

Yes, a Synology.

I wondered. There’s some problem with SMB addressing synology NASs with their (Synology) latest update. Using IP addressing works - as you’ve discovered.

See this thread No longer connecting to SMB shares on Synology via Hostname

Thinking about this, I am a bit confused here. I have just put my NAS to sleep so that Roon no longer sees it, and I get this when accessing the storage

The three dot edit is still there. Did you not see that?

Only the “active” location shows up under Folders. The “unavailable” location is only visible Add Share view. Sorry, I can’t remember what it looked like before I put in the new path.

Regarding the Synology update, when I had Roon Core on my iMac there were no issues accessing my library using the NAS name. I have done no updates on the NAS for a few weeks now, the only change was switching over to a ROCK.

Import is finished and at first glance it does look like the databases were linked so my edits are still present along with my playlists. I moved the NUC into my music room, installed it into my “data” closet and fired it up. I have music again! Hopefully it will be clear sailing from here.

1 Like

Good news. Now you can relax and enjoy your music.

As you never were able to disable the pointer to the old location, I would keep an eye on that when the Rock/Synology problem does get sorted out in case you suddenly find it becomes active again and you start getting duplicates of your music. I don’t know if that would happen, but no big problem, you then delete that pointer.

I’ve been searching around to try to answer the questions/problems that I encountered with my NUC. This NUC8i3 behaves a bit different from my NUC5i3. To access the Function Key menu in order to access the BIOS, I needed to hold down the power button for 3 sec, I don’t recall having to do this with the NUC5i3, in that case the menu came up while the normal boot processes was taking place. This behavior is documented on the Intel website in BIOS Troubleshooting. However, I have not been able to find out why my M.2 SSD never appeared in the boot order menu, there was always a message indicating that no boot discs were found. I tried setting the boot priority/order both before installing Roon OS and after. Since the NUC is able to boot into Roon OS, a boot disc is clearly present. Would like to know the answer to that one. Again, I did not have this problem with the NUC5i3 last year.

If at a later point I decide to pop in a SSD drive for database backups, will Roon OS recognize the SSD and format it automatically? Thanks for your help yesterday.

The strict answer is yes. From the Roon Knowledge Base

  • Internal storage (for music content) WILL be reformatted

BUT this is NOT recommended, see