Slowness on Windows 10 after Windows Update KB4013429

@Eric Yes, my graphics driver is up-to-date. I checked with the Acer site, and the Intel driver update utility. I tried adjusting different parameters of the OpenGL driver, to no avail.

The core server component still runs fine, and browsing using a roon remote on android still works flalessly.

Is the Win10 machine running as your Core? Or is there a third device involved here?

Also, can you let us know the size of your library (in tracks), as well as the memory setting you’re using for photos/artwork – you can find this information on the Setup tab, in Settings.

@Eric @mike Yes, win10 machine is running as my core. No third device. Library size: 57Ktracks, 3K albums.
I have good (or bad?) news. Since the problem was recent and postdated recent Windows updates. I tried uninstalling some updates received since March 15. I could uninstall KB890830 (Security essentials), and KB4013429 (cumulative update). This took a long time, but after reboot the user interface immediately spring back to life as it used to be, fully responsive.

Is this a side effect of the desinstallation process which may have effected some beneficial cleanup somewhere ? Or is it realy a consequence of removing some conflicting change between win10 and roon ? I am not knowledgeable enough to decide that, and leave it up to Roon support team to evaluate this.

Is there any test you would like me to do to help understand this issue ? I would prefer to keep my win10 system as it is now to see if the problem has been cured for good and will not reappear in a few days, But the win10 update center has again picked up update KB4013429 to be applied again, and will not let me go away without it. Assuming this update conflicts with Roon, is there a way to veto it for a while ? Could the Roon support team investigate this and advise on what to do ?


I have exactly the same issue. Deleting the above mentioned windows update files solves the problems after reboot. However, with the next reboot the updates are installed again, and Roon becomes unresponsive again. Is there a permanent solution to this?


@Eric This slowdown issue using Roon remote component on win10 is becoming more and more frustrating. As mentioned in my previous post, uninstalling update KB4013429 brought back the Roon UI to life. But I also pointed out that win10 does not allow you to block updates (at least in an official way) and I soon found that a new update KB405438 (which supersedes KB4013429) was waiting in the update queue to be installed. I had no choice but let it be installed following a shutdown. After reboot and a long install process, I checked how the Roon UI on win10 core server would react. Unfortunately, the same problems immediately reappeared : very poor responsivity, frequently unable to even move the Roon window on the screen. Frankly, the application becomes almost unusable.

So I had to enter a new lengty uninstall process (which may take over 45 mins!) to remove the update,which brings back the Roon UI to its usual,very good and responsive state. But I know I will have to face a new update in the next 24 hours, and I hope I will not have to waste my time resorting to this ugly uninstall kludge over and over again.

I saw today that I am not alone in this situation. It would be very interesting to see reports by other users.

My case shows that the problem is easily reproducible, and so offers a solid basis from which to work to find an explanation and hopefully a solution. In a way, this is good news. I thus offer all my collaboration to the Roon support team to dig into my system, run all sort of tests, produce all sorts of logs, etc.

Hoping to get some help,


Hey guys – we discussed this today and we are looking into it.

Unfortunately, we did some research and it seems like your theory is correct. People are having issues if they:

  • Install the Windows update you linked to above
  • Use the Intel HD4000 GPU
  • Use OpenGL-based applications like Roon (other similar reports here, here, and here)

By all appearances, this Microsoft update is causing issues for OpenGL. We are going to investigate, and if we can figure out a workaround, we will let everyone know.

If you guys want to experiment, the most obvious path would be try different graphics drivers, and perhaps an alternative one will perform better than the default one. There are also unofficial ways to prevent Windows from updating, and of course we can all hope that Microsoft rolls out a fix for this issue in a future update.

It would be good to confirm our understanding of the issue – @Pieter_Vroon, can confirm you’re machine also uses the Intel HD4000 GPU?

@mike Thanks for replying. Since it appears we will have to wait, can you in the meantime rapidly inform us on those “unofficial ways to prevent Windows from updating” ? I hope you understand this is the major headache we are facing, and if we could at least block this update, we could continue enjoying Roon. Otherwise, I am very close to giving up on it…

Sorry, meant to include a link in the post above. Edited now.

Thought I couldn’t be the only one, thanks for letting me know

I’m in the same boat too…

Same situation for me, Ive got a nuc and a surface tablet which both use the HD4000.

@Mike: I do have a HD2500 GPU.

Same here HD4000. Installing the 32 bit version of Roon instead of 64 bit fixed my problem.


Now that’s interesting - over a year ago I found that I had to install the 32bit version of Roon on my Surface 3 to get it working. It looks as though it’s been a graphics issue all along.

@support I suspect you may have heard this before; as of yesterday Roon has starting to become very slow or unresponsive to mouse input, and the library of around 1200 albums takes 2 hours to load. Nothing on my system has changed afaik. I tried clearing the artwork cache and then closing and restarting Roon; after it all loaded, if I leave the library (albums) page and then return to it, again the artwork is blank and very slowly starts to reload. It’s almost like Roon isn’t storing the album artwork and has to reload it constantly… What’s going on?
I’m running an Acer Aspire XC603 PC (win10) as my core with the library stored on its internal hard drive. It’s hardwired (cat6) to a netcomm router which is also hardwired to my SBT front end. I have checked and I’m running build 207 (current) and can’t figure out what is going on? Not being able to play music is killing me! :wink: Please help!!!

Is this your situation?

Yes Geoff, it’s exactly like that! I lack the skills to disable these updates without a step-by-step guide, but really think it shouldn’t be my responsibility. After all, we’ve paid for a fully functional software package and I trust that the folks at Roon will be able to sovle it for us in a near-future update. As is, I’m really not enjoying the Roon experience atm which is a shame, because I was loving it before…

Steven, there’s a link to a step-by-step guide to disabling Windows updates in that message of Mike’s. This issue has been caused by an update from Microsoft - the responsibility for fixing it lies with them. The Roon folks may be able to find a workaround, but for the moment, I think the best workaround is to uninstall the faulty update from Microsoft, and prevent it from reinstalling itself.

Hi All, just wondering if we’ve had any updates on this? Is installing the 32-bit version of Roon the only long-term fix/workaround currently available? Cheers, Steve

I have the same problem with de HD400. I reinstalled the latest driver and Roon is working normal again. Don’t ask me why!!!