I’ve searched around and I believe Rock only works using SMB protocols to connect to NAS drives. AFP and NFS are not supported?

What’s the maximum SMB version supported? I can’t seem to get SMB3 to work. SMB2 does, what about SMB2.1?

It used to be SMB v1 but now I think SMB v2 is supported.


Would be good to see an official response from @support and a move to SMB3

1 Like

Hi @Stephen_Harris,

Please see our documentation on this at the following link:

Use SMBv3 when possible. Failing that, SMBv2 should also be ok, but do not use smb2 with large MTU as it has known compatibility issues with Roon. If you’re using a Synology NAS and running your Roon Core on macOS, you can find some more information about fine-tuning your setup here

Don’t enable AFP or Timemachine if possible – some users may need this functionality for other applications, but they’re not needed for Roon. You can find more information about why AFP is not supported here

Hope this helps!


Thanks, most useful

1 Like


I have tried every combo but cannot get my Rock to connect to my QNAP NAS using SMB3. SMB2.1 works

Hi @Stephen_Harris,

I’ve moved your thread over to the #support section so that I can better assist you here.

Can you please provide a screenshot of the QNAP Control Panel SMB settings you have in place when SMB3 is not working? What is the exact error message that you receive in Roon when trying to add the SMB3 share?

Can you please share a screenshot of the error message in Roon and let me know the exact local time + date you tried to add the share (in case we need to take a look at diagnostics)?

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.