SMB / AFP problems

Hi,

I know this is a popular topic round here with Mac users.

I have a MacBook Pro with my library on a WD My Book Live.

As mentioned in numerous threads, the only way to force an SMB or CIFS mount is thro Go-connect to server.

This is very hit and miss for me. Sometimes it does it and most times fails.

I can connect instantly with AFP but for some reason Roon does not support this format.

I believe the SMB problem is something to do with finder because if I use mucommander the drive connects instantly with a SMB mount. This however is no use as Roon goes thro finder to find mounts.

On the odd occasion I do connect thro finder and add my library it’s fine until I reboot and then the mount won’t connect again even tho I had it as start up in my user profile.

I’m pretty hacked off with it now. Some people will say I should get a better NAS but I don’t agree as my other programs like HQ Player picks it up no problem.

Does anyone else have any suggestions and does Roon ever see support of AFP being in future builds.

I love Roon but this is doing my head in lol.

Thanks in advance.

Hi Wayne,

[quote=“Wayne_Bull1, post:1, topic:6224”]
… does Roon ever see support of AFP being in future builds.
[/quote]Roon supported AFP connection in the early builds but there were many issues with AFP. Given this and that Apple have deprecated the AFP interface it was decided to remove AFP from Roon as it caused more troubles that is solved.

With or without Roon I’m afraid you’ll have to bite the built at some point in time once Apple finally pull the plug on AFP as well.

I assume you have also looked for help on the Apple and WD forum sites, did they offer any advice?
I’m not a Mac user so can’t offer any direct advice there.

Hi Carl,

I’ve been on tons of forums and it seems to be a common problem with macs.

The cifs solution works for some and not for others.

I’m a new Mac user and it’s very frustrating.

Never experienced problems like this on Windows.

If apple favours smb why does it see my drive as afp?

You must have told it to at some point. Try deleting the “Connect to Server” entry that starts with afp:\.

I’m no network genius but it’s clear to me that stopping Roon using AFP, and using SMB instead, has improved performance in my system.

I’ll check it out Ludwig thanks

Can you turn AFP off at the NAS end? That would also stop OS X from using it. (This is possible on my Synology but I can’t see that option on my WD Mybook Live.)

No Ludwig there’s no option for that. Is there anyway to reset all startup connections on the mac?

The drive automatically loads in finder at startup but obviously it’s loading afp so I was thinking I could reset things and then force a connection in smb that may work?

Are you sure? Can you let me know what model of My Book Live you’re using?

I’d like to look into this, as I’d be surprised if there’s no way to configure the NAS to use SMB.

I think you have to open a new server connection to the WD.

You already tried How to connect with File Sharing on your Mac ?

Mike, its a 3TB My Book Live…Don’t think theres any particular model number.

Thanks for help

Weirdly, the Live does not appear to offer the option to disable afp other than ssh-ing in and hacking around.

@Wayne_Bull1 – could you post a screenshot of the storage tab of the settings panel in Roon?

Hi Rene,

I’ll post an image shortly. I’m just doing a factory restore on the MyBook to see if that helps.

Looks like forking out for a new NAS if not :triumph:

no luck with restore…

Instead of browsing to the local share, you can mount the share in Roon directly:

This forces Roon to use the SMB protocol instead of AFP. In your case, it will be something like smb://name_of_your_nas/Shared Music

Username and password if applicable.

Hi Rene,

I have done what you said and its ok until reboot when it takes ages to find the mount again.

Not much more to it than this, I’m afraid… Other than indeed considering less ‘consumery’ NAS that’s a better fit for ‘serious’ networking.

Thanks for taking time Rene.

Looking round forums this is a common problem apparently.

You should be able to mount the share in the Mac directly just like that instead of Roon, and set it to auto connect. As a side note, I never realized that anyone made single drive NAS enclosures like that. Every NAS I’ve ever looked at was always a RAID.