Software Update Need for new Nucleus +


New Nucleus +
Roon 1.6 build 416

Connected to via AQVOX Network Switch via POS to XFINITY Modem
Nuc + USB to Chord Dave

Roon recognizes and allows me to log into my HP laptop as Core.

Roon recognizes Nucleus + as REMOTE Core. Says software update needed. One or more devices on network need software update. However when I try to update, I get error message checking for update.

Hi @Daniel_Gale,

Can you please share a screenshot of your Web UI?

You have a bad network setup. You need to configure a router and a DHCP server on your network. Talk to your ISP for advice on what router can be used.
Your address to the Nucleus+ is out of the APIPA range where it should be from the 192.168.x.x range (or possibly 10.0.x.x)

An address like that is likely self assigned so no dhcp server is probably found

Hi @Daniel_Gale,

You’re not getting a valid IP nor a valid Gateway/DNS Server.

I would bypass this switch and have the Core connected to the router. If that does not resolve the issue, you’ll want to ensure you have DHCP Server turned on in your router and try rebooting the Core + Networking Gear.

Noris - I have connected the Nucleus + directly to my Comcast XFi Advanced Gateway modem/router. Same issue. Here is a screen shot of my ethernet properties on my laptop connected to the modem.

I had used a Netgear router in the past with this modem/router but was advised by Comcast to pull the Netgear as it was not necessary. Should I put it back in the chain before the Nucleus?

noria - DHCP is turned on in modem

Tried your above to no avail. Now with everything reconnected as it was Roon will not enable the Dave DAC even when I use my original settings and HP laptop as Core. When I click enable/and the Dave icon, Roon shuts down.

Hi @Daniel_Gale,

Is the Modem also a Router? As in - is it a combo unit with both router and modem capabilites?
It sounds like you’re almost missing a router in this setup, what is the model of your modem?

XFINITY COMCAST says it’s modem / router. See link. Initially I used Netgear Nighthawk with it going into the network switch. COMCAST told me to lose to Netgear router as it was causing a conflict. Also, it’s only now with the Nuc that I’m having this problem. No issues recognizing Fidelizer Nimitra up to yesterday when I replaced it with Nuc.

Norris. Have deleted Roon in my laptop. Now updating Roon in iOS app.

However update is stuck at 50%. Delete/reinstall of app brings me back to same upgrade hang.

Can you reset update for me? Download speed is 18 mbps. Should be adequate?

Just increases my wifi speed plan. Still no movement on Roon update download. I do not think the problem is with my network configuration. I have successfully run both my HP laptop and Fidelizer Nimitra as Cores on the identical configuration. The only thing that has changed is trying to replace my HP core with Roon Core. I am back using my HP as Core until this is resolved. If it cannot be resolved I will have to return the NUC. I told my dealer I will make a decision on Monday based on whether to Nuc can be made to function.

Again my set up is
Modem/router EoP to
AQVOX switch to
Nuc Plus to
Chord DAVE DAC via USB
HP laptop Core EoP to AQVOX switch.

My HP CORE is playing to the DAC and the only connection to the DAC is USB from the Nuc. So if I am showing the HP as Core but only the Nuc runs to the DAC is the Nuc being seen as a bridge? Allnof which functions perfectly through my network setup. Thoughts? Thanks and stay safe.

Noris. Firmware update successful. PC recognizes NUC. However can’t logo on. Says network connection problem. However every other network device is fine. Including PC which can be used as Core and which is identical network connection as Nuc - Ethernet to switch.

Spent the morning with XFINITY. They cannot help. Neither can my dealer. :(. Again, HP as Core works All network signals, configuration and hardware are good per XFINITY. They’ve tried every tool/work around in their end to no avail. Thanks

Can you post another screenshot of the current Web Administration page of your Nucleus+? Your last screenshot showed an incorrect network address.

Edit: also, that screenshot of your Laptop network adaptor showed that there was no network access for either IP4 or IP6 connectivity. I suspect that your network connectivity is going via the WiFi connection on your laptop - are you sure that is using the same network address space as your Nucleus+?

Here is screen shot, which is confusing to me. I am logged into my PC as Core, via Ethernet. However, when I try to activate the Chord Dave DAC associated with This PC, it does not activate and Roon shuts down.

OTOH, when I activate the Dave DAC associated with Roon NUC Plus below it, it connects and I am in business. And my settings shows me logged into This PC. BTW what is ALSA as opposed to ASIO or Wasapi? Maybe I’m logged into Roon but the system is just misnaming it as my PC? But in my laptop still needs an Ethernet connection for this to work, so that doesn’t seem right. Very confusing…

That screenshot is still showing that the Nucleus+ is sitting at - and that is definitely not a correct address. It’s clear that the Nucleus is not seeing the DHCP server on your router for some reason.

1 Like

Geoff. How would I change it. Earlier today it was showing 10.0…0.7 but that no longer shows.