Some Tidal Albums don't play on Roon with Tidal Premium Account

Core Machine

Roon Server Version: 1.8 (build 790) stable
QPKG-Version : 2021-02-01
ffmpeg version : user supplied version (john van sickle’s latest version)

Network Details

not related to my issue

Audio Devices

Tried PS Audio Direct Stream DAC, Sonore MicroRendu and Samsung Note9 cell phone. same issue.

Description of Issue


I’m using Tidal premium account which plays Tidal albums in AAC lossy quality. however some albums play with no issue and some just don’t play. on the album pages, both show the format as flac 44.1kHz 16bit. in Roon signal path, there are differences. the albums that do play show the source signal in 22.05kHz and 24bit. the albums that don’t play show the source singal in 44.1kHz and 24bit. I attach here the screenshots of them. any idea whether the issue is due to difference format by Tidal?

Thanks to @BlackJack who guided me to apply the user provided ffmpeg which I updated days ago but now there is this strange issue I need to seek support from Roon team.


I can play that version back to my System Output. Try playing the tidal stream which won’t work with the PS Audio DAC to a different DAC, like system output on a PC or MAC.

Thanks Rugby,
i tried to play the same version to the system output on my PC running roon client, as well as the analog output on my NAS. same issue.
there is no conversion showing in the signal path but still no movement in the progress bar.

Hi @Sam_Zhu

Apologies for the delay! Our team’s queue is longer than typical at the moment, but we’re working to get back to everyone as quickly as we can.

Are you still seeing this issue? If so, can you confirm if this happens when you try to play this content? Are you getting any error messages? Does it look like the track is playing but there is no sound or does it just fail to start?

Hi Dylan,

thanks for getting back.

Yes I’m still getting the same issue. it simply doesn’t play (time bar shows 0:00). no error messages.

I get the issue only when I play Tidal albums via Roon server installed on my QNAP NAS. I tried playing the same albums via Roon server installed on MacOS or Windows and there has been no issue. It seems that default AAC decoder on MacOS or Windows works fine but either Linux default FFmpeg or the 4.4 version i downloaded and installed from John van Sickle’s site don’t work properly.

afterwards I bought an Intel NUC and installed ROCK. I installed FFmpeg 4.4 on ROCK and I got the same issue. This kind of confirmed my suspicion that the issue is with FFmpeg and Tidal.

Now my workaround is to use Roon server on my MacBook to play Tidal and ROCK to play my own library. Later I may decide to upgrade to Tidal Hi-Fi then I won’t have this issue.

No idea who will work to resolve this issue but probably it is the job for Roon support team to do. If that is the case, this support ticket should be closed.


QNAP changed AAC playback a bit ago. Not sure if you saw that… let me check around the forum…Check out the following and see if it is applicable/helps:

Thanks Rugby,

I’ve just tried the CAYIN MSP’s ffmpeg. now it’s version 4.4. I’m not able to find the Roon Server app on my QNAP NAS thus I’m not able to apply and test it on my NAS. But I managed to copy the new ffmpeg file to apply on my Roon ROCK. still the same issue.

Then I tried to covert one of my own albums to AAC format. Roon is able to play the files without issue. see my screen copy. it does play. however if I play a Tidal album, it’s just stuck at 0:00 without progress.

before I tried this, I did apply the ffmpeg 4.4 version by John van Sickle. it doesn’t solve my issue but I guess it solved the issue that AAC or MP3 files are not able to be played on QNAP NAS.


Hey @Sam_Zhu,

I’m sorry that we missed on this reply of yours :pensive:

I was wondering, are you still running into the same issue?

Hi Rebeka,

thanks for getting back on this issue.

don’t feel sorry. in fact I didn’t expect a reply, considering that the issue should be with the external decoder, not Roon function, according to what I knew so far.

I believe that the issue hasn’t be resolved because the external decoder I installed with the Roon ROCK on my intel NUC is still the same one. now I’m using my macbook laptop as Roon server when i need to listen to Tidal. it means that sometimes i needed to switch my Roon account back and forth between ROCK and Roon server on laptop which isn’t very convenience but i lived with it so far.

Although I believe that it’s not an issue that Roon team can resolve, what i would appreciate is that if you could help me check whether I’m the only user who uses external decode running into such issue with Tidal premium account? if somebody else has exactly the same setup as mine but doesn’t have any issue playing music from Tidal, it means that maybe the assumption of a problematic external decoder isn’t true.


Hi Rebeka,

I received an another message from Rugby yesterday and I tried downloading the ffmpeg file again and it works now perfectly. the issue has been resolved and my ticket can be closed.

thanks for your help.


1 Like

Hi @Sam_Zhu ,

Thanks for letting us know that you’ve been able to resolve this issue by updating ffmpeg, that is great news! Please, do let us know if we can be of further help in the furture!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.