Sonicorbiter 2.5 operating system

Has anyone received the upgrade yet ? How is it working out ?

Nope. I am in Virginia and ordered it about 10 days ago. Have not received a shipping confirmation either.

1 Like

Yes. It eliminates the loud pops with native DSD but now I occasionally get some crackling sounds only at DSD512. I don’t know if anyone else had this experience?

1 Like

I had 2.5 installed, updated and working within 5 minutes no issues at all.

So far it’s working faultlessly and there does appear to be a SQ boost which wasn’t expected.


Works fine, no issues to report.


Yes. No issues at all.

1 Like

It is beyond my understanding how updating the software /OS on microRendu would improve the SQ. Am I missing something? As I said earlier, I have yet to receive the upgrade, so I don’t know.

It improved the sound quality for me because the sound before would have loud pops! Kidding aside, my impression immediately after switching was that it sounded different, I won’t say better or worse because I didn’t do a critical comparison. For me, getting rid of the accursed pops was worth it even if the newer OS had worse sound quality. Fortunately that doesn’t seem at least obviously the case, but again I haven’t performed critical comparisons. Maybe it is better, maybe not? But to me, definitely a worthwhile upgrade.

No issues for me either. I did lose my DSP settings but they were easily recreated in Roon. I was skeptical about a SQ improvement from an OS update, but to my ears and my setup I’m hearing a slightly fuller sound. I like it whatever the case is.

Hello. Just received the V2.5 release firmware and upgraded without problems. But am I right in thinking that V2.5 lost the Shairport mode - the ability to act as an Airplay receiver? I don’t see it presented in the Audio App switcher anymore.

Update: solved: just needs reinstalling with software manager. My oversight

A very few users may find that the new SD card for SonicOrbiter 2.5 doesn’t boot their microRendu and no Ethernet lights appear. If that is happening to you then email @Jesus_Rodriguez. This happened to me so I was pleased to hear a fix has been found.

Any news on the fix? I also have a microRendu that does not boot with the 2.5 microsd.

No news that I know of, make sure you email or PM Jesus so he knows to put you on the list to get a new card.

Ah. I’ve already sent Jesus an email. I thought that maybe you had heard more.


Here’s a little quirk with the new firmware.

“Current” SW version 2.5 / “Latest” SW version 2.3

An update yielded the same result…

If you have 2.3 that is the latest firmware you can update to. You have 2.5 so you are fine.

I take it that visual will change once an update to SW 2.5 is rolled out at some point.

There has been at least one update to Sonicorbiter 2.5 (possibly minor version). 2.3 is pretty odd on this page, I think Sonore should fix this.

1 Like

Hello folks,
I have installed/upgraded to version 2.5 from 2.3 and I can no longer play music from my Roon Server on my Mac with MacOS 10.12.5 on the Roon app on iOS 10.3.2 on my iDevice.

When I reinstated 2.3 everything works OK. I have Roon Ready Diagnostics from both versions of the Sonicorbiter OS [dumped as HTML files]. Asking this forum if they have any similar experience successfully running 2.5 wired into a set of KEF wireless LS50s ?

I’ve spent the past day ensuring everything is the same on both Sonicorbiter setups insofar as I can. I have also rebooted software (Roon, MacOs) hardware (routers, idevices, etc.) - troubleshot to the nth basically - but to no avail. I can see the full 2.5 suite of apps etc so there’s no issue with visibility. So I’m stuck.

[quote=“Paul_McBride, post:80, topic:24737”]
I have installed/upgraded to version 2.5 from 2.3 and I can no longer play music from my Roon Server on my Mac with MacOS 10.12.5 on the Roon app on iOS 10.3.2 on my iDevice.[/quote]
I have the same versions of mac os and ios and the latest updates to the mR and all plays fine.

Suggest you go to Roon, go to Audio Setup, and find the mR - the update from 2.3 to 2.5 makes it look like new device. I am assuming your mR is connected to your LS50w over USB.

1 Like