SonicTransporter not showing up as a Core in Roon app

Roon Core Machine

SonicTransporter i5 Gen 3

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

I removed and reinstalled Roon but now it now longer shows as a Core. Can get into the machine via IP address.

Did you check via the Sonic transporter web GUI that Roon is enabled there after the reinstall?

Yes, it shows up under installed apps.

If memory serves me correctly though you still have to go and select Roon as method of usage from the available choices like Roon, dlna, upnp etc.
And also then it’s output method , either USB or?

What are you using for a Roon Remote to try and select the Roon Core?

Have you rebooted that remote to see if it then sees the “new” core?

Yes, rebooted both iPhone and iPad but no luck.

All I have left for suggestions here is to reboot EVERYTHING.
Sonic transporter, remotes, router, modem etc.

If no luck with that hopefully someone else may have a better idea.

I used to have similar issues at times with Rendu units and it was ALWAYS something in the Sonic web GUI I had missed.

1 Like

Thanks, rebooted everything back to the router, but no difference. Tried updating the SonicTransporter software even though it was already running 2.8. Can’t find anything else to configure in the Web GUI; there’s not much there. I’ll reach out to Small Green Computer I guess. Thanks!

Just a wild guess… under Settings->System settings, you can change the name of your machine. Apparently, Microsofts wants this name to be 15 characters or less. Your name has 16 characters.

Second question: is every device on your network on

Thanks, I’ll try that! (Though it’s been that way for a year without issue).

And yes, everything on the network is on

The unit has been rock solid until today when I removed and then reinstalled Roon via the web GUI.

Another one… I’m still just guessing…
I assume that when you open the Roon Remote app on your iPad, it just says: searching for core…
Or does it go beyond that step and does it give you access to the Roon settings menu? Are there any hints there, especially on the tabs General and Setup?

Do you have a computer that is hard wired to your network that runs Roon as a remote? Will this work?

Tried changing the server name but no luck.

The app doesn’t get past the attached screenshot.

Too bad. I don’t know what else could be the problem. Let’s hope SGC will have a solution. Good luck!

Just tried Roon remote from a hardwired computer and got the exact same result.

Are there any hints in the logs (Roon server diagnostic on the Sonictransporter)?

Or else: have you completely uninstalled and reinstalled Roon Remote on your iDevice?

Thanks for your suggestions! Hoping I won’t have to send it back to SGC. Tried removing and reinstalling Roon several times just in case there was corruption somehow. Hard to believe it’s hardware related as the unit is less than a year old.

Not any help to your present predicament but why did you uninstall and then reinstall Roon in the first place?
Was there a problem?

I only did that because I was advised to do so by Sonore. My new Signature Rendu SE was sometimes dropping as a Roon endpoint intermittently and they suggested it might help matters. Wish I hadn’t now!

Still, I wouldn’t have thought that removing and reinstalling an app would be enough to brick the server. It’s designed to be configurable with different apps after all.