SoundID Reference ASIO support

I’ve been trying to get SoundID reference working with Roon and am having trouble.

Using the SoundID ASIO to ASIO option (to allow for proper sample rate switching), other applications like HQPlayer are able to play to it and everything works fine.

However with Roon, whilst it can see the device, trying to enable it just results in a red ‘Device not found’ text showing up above the name, and I’m unable to play to it.

Would Roon be able to look into why this is happening? SoundID is a really good room correction tool used by many and not being able to use it with Roon is a shame.

A temporary workaround is to have roon play to HQPlayer and then HQPlayer play to SoundID but that’s a bit of a clunky way to do it and it’s odd that Roon is unable to communicate with the SoundID asio driver when other software can?


Hi @GoldenSound,

Thank you for your patience while the team worked through a recent uptick in inquiries to reach your report.

We’ve pulled account diagnostics to investigate and see SoundID is now associated with a Wasapi driver on your Core, but playback is riddled with errors. I’m assuming you’ve switched away from the ASIO driver since your post? Have you had any success with this Zone in the time since originally posting? In the meantime, try refreshing RAATServer:

  • Create a Backup of your current Roon database to preserve Zones, DSP customization, etc.
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “RAATServer”
  • Rename the “RAATServer” folder to “RAATServer_old”
  • Restart the Roon App to generate a new RAATServer folder

Diagnostics also show IO failures loading certain content from your local storage location. It might be worth checking your Watched Folder permissions, drive condition, etc, to make sure nothing has changed that might affect Roon’s ability to access your library.

It has been quite problematic, though I think a lot of the issues are in large part on SoundID’s end.

They have chosen not to allow their ASIO or WASAPI drivers to allow sample rate switching. This seems to be the main cause for Roon not being able to communicate with their ASIO driver.

Their support staff is unfortunately providing essentially no information or assistance on the matter and so I’ve little hope it’ll get resolved. It seems other Roon users have encountered the same issue:

It would be great if SoundID would actually enable sample rate switching to alleviate this issue, but also would be ideal if perhaps Roon could update to allow communication with ASIO devices that cannot change sample rate? That would also fix the issue.

I’m now using SoundID’s ‘WASAPI to ASIO’ option as Roon can communicate with that, however for similar reasons, it only sees one sample rate available and so will resample all content to that sample rate. This is up to SoundID to fix though.

@connor So as it turns out, ASIO sample rate switching in SoundID DOES work now. Other software like Qobuz can use it fine, it seems to be Roon (and HQP) that cannot.

What could I do to help identify the issue so Roon can fix it?


Hi @GoldenSound,

Thank you for sharing the results of your investigation here. Do you have a recent timestamp (approximate) of when playback failed in the attempted setup? We’ll investigate logs promptly with QA and report back with possible next steps.

Hello, I am the creator of the other support ticket on the same topic (that @GoldenSound linked to). I can confirm again that SoundID correctly changes sample rate with ASIO to ASIO driver and Qobuz.

@connor It’s not possible to activate the “Sonarworks ASIO Driver” device in ROON at all. It tries to activate it but then goes back to “device not found” if I remember correctly. I don’t have an active subscription to test if that’s still the case right now but I assume it’s behaving the same @GoldenSound can perhaps confirm as well.


1 Like