Spinning Wheel of Death

The audio analysis wheel never stops spinning in the upper right corner since I have had Roon. Any way to tell it to stop analyzing music? I have turned off settings in setup but that doesn’t stop it. All of my metadata is pretty much there. It says it has 7000 more files to analyze but never finishes analyzing. Anyone else have this issue?

1 Like

Hey @Fritz_Curtis – have you restarted your Core? Can you post a screenshot of exactly what you’re seeing when you click in the top-right?

Also, can you let us know a little more about your setup? Thanks!

Will post pics tomorrow. Running Mac Mini 16gb of Ram. 2 TB Samsung Pro installed. Approx 14,000 files in total. 4k of which alway are under analysis

Adding Music to Library
Of 4710 tracks, 0 added, 0 identified.

This never changes. Wheel spins contanstly. Numbers never change.

I have reset the core to try to correct as well.

Mac Mini with 16gb RAM. Using 2 TB Samsung PRO SSD. Have turned analysis off and wheel still spins. It never finishes analysis. Core has been rebooted, but stays on continually.

I don’t think your issue is caused by Audio Analysis not finishing. From your screenshot, it seems to point to the fact that tracks are just not getting added to the library (“Of 4710 tracks, 0 added, 0 identified”).

Audio analysis is to do with generating data that drives volume levelling, crossfade and the waveform displays.

Something else is wrong, I think…

Hey @Fritz_Curtis,

@Geoff_Coupe is right, this has nothing to do with analysis. This pop-up informs about import procedure.

  • Which method did you pick to point Roon to the source of your audio files: watched folder, organized folder or iTunes library ?
  • Do you use TIDAL ?
  • 2TB Samsung Pro SSD is your internal drive, right ?

Organized folder on Synology NAS. No TIDAL. 2TB is the internal drive running Roon Server on my Mac Mini.

No iTunes. Only one folder that Roon is pointed to is /Diskstation/music via smb.

In a normal situation, how quickly should the spinning wheel take with a 14,000 library?

From memory, my library of 18,000+ tracks took less than 30 minutes to import the Watched Folder…

I need some support from Roon. How do I either reset this or disable. Please help.

Hey @Fritz_Curtis – sorry for the trouble here. Can you try this:

  • Go to Settings > Storage
  • Click the gear icon next to your Organized Folder and then click Remove
  • Re-add the NAS folder as a Watched Folder

I’d like to confirm whether this is related to the Organized Folder feature, or whether this is something else related to your media or storage device.

Let me know how that goes, and if it doesn’t help, we’ll take a deeper look here. Thanks for your patience!

Same issue. Goes right back to same thing. I have my NAS under watched, not organized. Removed everything and reenabled. Interestingly, when I enable and I click on the wheel, it initially shows check marks by the File Exporting, File Copy and Adding Music topics as done. After all files are scanned, it goes back into the mode of Adding 4710 Files and gets stuck. Hope this helps.

Ok, I’d like to have a look at your logs @Fritz_Curtis. I’ve sent you a PM with instructions.

Sorry for the trouble here!

The same thing just recently started happening to me. Judging from this thread that seems to go on forever, it is not an easy thing to solve. I recently moved to a different location for a couple of weeks and brought my setup along, so I am assuming it is some sort of network issue with this particular router, which is new and recently installed as part of a fiber-optic connection.
I am running a Roon Core on an Intel NUC, connected directly via ethernet. Library is on a USB connected 2 Tb SSD. Chord Mojo is connected via USB and running out to my system. Everything else works fine except I cannot add albums from Tidal or Qobuz and the ball spins endlessly. This same exact setup at home does not do this.Screen Shot 2020-04-13 at 10.35.12 AM