Stable release 2017/08/31: introducing touchscreen support


I’m happy to announce RoPieee’s latest stable release. This release lands support for the Raspberry Pi touchscreen, after being in beta for a few months.

For more information you can read my blog post here:

Besides landing the touchscreen support this release also adds support for native DSD with the latest Matrix Audio X-SPDIF 2 DAC.

I want to express my huge thanks to a number of guys over here that have been testing the touchscreen support over the last months and had to deal with me breaking stuff quite a few times and provided valuable feedback. So a big hug from my side: I owe you all a drink!

Kind regards,


Nice work Harry!! So to move from beta to stable is just a matter of changing the ‘Update Channel’ on the ‘Advanced’ tab?

Yes that’s it!

1 Like

I would like to try this looks like it is very nice. However, unless I am doing something wrong, I cant seem to get it to download completely. In IE it either just opens the file (cursing smiley faces filling the window) or it tries to save it as an HTML. In Chrome it starts to download and then fails after a few hours. have tried a few times and just cant get the file. It is 1.5 Gig right? Am I doing something wrong? Or is there a better way or program to use to get the file?

PS I live in the sticks so internet speed is 11meg down and .3 meg up if that makes a difference. I have had issues with Windows cumulative updates every so often but they do work in the end.

You should use Chrome. IE has problems with this. The 1.5G is right.

Ok, i will try again. thanks.

Edit: got it now. Will try it out.

Switched to stable. Well done Harry, time to roll out the bubbly. :smile:

1 Like

Thanks for the hard work Harry. RoPieee is a nice piece of software and all issues have been resolved promptly. I feel that it is us that owe you more than one drink. :beer: :beer: :beer:

1 Like

It been a fun ride testing this and its just perfect now - even SWMBO is now using it and asked how to setup the alarm to fade to stop that Jan did.

Awesome job Harry.

Just one thing…How do we confirm we are back on the stable channel?

1 Like

Go the ‘advanced’ tab. There’s a field called ‘Update channel’ that should say ‘Stable’.

I know that…but is there anything in the info screen that can indicate the stable version is updated?

Ok got it.

I’ve just pushed out an update to the stable channel. With this version you’ll see the first work in preparing RoPieee for manual updates, which in itself requires a way of ‘knowing which version I’m running’.

So with this update you’ll see on the ‘information’ tab een package called ‘ropieee-version’ with a version number. That identifies which build you’re running, and it differs on the beta channel.

For stable it should say ‘052-1’.

1 Like


How did it turn out?

1 Like

Just got the new Pi, case, and touch screen today so will be putting it together tonight. I will let you know.
The hat (HiFiberry digi+ pro) wont be here till next week or later but I can at least get the base unit set-up and running.

Edit: Ok got it set-up and running. Looks great!! just have to fix a few things with my core and PC not liking each other right now. Which has nothing to do with the RoPieee.

1 Like

So here’s a question, can the RoPieee control more than one zone? I just noticed that when I group zones I have no control. Or do I have something not set right?

Edit: I just read through some of the other posts and tried it again. If I start playing on my Den zone and add the “livingroom” zone (the one RoPieee is set to control) then the touchscreen still responds to touch. If I start playing on “livingroom” and then add the den the touchscreen does not respond to touch. Is this the way it is supposed to work?

Hi Bob,

No that’s not by design. this was reported before, but for some reason I can’t reproduce this, but I’ll try again.
Just to be sure: you’re on stable right?


Yes, stable. Thanks.

1 Like

Stupid question, perhaps… But does this require the official touch-screen?

No stupid question, but yes it does.

I have the Display, put it all together, I see all the commands at boot, Ropieee is running, but no graphics on the display… Is there something else to do?