Static is heard when switching from Flac 44/16 to DSD64

Core Machine (Operating system/System info/Roon build number)

Mac Mini (Late 2014) OS X 10.10.5/ Roon build 521
Music files are stored on a QNAP TS-431 NAS

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

FIOS-G1100 router, Trendnet TEG-S80g gigabit switch, two TP-Link MC200CM Gigabit Media Convertors between the Trendnet switch, and the Allo USbridge. I am using Ethernet.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Pro-Ject Pre Box S2 Digital DAC connected to an Allo USBridge by USB and then out to a Marantz SR5010 AVR CD input.

Description Of Issue

When Roon switches from a Flac 44/16 track to a DSD64 track, I hear static for about 7 seconds over the DSD track. After the static fades, the track plays normally. This only occurs when listening through the Pro-Ject DAC. It does not occur when listening through the Mac Mini HDMI output to the Marantz AVR. It also only occurs when switching from 44/16 to DSD. No other bit rate or sampling frequency produces this issue. It occurs with 44/16 files on my NAS, as well as Tidal 44/16 tracks.

Thank you

make sure the unit has the latest firmware installed. sadly lots of dacs dont deal well with such bitrate changes.

Thanks wizardofoz. It does have the current firmware installed.

Hi @Robosledger,

Is there any change in behavior if you add a slight Resync Delay to this zone? You can do so in Roon Settings -> Audio -> Cogwheel -> Device Setup -> Advanced -> Resync Delay.

More info regarding Resync Delay:

Resync Delay

This setting is primarily used when an S/PDIF, AES, or I2S connection is involved. Oftentimes, a DAC will take a little bit of time to lock onto a new audio signal–sometimes as long as a few seconds.

This setting causes Roon to play a configurable duration of silence whenever it begins a new stream. Like the last setting, this one is a problem solver. If you find that the beginnings of songs are being cut off, or you’re getting a lot of clicks and pops while your DAC locks on to an S/PDIF signal at the start of playback, try increasing this setting. 500ms is a good starting point. If that doesn’t work, try gradually increasing it from there.

We default this to a very small value because it produces delays in Roon’s user experience. Consider that when setting it up–unless you have an uncommonly slow DAC, settings longer than 1-2 seconds are probably not necessary.

1 Like

Norris, thanks so much for your reply. I had tried that, but it had no effect no matter what I set the delay to. This afternoon, I was doing additional searching and got a hit for a Roon community post I had not seen in my prior search. This describes my current problem exactly. It seems to me the problem may lie in the Diet-pi Linux OS on the Allo USBridge. Do you agree?

Hello @Robosledger,

I would test this to confirm, if you bypass the Allo USBridge and temporarily connect the Core directly to the DAC, do you still experience this behavior?

I had a similar issue when I owned the ProJect. Getting Roon to upsample everything to DSD256 solved it (and this seemed to be the sweet spot for performance for me also).

1 Like

Upsampling does put a higher load on your core cpu and maybe push past its limits on a lower spec core system. I have done this with an Oppo setup that had similar issues.

If you dont need DSD then upsampling everything to 24/192 is a less taxing option.

1 Like

Thanks Noris. When I connected the DAC directly to the Core and enabled it, Roon detected the DSD Playback Strategy as DOP. There was no Native option in the list. If I connect it back to the Allo USBridge and enable it again, Roon detects the DSD strategy as Native. If I change it to DOP, the issue does not occur. Although I would prefer to use Native, DOP is fine.

Hi @Robosledger,

If you manually set the USBridge to DoP mode, do you still have this behavior? I believe you should be able to set the DSD strategy in the Allo’s Web Interface (by opening a browser to volumio.local or

You could also try the other suggestions here, witch is to have Roon upsample content to a specific sample rate such as DSD. You can toggle this kind of setting on in Roon’s DSP Engine -> Sample Rate Conversion.

The only place I see to configure DSD options in the Allo web interface is under Squeezelite settings, which I don’t use. If I set the DSD Playback Strategy in Roon to DOP, the noise does not occur. I can just leave it set to DOP in the Zone settings for the DAC in Roon. I prefer that to upsampling. Thanks

1 Like

Hi @Robosledger,

Glad to hear that DoP is working as expected for you and does not cause the noise. I spoke to our hardware team regarding this behavior and they have noted that in older Pro-ject firmware, this was a known issue.

I know you mentioned that you’re using the latest firmware, but I would double check this aspect on the Pro-ject support site (under downloads):

In any case, if DoP works, you can keep using that instead.

That’s interesting to know regarding the firmware. I just purchased the DAC recently, and the firmware version reported on the DAC matches the current version on their download site. I think I’ll give flashing the firmware a shot. Otherwise, I’ll continue to use DOP. Thanks Noris.

1 Like

I flashed the firmware again, and it didn’t resolve the issue with switching from FLAC 44/16 to Native DSD playback, so I’ll just stick with DOP. I found something interesting, though. I checked the ALSA stream when using Native playback, and again when using DOP. When using Native DSD, the stream was 88.2 kHz. When I switched to DOP, the stream was 176.4. I would expect it would be 176.4 for Native as well.

I would have expected it to show 2.8224 MHz for native DSD. 88.2 kHz looks just wrong. Are you sure you get DSD at all with that setting?

BlackJack, thanks.

Here’s some pics with Roon set to Native playback for DSD. The actual track being played is at the bottom of the Roon window.

I don’t know if one can trust in the reported frequency here as it also reports using Altset 2 which is using format SPECIAL DSD_U32_BE and the DSD sample rates aren’t in the list of supported rates for the interface (Rates: …).

Btw.: A search for “0xb.0640” leads to other reports of clicks. Sadly no solution provided as I’m aware of. At least to me it looks more like a problem related to ALSA | Linux | drivers than Roon.

Thanks BlackJack. I appreciate your input. Looks like it’s a dead end. At least with the playback strategy set to DOP, at least it will switch from 44/16 to DSD without the noise even though the frequency is not right.

This is correct for DSD64 over PCM (2822.4/16=176.4).

PS: As the native format is reported as SPECIAL DSD_U32_BE, the 88.2 kHz might be correct in some crude way as 2822.4/32=88.2.

1 Like

Ah, interesting. Thanks so much.