Static Noise/Pop with Bluesound Node's USB Output

Hello everyone, I’ve been having an issue with playback from my Bluesound Node with its USB output only when playing through Roon. There is an audible and sometimes rhythmic static pop that persists. I’ve tried absolutely everything to remedy this and it seems as though Roon is the issue. Typically I use the Coax output on the Node and its flawless. Ever since switching to USB (since the long anticipated update) from the Node to my Chord Qutest, I’ve had this problem. If I use Tidal connect, there is no static. I’ve tried everything from switching cables, factory resets on the Node, all types of troubleshooting with Bluesound’s support, but everything seems to come back to Roon. Has anyone else experienced this?

Any help would be immensely appreciated.


Speculation: ground loop?


Static Noise Pop sounds like a genre I could


Thanks so much for this! Looking forward to the fix.

Many thanks! I have the same issue and keen to get it resolved. The solution I found are either to use the coaxial connection instead or bypass roon completely and use tidal connect.

and as a result, because of this issue, I stopped my subscription to Roon.

I’m so glad I found this thread because I’ve been having the same issue over the last few weeks. I get intermittent static when using the Roon app. This will occur every 10 to 15 seconds. I do not get any noise when using Tidal Connect (via Bluetooth) or with the Bluos app. Unfortunately, Roon is currently unusable.

1 Like

Glad I’m not alone. I also experienced this issue when I recently connected my Ferrum Erco through the Bluesound Node (N130) USB output (Audioquest Cinnamon USB-A to C cable). Again, reverting back to BluOS completely eliminates this issue, which is not ideal as I love Roon’s interface and how it manages my library effortlessly, not to mention having bought a lifetime subscription.

The take home message from the other thread is that perhaps when both Roon and the Node are watching the same shared folder on my NAS that creates some sort of data bottleneck when trying to output through USB? That might explain why the issue is worse when playing my FLAC files, although Tidal streaming through Roon also runs into the same issue albeit more intermittently than physical files.

1 Like

I’ve been experiencing the same “popping” noise and I can confirm I have not configured a watched folder from the same directory my Roon server is pulling from. Though that’s not to say it’s not part of the issue with other users.

I have the USB “dropout” issue which only occurs when using Roon. BlueSound told me that they are working on this issue and I should contact Roon too.

Using the BlueSound UI works perfectly.


Does anyone know if Roon has captured this bug fix in their last update?

It’s a bluesound issue to solve.


Hi All,

I checked with the team regarding this issue and as @ged_hickman1 and @Baat_Karlo mentioned, Bluesound is aware and working on this issue. For the latest status updates regarding this issue, please reach out directly to them, thanks!

1 Like

mactopia i read the same, regardless this is both a roon and bluesound issue. roon lists the node as roon ready, so it is their reputation on the line as they are staking the claim. i too dropped my roon subscription as it seems have others, will keep node as it seems at least that team is trying to move their product forward. for me, not interested in paying for a pretty ui when sound quality and compatibility does not seem to be a priority. the node is not some esoteric product but one of the most popular streamers on the market. the roon team listing the node as roon ready does not reflect well on their attention to detail or rigor of their compatibility check.

I fully agree :+1:

I followed your advise and checked with Bluesound support and they advised a few settings (which didn’t solve the issue) after which they advised to:

“ If you still encounter audio dropouts, use USB DAC implementation natively without ROON and reach out to ROON directly for further assistance.”

so back to Roon support again……any advise?

@ged_hickman1 just helpfully directed me to this thread after reading this post of mine on what seems to be the same issue.

I feel like the problem might have started when I updated my Node 2i streamers to the latest BluOS version. Does anyone know if it is possible to roll back to a previous version of BluOS? If so, has anyone tried this as a potential solution?

Hi All,

After very helpful advice from Kyle of BluOS Support to do a reboot of all of my Node 2i players, the playback distortion issue that I was experiencing is now gone. He also noticed some errors that I was getting because I had moved a network share folder that contained part of music library, but I do not think this was related to the distortion issue because I moved the network share folder long before I started getting distortion.

I have copied part of the exchange with Kyle below in case this might help anyone else who is having problems with Roon and Bluesound players.

40x40 Kyle F. - BluOS Support Specialist Level 2 (Bluesound)

Sep 7, 2022, 3:08 PM EDT
I would like to request you to do the following;

1. Upon disconnecting the network share, wait 1 minute and disconnect the power of each Bluesound player you have(ensure all players aren’t grouped with each other when you do this)
2. Ensure you also unplug the router from the power and re-connect it
3. When all players have been disconnected from the power and re-connected - including the router… try playing Roon to each player individually*(do not group them for this test)***
4. Verify if the same issue occurs while playing Roon to each player individually, with MQA and without
5. Once you do this on each player, submit another support request as you did previously - do not group the players at any point through the above

See below for part of Kyle’s reply after I told him that I was no longer experiencing distortion after a reboot. Kyle also asked if I was getting the problem when playing MQA content, hence the reference to that in his reply.

I am glad the simple reboot on the players and router at the very least has alleviated the issue you were experiencing.
It’s good to know about the lack of MQA playback, which means it’s primarily on FLAC files where you were experiencing the issue originally.
I don’t know for sure if I could be considered to have resolved the problem, as a simple reboot is just that after-all.
Hopefully the reboot continues to allow the system to be stable for you(which essentially re-synced all the Bluesound players onto the network) but there’s a chance it may return(but that’s just me being proactive to be ready if it does).
On the topic of other users, our stance remains the same and that is to contact us directly so we can try to help(same way I have helped you and will continue to do so).
Be aware however, that all these users who are reporting the behavior - may have other factors that are causing issues(could even be user error or external equipment) which happens more often than you likely think in our line of work but could also be completely different problems that are being described the same way(that happens too).

Will be interested in hearing if this solves the problem for others as well.

1 Like

The problem with the network drive was in BluOS where it was added as a network share that I never used. I use the network drive with Roon constantly. I can see how that was not clear.