Streaming issues - both Tidal and internet radio



I have tried everything but nothing seems to cure my streaming woes. Utterly disillusioned with Roon. My Sonos - rock solid. My yamaha musicast - rock solid.

Roon used to be, but now it;s terrible. For the service i pay the most for, this is inexcusable.

I have tried the google DNS trick, tried clearing the cache, tried logging out of TIdal and relogging in . tried rebooting everything.

I have an core i5 ASUS all-in-one running the core, into an allo digione into a Schiit bifrost mulitbit. I use Netgear Orbi, but the digione is wired into the orbi router. I am in HK with 500MB optical fibre broadband. I have no issues with any other streaming services. I stream 4k movies etc on apple tv without issue.

I get the tidal is loading slowly message constantly but erratically. sometimes it works for 20+ minutes, sometimes it stops after only a minute or two. LIkewise with internet radio services like radio paradise - although i get no error message - just silence.

Please help . I love Roon but I am going to cancel because this is an issue which is ruining my experience.

Bump to the top

Hi Lyndon,

Support will see your post and pop in soon. How is the Core connected to the network ?

I apologize for the difficulties you’re experiencing here, @Lyndon_Reid!

To get a better idea of what may be going on, may I kindly ask that you please provide a brief description of your current setup using this link as a guide.

In particular I’m interested in your network configuration/topology, including any networking hardware currently in use, so I can have a clear understanding of how your devices are communicating.

Can I also ask that you please verify the following:

  • You mentioned that Roon used to work great - When did you start experiencing this behavior? Have there been any changes to your setup since noticing this? Any new devices on the network, or software that may utilize the network (VoIP, AV, etc)?
  • Have you tried rebooting your Core machine, endpoints, and networking hardware?
  • Are you experiencing this for all endpoints? If you play to System Output on the Core machine do you still experience this behavior?
  • Just to confirm, local files are always playing just fine?

Thank you,

Lyndon, I have a similar setup (Digione and Yggy) and it too had dropouts. Starting with v1.5, these have become a thing of the past for me with Roon’s auto-configuring of EndPoints. My only added setting was to add 100ms delay for the Yggy to switch gears if playing different quality tracks. Here are my settings FYI:

and the advanced stuff:

Hang in there!

PS: One last ‘hail mary’ thought: log out of and in to TIDAL from Roon.

1 Like

Hi Dylan,

Thanks for the reply,

I started experiencing the drop outs after the recent Roon upgrade. No significant changes to the network set up or devices on the network.
I have tried rebooting everything! Multiple times. I also put a new iFi power supply on the digione and switched from volumio to Ropieee.
It does happen across different endpoints; but i need to check on whether it happens with system output on the core machine and get back to you.
Yep, local files from my NAS play fine.

As for network topology, I use an Orbi router wired to an optical fibre modem. I have 2 orbi satellites. The roon core machine is wired to one of the satellites (which is line of sight about 30-40 feet from the orbi base). The digione is wired to the orbi base station.

Hope that all helps…

Hey John,

Really appreciate your reply. Thanks!!

My drop outs seem to have started with v1.5…
I added 500ms of delay; but might try 100ms just to see if that makes a difference.

I’ve also put in some buffer in the “buffer size” advanced setting.

Also tried logging in and out of TIDAL from Roon.

Thanks again for the advice!!

The signal always goes through the Core. With the topology you describe the streaming signal comes in the Modem, then by Ethernet to the Orbis router, WiFi to the satellite, Ethernet to the Core, Ethernet from the Core, WiFi to the router then Ethernet to the DigiOne.

The full duplex WiFi leg is the main suspect. What happens if you connect the Core by Ethernet to the router ?

Ultimately I would recommend using WiFi for control signals only or, at most, a single one directional signal leg.

1 Like

Hi Andrew,

I suspect you might be right.

But as a point of comparison (and maybe a little bit rhetorically), can I ask why it might be that only Roon experiences this issue? I stream Tidal to a Yamaha soundbar (via its MusicCast app), a Sonos playbar all wirelessly and all with out dropouts. I also stream 4K video using an appleTV, again, without issue.

I will definitely try connecting the core by ethernet - but that’s not really a sustainable solution…

Thanks very much for the suggestion!

At least some of those other solutions use casting, where the end device pulls the content directly from the Internet. You can shut down the initial control device after casting is established and playback will continue because the signal is not going through the control device. Roon is different, the signal always goes through the Core.

If it’s not viable to connect the existing Core to the router by Ethernet, then it may be that a NUC running ROCK which can hang off the router would be a good solution.


One very long ethernet cable later and it seems that not having the Core connected by cable to the router is the issue.

Is this a known issue with the Orbi system, or endemic to wi-fi connected Cores?

I really don’t want to have to invest in an NUC or similar solution - is there anything else i can do?

Hey @Lyndon_Reid,

Thanks for the update! Glad to hear that the Ethernet cable did the trick.

You’ll definitely get the best performance out by ensuring that your Core utilizes a wired connection. That said, there is one thing you can try with the Orbi router to see if the experience improves:

In your Orbi router settings, you should see a checkbox for Disable IGMP Proxying. Can you confirm what the current status of this checkbox is? If it is checked, does unchecking it change the behavior you’re seeing at all? In the past we’ve seen that unchecking this can sometimes help.


WiFi is only half duplex and has other practical issues. Expecting full duplex in real time from a WiFi leg is always likely to disappoint. Ethernet is full duplex.

Can you alter the connection point to the optical fibre to be closer to your Core ? If so you could exchange the positions of router and satellite, leaving you with a single directional WiFi leg which is more likely to be OK.


thanks Dylan and Andrew, i had thought Dylan’s tip had solved the issue. but just had another drop out…

So i guess finding a wired solution it is going to have to be…

Thanks again for your help and advice