Stuck Spinning Circle - Metadata Improver error message

I’m seeing the same error today. Not sure if it’s related to my recently updated to build 710.
I’m using Roon on Mac with Nuclueus+.
Adding album from Qobuz and Tidal all went into the same problem.


The Roon @support team prefer one topic per customer’s issue… so they are able to track it and focus on each individual problem. hence I split out your topic.

In order for Roon’s @support team to better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so they can have a clear understanding of how your devices are communicating.

Typically that message persists when Roon can’t reach their backend services … I’d suggest a full reboot of your network gear and the Roon core.

If that does not work, I’m out of suggestions and Roon’s @support will have to looked deeper.

I think I have solved the problem. Here’s what I did and it might help other people with similar issue.

tl;dr - I removed the “Scheduled Backups” and restart Roon server.

Below is a detailed description of the problem and what I tried to recover it:
My setup: Roon Mac App and Nucleus+

  1. About a week ago the Mac app was updated to build 710, the Nucleus+ was still on an older build
  2. My “Scheduled Backups” was configured to backup to Dropbox. I got a mail that my Dropbox was running out of space so I reduced the “number of backups to keep” to 5. (from the default 10)
  3. After a day or so the Nucleus+ was also updated to build 710
  4. This is when the exclamation mark showed up and saying the Metadata Improver error message. Stuck in spinning circle after adding albums. (either from Qobuz or Tidal) I was able to play the music but the album artwork didn’t show up.
  5. Restarted Nucleus+ and Mac App and even my Mac multiple times didn’t help.
  6. I was able to manually identify the album and the artwork showed up but it still stuck in spinning circle. The only way to stop the spinning circle is to remove the album.
  7. I did a manual backup and then deleted the “Scheduled Backups” setting. Restarted Nucleus+.
  8. The exclamation mark and error message disappeared!
  9. Tried adding a few albums and didn’t stuck in spinning circle.

It’s worth trying to remove the backup setting (although cumbersome) but remember to do a manual backup first!

1 Like

Hello @Ching-yun_Chen, and thanks for the detailed steps! Please let me know if the issue returns.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.