Stuttering and trouble recognizing dac

Roon Core Machine

Running on my unRAID server

Networking Gear & Setup Details

Unifi ultimate dream machine with various APs. Bluesound Node connected through WiFi.

Connected Audio Devices

Most recent Bluesound Node streaming to Gustard x16 through USB to Schiit Freya+ through balanced xlr to emotiva amp

Number of Tracks in Library

Streaming Qobuz only, no local files

Description of Issue

I am having a relatively constant stuttering problem when I’m playing music through Roon, while playing the same streaming service directly through the Bluesound app doesn’t have the same problem. The songs will play great for a bit, then get choppy. I’m sure it has to do with how Roon sees my setup, but after messing around with all of the settings I can find, no change to the stutter through Roon. When I check my signal path, it shows the Node, but no sign of my connected dac. I’m assuming that has something to do with my stutter. How can I have the dac appear in Roon so that I can adjust its settings? Any ideas would be helpful. Thank you!

Does the stutter also happen when on LAN cable?

I can’t see the DAC in the Roon Ready list. So Roon will see the Bluesound only.

Roon will only report back Roon Ready and in some cases Roon Tested devices

Hasn’t there been reports of the Bluesound node having problems on WiFi. The Bluesound app is probably passing a lot less data than Roon hence the no problem

Try a LAN cable to eliminate WiFi?

This is a great idea. I don’t have a long enough cable to test this due to placement in the room, but Amazon will be delivering soon.

I was going it was a setting mainly because there aren’t any network jacks anywhere close, but I bought a longer cable so I can test this out.

Even though it’s the same streamer and the same streaming service, the Bluesound app passes along less data? That’s very interesting. The Bluesound has been frustrating since moving it to a different position but after giving the forums and reading about other’s experiences I’ve found the correct (and rather hidden/specific) settings to get smooth playback from the app. It will be nice if the lan connection resolves the problem, but I’ll be pretty disappointed at that price point that the WiFi circuitry isn’t capable.

Thanks for your response.

Most likely the Bluesound device pulls the data as FLAC and decodes it on the device. Roon decodes it on the Core and sends the decoded PCM samples over its RAAT protocol, so that’s 40% more local traffic right there. The way Roon does it has several advantages, such as endpoints needing very little computing power and requiring no support for audio decoding on the endpoint, and making it more future-proof when new audio codecs are developed, but at the price of higher local bandwidth.

In addition, RAAT guarantees synchronized multiroom audio between Roon Ready devices made by different manufacturers, and to do this it needs to keep buffers small and is less resilient to variable wifi throughput rates.

Often enough, endpoints on wifi works, but if its marginal it may jump over the edge with RAAT while it still works with other protocols.

More about the RAAT design:


I tried the lan cable, but it still stutters. Really frustrating, especially with how clunky the app is. I have an old raspberry pi that I have played around with in the past and I threw roopiee on there and in five minutes I was up and running with no stutters and my DAC recognized in the signal chain in Roon. I can’t really hear a difference in the quality vs the Bluesound, am I missing anything by not pursuing this further with the Bluesound? Would there be any gains if I were to get a different streamer with less troublesome wifi? Thanks for your time in this.

Depends which RPi and how you are connecting . The Pi3 had a issue sharing “Stuff” (power supply I think) with USB and LAN that was fixed in Pi4. I ran both a Pi 3 & a Pi4 on Ropieee (both std and XL) with an Allo Digione HAT with no issues BUT I only used Ethernet. It ran COAX to a Audiolab M-DAC

The Pi’s in general are not renown for their WiFi performance. Without “Tub Thumping” if you can somehow run Ethernet it will save you a lot of frustration. Why the Bluesound should stutter on Ethernet confuses me , maybe someone can comment (How old is it can you send it back?)

In terms of SQ , well… The “Bits are Bits” advocates would say no , Its a massive and long held debate. Ropieee is built for the job as a Roon Bridge so little or no other processes to cause issues. Ethernet separates any circuit noise etc . You pay ypour money yopu take your choice. I only moved to get a better Headphone amp , I was perfectly happy with Pi4/RoPieee

Can YOU tell the difference on your system, that’s the final arbiter


I don’t understand. Doesn’t seem to be caused by the wifi?

1 Like

I am wondering if the Bluesound networking is defective ?

1 Like

The Bluesound and usb output have been problematic with Roon for some time this isn’t your DAC or network. There have been many post covering the same problem.

You won’t see the DAC in Roon via the Node as all outputs are active at once so Roon assumes you’re using the internal DAC which is how it’s tested for the main part and not via the external DAC options as it doesn’t feedback to tell Roon which output is being used. This is how BluOS have implemented it. Not sure if Roon Ready is even tested via the USB output at all especially on the older nodes it was added via a firmware update and Roon doesn’t redo the certification process again for firmware updates.

1 Like

I don’t think so. I ran an ethernet cable directly to the Node and it still stuttered. Not to mention that it automatically reverts back to WiFi when power cycled regardless of whether or not a cable is in place. I finally had to put incorrect credentials in and make sure that it didn’t have a WiFi connection when testing with the cable because the results weren’t any different. The good news is that it doesn’t skip at all when using the Bluesound app (using multiple services like Qobuz and Deezer) but with Roon it’s enough to be unusable.

I hesitate to factory reset it only because in my experience it takes an exceptional amount of effort to get the streaming services and connections setup correctly.

I found a raspberry pi 3 b+ in my junk drawer and within minutes using the same lan cable I’m using Roon without a hitch. I think I’ll probably stick with it and maybe move the Node to a secondary system or sell it.

1 Like

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.