Stuttering MQA playback - ifi zen dac - RPI 4 on Ropieee

Core Machine (Operating system/System info/Roon build number)

Dell latitude laptop with Intel Core 4th Generation i3-4010U Processor (1.7GHz, 3M cache) running Windows 1o

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Eeero Mesh wifi

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Ifi zen Dac connected to Raspberry Pi 4 2gb running Ropieee

Description Of Issue

Hi all, I just hooked an IFi Zen Dac up to a Raspberry Pi 4 2GB endpoint running Ropieee. Non MQA playback works just fine, but when the track is MQA, I am noticing several instances of stuttering per song. I didn’t notice this at all with MQA playback the same device recently using a Zorloo Ztella DAC. I already tried setting the buffer size to 500ms, but the issue persists.

Very similar setup to me. I use a Mac Mini as my core but while I don’t use it that way now, I did have my Ropieee connected to my iFi Zen DAC and it played perfectly, including MQA. Let me know if this persists for you and I’ll set up my RPi with the iFi again and test for you if you tell me which songs you’re having issues with.

Hi Michael I run the same setup on office desktop and have been running it for about 2 months without issue. It’s such a nice little DAC AMP.

What is the processor usage like when listening to MQA ? If you run task manager and have a look. That is quite an old processor so it could be worthwhile watching task manager for non MQA and MQA to see the difference.

Also are you applying and DSP or anything else while playing music that could add to the overhead?

You can also try changing the MQA capabilities option Renderer and Decoder as the iFi can do both just to see if this reduces any overhead.



Thank you, Eugene. Thanks to Michael as well. Michael, I didn’t notice an undue load on the processor with either MQA or non-MQA playback. Memory seemed pretty taxed in both situations (80+% utilization), but that hasn’t impacted non-MQA playback.

I set the Ifi Zen DAC to both render and decode and playback improved dramatically, but I also noticed that the volume knob light is now green when playing MQA tracks. That means I’m not getting MQA, right? Any idea why?

Also, what do I need to know about DSD? All I see at this point is it’s set up to convert to PCM.

Michael great news, when set to renderer and decoder Roon is passing the work onto the DAC allowing it to decode the music in its own way. I get the feeling that Roon should set that by default

I would forget about DSD for now as it is incredibly taxing on the cpu. I do sometimes do this on my Zen Dac but my i5 NUC is only just getting through the processing when set to DSD256. I do like the sound though, but I think a high end I7 required for consistent use.



You can’t set to decode and render… the iFi doesn’t decode so it’s just playing as FLAC. You need to set for render only for MQA.

1 Like

Thanks, Eugene. I noticed this as well. At this point I think it may have to do with RAM utilization. I ordered an upgrade from 4 GB DDR3L to 16 GB DDR3L. Fingers crossed.

I think it’s more CPU related than memory… I’m running on an Mac Mini, i5 with 8GB and it hums along FWIW.

What was odd to me was that when I connected the IFi Zen DAC directly to the laptop Roon core I had perfect MQA playback. I also reconnected the Zorloo Ztella to the RPI 4 running Ropieee and got perfect MQA playback. Also, on the laptop Roon core CPU usage never went above like 10% while RAM usage seemed to vary between like 60% with the Ifi Zen DAC connected directly to it and like 87% while streaming to the RPI endpoint with the IFi Zen DAC connected to the RPI.

And you’re plugged into the blue USB ports on the Raspberry Pi right? The USB 3.0 port?

I had heard previously that it was better to use the USB 2.0 ports for DACs, but that was more important when I had a usb hard drive hooked up to the RPI in a previous incarnation. If you think using the RPI’s 3.0 ports might help, I’ll certainly give it a shot.

I may be confusing myself but I seem to recall, for me… when I had it in a USB 2.0 port I had issues with MQA not working so I quickly moved over to a USB 3 port.

USB 2 or 3 should not make many differences to this I don’t believe DACs take advantage of the extra bus speed as USB audio doesnt need it. My Pi4 worked fine on both when I had Tidal.

How s the pi connected to the network, wired or wireless? What’s the signal path in Roon show your cores processing speed is? This is the important factor as mqa takes quite a lot of resources for Roon, plus network latency it can all add up to slow speed. Anything below 1.5 and your getting dangerously close to underperforming.

Does this DAC support Linux properly? I had lots of Issue with MQA and all Linux endpoints with my Ifi IDSD Nano it used to stop and dropout. They never really supported Linux properly. It only worked when I upgraded the firmware to use their GTO filter and then it would often not come on with Ropieee.

I am not sure about the Pi4, but I used an Intel NUC with the iFi, Chinese made, MQA DAC.

I have an i5 NUC running Windows 10, mainly because it was easier to download the USB DAC drivers. The iFi had a good write up in the What HiFi? (The Beano) so i thought I would give it a try, I purchased from Richer Sounds tried it for a week of so in both MQA and DSD, I have a Tidal subscription.

My network is a fully wired, apart from the Roon remote controls.

I returned the iFi Zen for a full refund, my March DAC, based on the Khandas Toneboard, can handle DSD256, sounded superior to the award winning iFi DAC. The March DAC costs £260, is USB powered, and is a marvel! It is presented in a beautiful aluminium case.

Perhaps it is the weakest link in my system, Naim 200/202/Stageline Amplification TeddyPardo power supply. Kudos KS-1 speaker cable, Kudos X3 speakers. I paid more for the speaker cable than the DAC!

I also have have a Pink Triangle turntable with a Rega RB300 arm, reworked by Audio Origami, and a Rega Elys2 cartridge.

1 Like

The issue persists even while using a USB 3.0 port on the RPI 4 running Ropieee. It also persists after upgrading the ram on the Core device from 4gb Ddr3l to 16gb Ddr3l. I will say that it seems to happen quite a bit less than before these changes. The signal processing speed showed as about 15x before and after the ram upgrade it’s showing as 30+x.

Before I tried switching to the USB 3.0 port and upgrading RAM, I had experimented with using a wire connection to the router for both the Core and the RPI 4. I didn’t notice much difference at all and maintaining a wired connection for one or both would be inconvenient at this time, though I might try it later.

Does anyone think there is anything else I can try? If not, I might just leave the core as the playback device connected directly to the Ifi Zen Dac and use the RPI in my other play location with the Zorloo Ztella DAC that continues to play nice with that device.

Do you still use Roons core MQA decoder when using the other DAC and that works ok?

Hi Euge,

I use the same Roon setup as above, core is with Roon Server on a Mac mini late 2012 (i5, 4Gb) and Rpi 4b (4Gb). Stutters like hell. Could I do something wrong in my Ropieee settings?

From what I’ve seen it’s not the Ropieee. I even tried wired gigabit Ethernet. Like I said, restarting my Roon Core fixed all issues for me.

Tnx, strange thing is that when the MQA-DECODER is disabled in Roon, it runs smoothly

The only issue I have with MQA is it won’t do gapless for live concerts and classical music… so I have Roon doing the first decode but told Roon my MQA DAC can’t do MQA (even though it can)… but that’s fine as right now I’m playing with DSD256 upsampling and MQA tracks were ignored previously, guessing due to MQA “purity” having priority over upsampling.