Suddenly lost connection with Tidal from Roon since around 28th May or since setting up a new DHCP server within my home network

I have replaced my DHCP server with a new router on 28 Tue May just to accommodate ultraRendu into my home network (which kept failing to do so with my previous DHCP server set up). I then noticed that I can’t access Tidal from within Roon. I then searched Roon Knowledge base and read every thread regarding “Tidal login problems”.

When in the “Setting”> “Services”, I tried to re-login to Tidal account, I got error message “Network error. Please check your connection”. I can play music from Tidal itself without any problem. I just can not open Tidal from within Roon.

I have tried every single method shown in these threads without sucess.

  1. Rebooting ROCK server, including reboot twice consecutively.
  2. Change DNS to Cloudfare or Google DNS
  3. Clear Cashe of Roon database, as well as clearing Tidal Cache

My setup is:

ROCK server (NUC i7) > ethernet network>Mac mini running Roon Bridge > USB connection to DAC (LKS MHDA-004)

Hope someone can show me how to work around. Tks!

Hi @Kiyoshi_Yoshida,

Would you mind if I moved this post over to the #support section of Community? Generally we try to do all of our support there since our troubleshooting can be found by others and hopefully help anyone in a similar situation in the future.

You mention that this started occurring after you added a new router to the network. What kind of router did you add?

Is there any other networking gear involved (switches, access points, etc.)?

Apologies. Pls move the thread to “Support”.

  1. I am not 100% sure of the relationship between the new router (it is Buffalo WXR-2533DHP2) and the login failure. I just have the impression that the new network configuration and the login failure happened same time.
    2)I am living in a condo with more than 120 residences. These residences are under the central router/firewall/DHCP server which is connected to the internet service owned by NTT-West Co and provided by Sui Sui Company. So every residence has one LAN cable from this central router. (By VPN software, each residence can only see devices connected within the same residence even they are under this same router.)

  2. Before the installation of WXR-2533 DHP2, this LAN cable (say “trunk line”) was then branched out to 7 LAN ports across my residence via 8 port Switch ( Buffalo LSWT-GT8NS). I am therefore relying on the DHCP server function of the central router. As my ultraRender failed to join into my network, Sonore strongly suggested my network is the problem, I decided to add my own DHCP server by first connect WXR-2533 DHP2 to the “trunk line”, and from one of the 4 LAN port of WXR-2533 DHP2 I connected existing LSWT-GT8NS. So all the devices in my home network is given IP addresses from the DHCP server of WXR-2533 DHP2 instead of central router of the whole residences. (see attached screen shot)

  3. There are no access point within my home network. I added 4 to 8 port hubs (or switches) of similar kind at the several of 7 LAN cables. For example, in my living room whrere my set my audio system, I added 8 port switche and connect all of my TV, Apple TV, Amazon Fire TV, Sony TV, Bluray recorder as well as Mac Mini, RasPi DAC, etc.

Hope above is clear to you. Thank you.

Hi @Kiyoshi_Yoshida,

Thanks for the detailed information here.

Based on the information above, it sounds like this is the case. To be sure, would it be possible to bypass the new router and connect to the network similar to how this was previously done? Confirming if this is limited to the new router will definitely be a great data point for our troubleshooting.

Just to confirm, are you able to use TIDAL outside of Roon with this new networking setup? Connecting to TIDAL via Roon is a bit different than connecting to TIDAL directly, but knowing this would be another good data point.



Under this new topology, I could play Tidal from outside of Roon (i.e. standalone). Login, play music without a fuss.

Now check if Roon can handle Tidal under previous network. > I did experiment. Here is the result.

I have rewired back to Central Router/DHCP connection.
Roon recognized my Tidal account and I can play Tidal music without any trouble.
(This seems the end of the story, but under this topology, my ultraRendu does not function, i.e. obtain local IP address from the central DHCP server, it seems.) So, I need to install my local DHCP/Router (i.e. Buffalo router WXR-2533DHP2) again and got it run Roon and Tidal from within Roon somehow.

At the moment, I don’t have an answer. Hope someone can tell me where I should look at. Tks!

Following up my struggle with this problem.

I have again rewire my Buffalo WXR-2533DHP2 Router/DHCP server back and connected ROCK and other devices under this device.

For no reason, Roon now recognizes Tidal from inside and I can now play Tidal tracks from it! I did not change any setting except ROCK’s IP address setting (from static IP to DHCP). When I could not connect Tidal from within Roon, I set this as “static IP” so that I can control from my Mac or iPad easily. This might have caused the problem. I can only guess.

Anyway, at the moment Roon is functioning happily as before.
So, case solved?

I think ROCK’s IP setting (static or DHCP) caused the login failure of Tidal from within Roon.

After setting ROCK’s IP setting back to static (and save>reboot/restart the ROCK), I lost login status of Tidal (error message from Roon as “log in to Tidal failed” or similar wording appeared while starting Roon.

I then set IP setting of ROCK to “DHCP” >save>reboot, then Roon can login Tidal as it did before.

Therefore, under my network setting with local DHCP server, ROCK’s IP setting should always be DHCP. (Although I do not know why.) :sweat_smile:

DHCP connected setups get their IP address from the DHCP server but typically also need to receive their DNS and Gateway information all critical for seeing the outside world and finding things inside and out.

DHCP function was always enabled even in my previous topology. Our condo’s “central router/DHCP server” assigns local IP addresses to all of my connected devices as well as other hundreds of devices connected to each one of residential units. I suspect the VPN software used to hinder network traffic from mixing some other resident’s devices with my networked devices might be causing this problem.

I will find out sometime next week whether my “local DHCP function” of “central router/DHCP function” is causing this login problem or not (as I am connecting ultraRendu to my home network as soon as it is returned from Sonore).

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.