Switching to low quality aac or mp3 causes dac to freak out

@eric any more news on this issue. Updated to the latest core tonight and it still does it :frowning:

Hi @CrystalGipsy ---- Thanks for reaching out to me and my apologies for the delay.

Continuing forward, I am curious if you had a chance to test with the DAC attached to MOCK over the weekend? If you did what was the experience like? Furthermore, being as this isn’t a Roon tested DAC I met with another support team member today to see if we could find any other reports of what the experience has been like for others using the irDACii with Linux and came across the following:

I have contacted the manufacturer but they are not familiar with the issue. According to them they have confirmed general compatibility with Linux. But they cannot guarantee compatibility with every distribution.

I don’t know what USB interface Arcam uses right now. With the first irDAC (and the DA-33) they used an interface developed by DcS. I assume they still use the same technology for the irDAC II. Since 2 weeks I have a DcS Scarlatti Clock in my main system with USB input connected to another RPi using M2P and Squeezebox. And SPDIF + Wordclock output to my DcS Puccini. This setup is rock-solid. Although a bit ridiculous to drive a EUR 35k (original price) setup with a EUR 35 piece of hardware…

Anyway, I’ve tested the irDAC once more this weekend on my system in the kitchen. Still the same result: after 7 hours I heard only crackling noises. After a ‚kill‘ (shutdown didn’t work) and a restart of Squeezelite, it worked properly again.

I have given up on this setup for my system in the kitchen and moved back to the Allo BOSS DAC. The Arcan irDAC is now running (without a glitch) in my daughters macbook based setup.

Not to be overly presumptuous but it seems like others maybe having some issues with the DAC under Linux as well. As such are you able to also confirm how other application handle sample rate switching with the DAC?


I will try using MPD or squeezelite on the Allo and see if that works ok. I must admit I was using upampling for a while so this might well have masked this particular issue and it’s only when using radio I get the upsampled aac or MP3 as I don’t tend to use them much these days. Also will try with internet radio as that also upsamles these days. I will also try a raspberry Pi running Ropieee and see if that works.

If none succeed then will look to return to upsampling. Or swap the DAC but I really like the sound it puts out.

1 Like

Thinking about this Eric I cant test this out on any other app as its only Roon performing upsampling to 24bit on all lowres files 44.1khz files I don’t have any 24bit 44.1 files. So this is a pointless exercise. As I have explained its only switching from from 44.1 16bit to 44.1 24bit that is the issue. I guess I will have to try my core instead or RPI.

Ok can confirm the same issue is present using a Raspberry Pi with Ropieee. So its not the USBridge either ALsa or Linux and the DAC.

@eric i have just got round to testing this with another player. I created a 44.1khz 24bit file using ffmpeg from an aac that Roon has issue with when switching from 44.1kh 16bit flac. . I then tried this in MPDplaying a 16bit source then the 24bit upsampled file and there is no issues with MPD switching sample rates. Roon still makes my DAC fall over when playing it. So this does look like it’s Roon related and not my DAC or at least some compatibility with Roon and my DAC. I am not the only one experiencing this either and this is a different DAC.

1 Like

Thank you for the feedback and sharing the results of the mentioned testing, @CrystalGipsy . The additional feedback is very appreciated!

Moving froward, I would like to enable diagnostics on your account so we can have a closer look into this behavior. However before I enable this feature may I very kindly ask you to please reproduce the issue and note the time that it occurred along with what track/album was being played.


Thanks @eric for following up so soon. I just had the issue 22.33 GMT on zone Dining Room playing FLAC Sufjan Stevens - Concerning the UFO sighting near Highland, Illinois skipped to play aac track The National - Beautiful Head. DAC’s lost sync and locked up. Allo still shows the output to be of Alsa to be

access: RW_INTERLEAVED | format: S32_LE | subformat: STD | channels: 2 | rate: 44100 (44100/1) | period_size: 882 | buffer_size: 1764

repeated at 22.40pm GMT

Hi @CrystalGipsy ---- Thanks for the follow up! I just tried to enable diagnostics and it looks like the request failed almost immediately. Is the core machine currently active?


yes i am playing music in another zone at the moment.

Wondering if your accessing the correct account? I asked for all of them to be merged to the one my subs under as I had a few trials before I went full Roon. Its most likely on this email [personal information removed by support]

Thanks for touching base with me @CrystalGipsy, appreciated! Before enabling I checked to make sure I had the correct account and I had the mentioned e-mail address “on file”.

I have went ahead an re-enabled the request and it looks like it’s being processed. I am going to check our serves in a bit to confirm that the request has been fulfilled.


Hi @CrystalGipsy ---- I wanted to touch base because I checked our servers this morning when I got to my desk and the diagnostics report did not arrive :dizzy_face::thinking:

In light of this may I very kindly ask you to please send us over a set of your Roon logs from the device hosting your core using the instructions found here. Please provide a download link to retrieve the logs in a PM addressed to me.


Hi Eric I’ll do that when I’m home from work.

1 Like

@eric just messaged you the logs

1 Like

Hi @CrystalGipsy ---- Thank you for the follow up and PM. Very appreciated!

I just checked the package and you actually had provided me with the RAATServer logs. May I kindly ask you to send me over your “Roon” logs from your core machine? Thanks!


Oops. Resent

Thanks @CrystalGipsy, very appreciated! Confirming that the updated set of logs has been received for analysis.


HI @eric any progress in isolating this issue. Would really like to not have to use upsampling as Roon sounds better without it in to this DAC.

Hi @CrystalGipsy ---- Thank you for your patience here!

I wanted to touch base with you because we are going to reach out to Arcam to see what we can do to get one of these devices in house for testing. In order for us to properly evaluate this behavior we will need to make it reproducible in our QA environments and having the gear in front of us will be the first step to that.

Again, your continued patience is very appreciated!