Sync Gap Issue Between AirPlay 1 and AirPlay 2 Speakers in Roon Update [Investigating]

What’s happening?

· I'm having trouble with my DAC, speakers, streamer, etc.

What best describes the issue with your audio device?

· Other

Describe the issue

With the recent update to airplay 2 my older speakers which only have airplay 1 do not sync with the newer speaker that has airplay 2 capability when they are grouped together. There is a roughly 1 sec gap between music playing through the speakers when they are grouped together. This was not an issue before the airplay 2 update in roon came out

Describe your network setup

Roon core on laptop.
Sonos move 2 speaker (airplay 2 capability)
Yamaha NX N500 speakers (airplay 1 capability)
Bluesound pulse flex 2i (airplay 1 capability)
System connected via wifi.

Same here. But delay is between a venerable Arcam Airdac (using airplay1) and a stereo pair of Sonos One’s also using airplay?2. This worked flawlessly until the newest update. This problem does not exist when I use TuneBlade which continues to work without any delays/ issue. Please fix! Very frustrating that a new feature should break a previously very stable system.

Same issue here, again.

Between AudioPro and an older Pioneer. AirPlay2 and AirPlay1

Unlistenable.

The previous version solved the last sync issue, but now it is back.

Edit: the AirPlay1 Pioneer does not switch on/wake-up anymore when asked to by roon. It does play when selected manually.

+1

1st gen Zeppelin Air AirPlay with Home Pods / Naim AirPlay2

Have you added your Zeppelin to Apple Home app? My Naim gear wasn’t working after the last update. It was recommended I add my devices to Apple Home and it worked resolving my non-playback problem.

No guarantees but it’s worth a try…

What best describes your playback issue?

· Other

Is there a specific error message you see? If so, please select from the following options:

· "Roon lost control of audio device"

Please try to reboot your Roon Server and check to see if this helps.

· Rebooting my Server had no effect, the issue remains

Please try to reboot and unplug/replug in your affected audio device and check to see if this helps.

· Rebooting and unplugging/replugging my audio device, the issue remains

Please open your Roon Remote and select the "System Output" Zone and try to play to it. Do you encounter any playback errors with this Zone?

· Playback *errors for both* my other zone and when I play to System Output as well

Please try fully rebooting your network equipment

· No, I'm still having trouble

An issue with playback on System Output and another zone often indicates a network security problem. *Check your firewall(s)* to ensure that *Roon*, *RoonServer *and *RAATServer* are allowed to properly communicate

· I'm still having problems / This isn't relevant to me

Does the issue happen with local library music, streaming service music, or both?

· Both local and streaming content are affected

Please try playing content of a lower sample rate (44.1kHz or 48kHz). Do you still have the same issue?

· No, lower sample rates are still affected

What is the model/manufacturer of the affected audio device(s) and the connection type?

· Sonos1s, Sonos 5s, Sonos Move 1s & 2s, Symfonisk Frames Wireless

Describe the issue

The utility company replaced my electrical meter, the service kicked everything off. Now Roon will not airplay to sonos where it was happily rolling along previously. I have a Intel 11 NUC as my Core, Asus 11,000 Router, Fiber 1G, all sonos 2 ready speakers, have removed firewalls, etc... Also the one Sonos speaker showed up as a Roon Ready Device that was previously just a net work device and when I request the system to find my Roon Core, it just rotates around and around. At this point I am a tad bit frustrated because as we all know sonos is a tad bit mess up. I am still using the old android S2 app on all of my devices just for that reason. Thank you for your assistance in advance. Roxie/Mary

Describe your network setup

LAN thru Switch to NUC ASUS 11,000 Router, Nokia ONT, Home Asstant connected to same router switch (no wired connections to sonos)

Hi @Roxie_Muzic,

Thank you for the report. We’re investigating Airplay sync issues and potential regressions with Airplay-1 devices with Roon. I’d first restart RoonServer and try adding any Airplay 1 devices to the Apple Home app. This might help around in the short term while the Roon team investigates a more permanent solution.

What’s happening?

· Something else

How can we help?

· None of the above

Other options

· Other

Describe the issue

Re Roon 2.0 build 1432
I installed the new build update about a week ago and it created a sync issue.
I use a combination of Airplay 1 and 2 speakers. My 2 speakers are on WiFi and all others are Ethernet.
Since the update, the Airplay 2.0 speakers on WiFi are out of sync with the other speakers. Nothing else at changed but the build and it immediately started the sync issue.
This happened once a while back and you came out with a new build that installed and fixed the issue. Not sure if you are already aware of the problem.
Thank you

Describe your network setup

I use a Cisco RV345P router with NETGEAR Wireless Access Point (WAX630EP) - WiFi 6E Tri-Band AXE7800. Server is a Mac Mini on Ethernet

Hi @PixelPopper Thank you for the tip unfortunately, my Zeppelin must be too old as there is no way to add it to Apple Home app I can add my Naim on which I did, but this made no difference, was definitely worth a try, Thank you :+1:

There are mixed reports on the success of the “work around” but the support team are investigating the issue but are on a public holiday and recommencing next Monday…

1 Like

Hi everyone,

Sync issues between Airplay 1 and Airplay 2 are very likely a separate failure mechanism from the issue affecting playback on first-generation Naim devices.

We’re tracking this issue with an independent investigation and will post updates here. You can expect a broad constellation of Airplay-related improvements and corrections in the upcoming several releases.

The sync-issue was already addressed around release 14 or somewhat around this number. (I’m now on 36)

I was asked to switch to early access and there was no problem anymore, at least with my setup. But now it’s back.

So pls do what you did before.

I’m using this part of the audio for daily use in a big open space. Out of sync is going to cost me my marriage. :wink: