Synology SPK-Package: Development

@rovinggecko’s issue should be solved now. I adjusted one line and updated the spk-file.
The link is back in post #159.

1 Like

Super !

Works perfectly, now also with a USB DAC on the Synology :slight_smile:

Thank you.

Unclear about something,

If I attach an external drive (something fast like an external ssd drive), can I store the roon database there? I would assume that you first install the external drive (which creates a new volume) and create the roonserver share folder there.

Will this result in a faster experience rather than storing the roonserver share on the RAID volume.

One other question-- where does the roon server installation go? Does this stay on the original RAID volume?

I also have all my music on this same NAS, in the original RAID volume. How does this impact the installation process?

Hi steveoat87,
The package will still be installed on an internal volume (due to restrictions in the dsm).
When RoonServer is launched it will look on all volumes for the folder “RoonServer” and will use it for its data storage (meta-info, logs, audio setup).
If you would like to use an external drive or ssd it should be setup for Synology first. (I can’t give accurate steps at the moment as I am currently on vacation and not able to connect a drive to my Synology).
However the share (in the dsm “shared folder” config) has to be renamed to RoonServer.

You could also add music to that external drive, but the path is more complex than on a regular volume. In roon you have to enter something like /volumeUSB/usbshare/FolderWithYourMusicFiles.(I have to look it up later on my laptop. I currently just have my smartphone here.)

So in general: RoonServer binaries have to stay on an internal volume, RoonServerData can be located on any volume and the music files as well.

I can’t say anything about performance yet. Hopefully other users with bigger libraries can tell more about it.

Hi Chris,

What a wonderful help your package is and what a great job you’ve done so far. Many thanks, much appreciated!

One question:
I’ve installed the previous version of the SPK on my NAS, and I cannot access the Roon database directly as I assume it still is located in /var/packages.
The new SPK allows to create a shared folder RoonServer where the database lives. I would like to do this, but how’s about the existing database? How can I move it to the new share correctly? And after it’s moved, will the new SPK recognize it as existing?

Again thanks so much.


When you have the previous version installed, you can click on “uninstall” in the package center and you will be asked for an export location. Enter your export location as you did in the import window. (e.g. /volume1/music ).
If you already have created the RoonServer share, you can also use it as an export location (/volume1/RoonServer - if it has been created on volume1).
A new folder should be created called Roon_Database_DATE_TIME. Copy the contents of this directory (2 folders should be in there) to the root directory of the RoonServer share.

1 Like

I tried running the synology package on my 415+ with 2 GB RAM, using the RAID configuration (NAS drives).

I have a very large collection (over 15,000 albums) and wanted to assess the experience.

In short, it was not good. The package ran fine, but was incredibly slow to create the database. I ended the experiment before the database was 5% complete,since it was taking forever for the database to build.

I also had difficulty having HQ player run consistently.

So the package does work, but at this time, it is probably only for much smaller libraries.

Building the database is the part that needs the horsepower. And playing while it builds could suffer from it on a low end box.
Just curious, do you already have a database build on a different machine?
You could try to copy that over and see how that runs. Would expect the experience to be better.

Worked like charm.
Vielen Dank!

So I just updated to the latest spk from @crieke (link in post #159)

Everything went fine, picked up my backed up RoonServer files, no hiccups.

Has anyone managed to get Roon Core on the Synology detect a DAC connected directly to a USB port on the Synology? Audiostation detects my Oppo without issue, but Roon can’t seem to find it. Any ideas?

Is just the oppo device not working or all connected DAC?

I don’t have any other DACs, just the Oppo.

Control Panel on Synology shows “EXTERNAL DEVICES > USB Audio > OPPO USB AUDIO 2.0 DAC - OPPO”

Just to share my impressions with a Synology DS415+:

I have ~3.800 albums on this device. The initial scan only took a few hours.
The background analysis did 25% within the first 2-3 days.

All music is played on a small Windows PC (ASRock Q1900TM-ITX) running HQPlayer.
There is (even using a single core, no multicore) no shuttering at all.
All music is upsampled to DSD128 and passed to a Resonessence Concero HP.

This combination is perfectly fitting my needs for a secondary installation (at work).

What user does Roon run as in DSM?

Roon is running currently with root privileges. This is actually not DSM specific. On linux the system-service is also setup as root.


Please excuse my ignorance, I have a synology 1813+, if i install Roon Server from the SDK package, will I have to manually reinstall whenever their is an update, or will Roon Server (Linux) automatically handle that?

The updates will be handled by Roon Server itself. It should update on the synology like on any other computer.

The only reason for uninstalling and reinstalling on the synology, was due to changes in the structure of the spk file. When all things are set (location of the RoonData, etc. ) there is no need anymore to uninstall/reinstall the spk. And at the moment I don’t see any flaws that needs to be changed. :slight_smile:

Thanks @crieke

So the issue with Roon not being able to read the iTunes XML and/or the iTunes media shouldn’t be an issue with privileges then.

I don’t think it is a privilege issue as the same error also occurs on other linux distributions. (I have tested debian and read about a user having that issue with ubuntu)