Systematic sample rate conversion to 48khz on Merging HAPI

Hello,

I’m hoping to get some advice from an audio engineer.
My system is iMac 27" (2014) / OS 10.14.6 / Ethernet link to MERGING HAPI RAVENNA (AES67).

I do not understand the settings to be affected with this HAPI: if I read a source in HiRes (24-192 Khz or less), the signal path makes me a conversion always in 48 Khz. I tried all possible settings (including: no setting at all) and it doesn’t change anything. Normally the HAPI receives and reads all sources. Why this systematic conversion which reduces the quality of my signal and the quality of the audio?

I specify that I listen on a professional system of very high level (quality of amplifications of a professional recording studio) and that this problem is very embarrassing for me.

Thank you for your precise help on this problem.

Check that no DSP is enabled in Roon and the sample rates are correct in the device settings

Hi Dude ! (Thanks)

No DSP Settings at all.
Sample rates conversion doesn’t go up more than 48 Khz (in “Personnalized”). I am sorry I am french, we don’t have the same screen.

The other one is under device settings >> advanced, where you can set the max bit and sample rate. Normally if Roon recognises the device it will set these but sometimes doesn’t

I have no settings available in this “advanced” part.

Maybe should I disconnect ROON and re-install it ?

that’s weird, looks like that device isn’t Roon ready or tested so may not be working correctly.

You could have a look at the RAATServer log file to see what handshaking or negotiation of rates is going on between Roon and the HAPI.

Think the log file should be in the Library folder on a Mac.

Actually the handshaking may be in the ROONServer logs so check those as well.

And what do i do ? :slight_smile:

TBH I have no idea, not the layout I was expecting to see, I was expecting to see two folders called ROONServer and RAATServer and in each of them would be a log folder.

I don’t use Roon on a Mac so it may be worth waiting for a Mac user to chip in.

Thanks for the help. I did a search for RAAT and ROONServer files. The computer does not find them. Have a nice day :slight_smile:

Think I’ve twigged it.

Open finder and then make sure you hold the ‘option’ key and select the Go menu and select Library.

You should then be able to see a folder for Roon and RAATServer, I guess the ROONServer log is in the Roon folder on a Mac called Roon_Log.txt

image

Thats’ right.

Should I use the terminal using this command

?

Does this device use the Merging ASIO driver? If so doesn’t the driver configuration drive the conversion and mapping?

What is the ASIO pilot ? :frowning:

Hapi user’s manual says that ASIO is for Windows. MacIntosh is Core Audio.

Post a screenshot of your signal path when you are playing one of these files that might help us see where the problem is.

1 Like

This conversion is to do the volume leveling. Turn that off and the files should be passed thorough with no conversion.

Thank you @philr, but how to do that ? I never used such a volume level. Where is it ? :slight_smile:

Sorry, I found it and dit it. It changes nothing about the sample rate conversion. See above :