The randomising of tracks does not stay turned om

Hardly a big issue compared to the issues some people are having, but anyone else have this issue.

I usually randomise tracks when playing an album or playlist

Something like (from Roon 1.8 (Build 880) is Live!)?

Improvements and Bug Fixes for Build 880:

  • Play Now / Play From here actions disable shuffle

If yes, then it looks like it’s intentional.


Thanks for the post. This is a shame for me as I use shuffle all of the time, except when listening to an album for the first time

Does this mean that I can only randomise playback of tracks after I have hit the play button ?

If it is then this is a backward step for me

One of the recurring support issues on the forum is shuffle being on and it’s setting per zone. I think this is a lowest common denominator decision by roon to reduce the support burden.
Those who understand roon and shuffle can cope with it being off, those who don’t can’t get confused by its vagaries.

Yeah I understand.
However am I right in assuming I can only shuffle the tracks of an album or playlist after it has started? Or am I missing something here?

If this is true then as I say that is a disappointment for me. An update that takes away a feature I use 90% of the time I play music.
I know they cant please everyone but this seems a strange decision to me

No I think you can enable shuffle on the play now button in the play action settings for album and playlist.

1 Like

Yes thank you, I have enabled this in the settings.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.