The Roon Experience on iPadOS

Not sure if this is the same for everyone else?

This is really painful.

3 Likes

It seems to me that your iPad is falling asleep after 15 seconds or so. If you wake up the iPad again Roon Remote restarts. The solution here is to keep the iPad awake.

Huh? What a bizarre message. If I wanted the screen to stay on, it would be, but why would I want to do that?

The issue is that it takes Roon 30 seconds to go back to the screen it was on when I turned the screen off.

The same issue if I use another app on my iPad Pro and/or iPhone 12, and then come back to Roon. It’s shocking!

@Akerow, no thanks for thinking along.

1 Like

I get similar behaviour, not always as bad. If I return to the Roon app from others I can get

a) The Roon app just crashes
b) a jellyfish, some flashing, and the screen I left - 5 or 10 seconds delay
c) a similar experience to the o/p with the “taking time to connect to the core”message

iPad 10.5” pro, 256Gb

Your remote/iPad is losing connection to the network/core, and it’s having problems reconnecting, which is why you are seeing that message.

I would look at your network as the first probable culprit. There’s some instability somewhere.

1 Like

Just tested it, normally I use my Tablet only for Roon menus, lyrics and control:

No problem at all when I play Roon music on my old iPad12
(Roon/Rock core 806 on NUC, tablet iOS14.6 + Roon 806, wifi)

I can switch off the iPad screen and my long Tidal playlist continues to play on the iPad…

As so often in these forums I presume that you have wifi network issues: when I had wifi problems, I replaced the old wifi router from my provider with a more modern but still modest tp-link ac3150…

On my kitchen table I normally choose music on my iPAD or iPhone and let Roon/Rock play as background music via an old and simple RasberryPi2B + RoPieeeXL + Wifi + first generation dragonfly + KEF MUO (that last one bought as a bargain, but great kitchen sound!)

I don’t often see the message. But I often experience a crash or a jellyfish and some flashing. Since in many cases I am using my iPad before switching to the Roon app surely I would notice if it lost connection to my network. And since my music is streaming from Qobuz surely I would notice it if my core lost connection to my network. Why would my network choose just the moment I went into the Roon app to be unstable?

When you wake the iPad from sleep, it then reconnects to your network and the Roon core. This should be almost instantaneous.

If your remote is having problems reconnecting to your network/Roon core on ‘wake’, then there is a problem with your network.

1 Like

My iPad does reconnect instantly to my network. My streamed music plays without interruption. The issues I get with the slowness of the Roon app often occur when I am already using my iPad and switch to the app and when music is playing. Why would my network choose just the moment I flipped to the Roon app to misbehave?

I’m not a network expert, but for some reason I never have that problem:

Count your blessings.

Is it ‘blessings’ or is it something that could be improved on with some effort or an alternative wireless setup? I’m an iPad Pro user and am used to seeing it hunt for Roon for a second or so but it virtually never craps out like in the first video. It simply works, so in addition to raising this perhaps adding extra information like what wireless hub is being used might be useful.

1 Like

The quality of wireless hub/router is imperative for the correct functioning of a network, IMO.

I replaced my Virgin Hub 3:

Win an ASUS RT-AC86U:

And the difference was simply night-and-day!

2 Likes

less than 3 seconds to connect to core from my 2020 iPad. As others mentioned, something is off with your network or even your core. Does your core run at very high loads?

2 Likes

I hate to say it as I know some people just do not want to hear it but it likely is network related.
Just because all other apps seem to work fine still does not mean it is fully optimized.

I use an older iPad mini4 and about one second is my delay on wakeup and I don’t believe it has ever crashed.

I put that down to my network and nothing else.

5 Likes

Have you tried turning off VPN?

1 Like

I have the same problem as well as having the history frequently disappear. Half the time Roon hangs on awake and I have to kill it and start it again. It’s especially frustrating when I want to pause music for a phone call and I have to kill, restart, wait for Roon to load and connect and then press pause. And no issues with network and I am an IT pro having worked in many data centres and on many networks over the years…

1 Like

I have no issue with the network - throughput, latency, packet loss etc
all not a problem.

But if you’re interested the router is a ASUS RT-AC5300, and I have a HP Procurve 1810G-8 network switch located at my Ropieeexl endpoint. Hard to upgrade the network without going down a Ubiquiti 10G route or something. The core is a i7 6700k overclocked at 4GHz, 32GB, M.2 SSD etc. This is a Roon issue.

It’s probably your switch that is to blame. It’s managed.

Get yourself an unmanaged switch, and you may see an improvement. So yes, it’s almost definitely your network that is the problem.