There was an error checking for an update on Silent Angel

Roon Core Machine

Silent Angel Rhein Z1 v2
VitOS 1.1.1414

Networking Gear & Setup Details

DLINK DIR825 router & ISP Modem
DLINK switches (tried to bypass by connecting Roon core directly to the router)

Connected Audio Devices

Linn Majik DS streamer
Various SONOS endpoints

Number of Tracks in Library

62.500 tracks in library

Description of Issue

Recently upgraded from Roon Core on imac to Silent Angel
imac & all end points run 1.8 build 831
Silent Angel was delivered with 1.8 build 778, tried updating before the restore but failed.
Imported my recent Roon backup and all runs fine except the fact that Roon code announces an available update, starts downloading, installing and ends with “there was an error…”)
All networking work fine, TIDAL integration works fine, streaming highres music from Synology NAS works fine, home office via VPN works fine, Netfli streaming works fine so I suspect the issue really to be in the Silent Angel / Roon core.

All Roon updates on the imac during the last 12 months were always executed perfect on the first go.

Update: just tried bypassing the DLINK router as well and connected the SA directly to a LAN port on the provider modem/router. Received an IP address, connected roon remote and retried the update…unfortunately the same result.

Found a way to get to the roon log files on the Silent Angel and found this error:

11/17 13:03:54 Trace: [base/Roon updater script stdout] Install package is at: /tmp/ee3c5b38-e8f5-4941-88c0-ac0c0de97704__RoonServer_linuxx64_100800850.tar.bz2
11/17 13:03:54 Trace: [base/Roon updater script stdout] Installing to: /mnt/RoonServer
11/17 13:03:54 Trace: [base/Roon updater script stdout] Removing any old update…
11/17 13:03:54 Trace: [base/Roon updater script stdout] Untarring new install to /mnt/RoonServer/.update.tmp
11/17 13:03:54 Trace: [base/Roon updater script stdout] ERROR: failed to mkdir /mnt/RoonServer/.update.tmp
11/17 13:03:54 Trace: [base/Roon updater script stderr] mkdir: cannot create directory ‘/mnt/RoonServer/.update.tmp’: File exists
11/17 13:03:54 Error: [appupdater] While installing update: System.Exception: update installer exited with 1

Hi @Patrick_van_Dijk and welcome to the Room forums.

These are the salient lines, it appears that it unpacks the update to a static filename /mnt/RoonServer/.update.tmp. For some reason, probably an update that failed to complete and clean up after itself, the file exists already. This should have been detected as a (fairly obvious) possible fail condition. If you can get command line access to the box then simply issuing a sudo rm -rf /mnt/RoonServer/.update.tmp should fix things.

Good luck.

2 Likes

Hmm … not so sure as the script already should do that, just without the sudo but Roon usually runs as user root anyway.

echo Removing any old update...
rm -rf "$ROOTDIR/.update"*
1 Like

And yet the error message is pretty clear that the dir is still there. You have the advantage of access to the script source? Anyhow, faced with that log it’s what I’d try first, although terminal access might not be possible. I’m not familiar with the device.

The script has to be installed with Roon so it can be executed by Roon for self-updates. So everyone with access to the Roon installation on his/her server has access to the script. It is /opt/RoonServer/start.sh on my Linux server install.

Thanks all for the first hints; I will see how I (or the shop where I bought it) can get root access. I have to say this is one of the reasons I bought this all in one solution so that I did not have to bother with all kinds of scripts and linux stuff :wink:

Hello @Patrick_van_Dijk ,

I have moved your thread to the tinkering section, please be aware that this Core is not officially supported by Roon:

Please reach out to the manufacturer for further details/troubleshooting.

All, thanks for the effort to help me out here. The distributor wiped the unit, loaded new firmware and reinstalled Roon. With this action the issue with the faulty directory is obviously gone. Restored my backup and now roon was updating to build 850….solved!

3 Likes