There was an error checking for an update response to checking for updates

Roon Core Machine

roon on docker image current version 2.0 (build 1202)

Networking Gear & Setup Details

not sure applicable here, all previous updates worked flawlessly. now, everytime i go to the About tab, it runs the “downloading…” then says: There was an error checking for an update

Connected Audio Devices

not applicable

Number of Tracks in Library

not applicable

Description of Issue

It seems the core is trying to reach out and failing to finish the downloading of meta data to determine what version I am on and the status.

If I could see the error logs, it would be helpful as something must be timing out. I do have an aggresive firewall, however, i turned off all firewall for 10 min while i tried a few times, same result. I wonder if you are attempting to hit a DNS server that is not allowed on the firewall - again, logs would be good

I did see this thread:
There was an error checking for an update problem - Support - Roon Labs Community
and you reviewed their account to see their version, can you check mine as well?

Logs should be here:

Note that there have been other Roon server-side issues this weekend, such as Roon Radio not working, maybe the error checking for an update is a server issue and will go away on its own

thank you @Suedkiez . I just tested again today and no joy… the apps will check and succeed but the server will not. I suspect its a dns issue since I control dns - I did a cursory search but did not find anything on the kb on the dns urls it calls… I do see it being a continuing issue with roon not publishing actual ports/protocols etc… it is a shame given the technology is sophisticated and networks are different.

@support - I have uploaded my raat and roon server logs folders to your file repository per the guidlines

1 Like

bumping for SUPPORT @support - still need help!

1 Like

paying customer BUMPING AGAIN for actual support!!!

We’re all paying customers. That’s why we’re here.

@Jim_F - Respectfully this wasn’t for you, it was to remind the roon support team a paying customer is STILL waiting for any acknowledgement /support…

Edit: on the other hand, if you know how to get support to actually acknowledge an open ticket, I’d love to know, I’m all eyes

Hey @patrick_mccarthy,

Thanks for your patience while we continue to work through each thread. I was able to pull your account up and I see your core is indeed on the newest build 1234.

Are you still running into issues here? If so, lets refresh your database and see how things run:

  • Make a Backup of your current RoonServer Database
  • Exit out of RoonServer
  • Navigate to your RoonServer’s Database Location
  • Find the folder that says “RoonServer”
  • Rename the “RoonServer” folder to “RoonServer_old”
  • Reinstall the RoonServer App from our Downloads Page to generate a new RoonServer folder
  • On the Roon Remotes, press “Use another Core” and connect to the new database

I’ll be on standby for your reply. :+1:

Hello @benjamin

I am on the correct build now as I completely deleted the docker image and all files then rebuilt the entire core earlier today… painful…(similar to your instructions above)

Can you please go back into the logs that I uploaded the other week and see WHAT was failing before my full rebuild today, otherwise I will be back here on your next point release… - I suspect a particular DNS call was failing (or several) and I will need to work thru my firewall rules… certainly your code is logging the fails somewhere OR I can turn on a DEBUG flag so it logs more - I recall seeing a generic error but no details (or that may have been rheos add on app).


@benjamin - Bumping for update.


Hey @patrick_mccarthy,

Our team reviewed the logs you sent over but was not able to pinpoint specifically what may have been the culprit behind the initial issue.

I’m glad to hear you’re back up and running properly! Please let me know if you have any additional questions. :+1:

@benjamin - thank you for the reply…

Can you let me know the cnames/domains its trying to hit to do the update check - it has to be a dns issue…

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.