There was an issue loading your database every few days

Pro### Roon Core Machine

SonicTransporter version 2.8
Roon Server Version: 2.0 (build 1202) production

Roon Server Database Size: 13G

Roon Server Cache Size: 922M

Networking Gear & Setup Details

eero Pro

Connected Audio Devices

Sonore Optical Rendu
Musical Fidelity M1 DAC

Number of Tracks in Library

42195 tracks
using Qobuz and local tracks on wired connected Synology NAS

Description of Issue

This looks to be identical to the issue reported in “There was an issue loading your database” issue continues thread closed in April 2022.
Every few days I get this error. The first time I restored a recent backup, but I have discovered that if I restart the SonicTransporter, normal operation is restored. It does not need to wait for the rescan, it just needs to reboot and start the service again. As far as I can tell, all the hardware seems to be functioning properly. I would dearly like to know what was done to solve @Patrick_Van_Osta problem in that thread because it was so identical.

3 posts were split to a new topic: ROCK won’t start properly - issue loading your database

I am now keeping atab open in a browser to my sonicTransporter. It had not happened for a couple of days, but then it just did. Instead of restating the sonicTransporter, I had the system restart the Roon Server, which turned out to be much faster and got me to a functioning system in a few minutes. Next time it happens, I will try to grab the log befoe I restart.
Anyone from Roon Support listening? I’m sure we’re not the only ones.

1 Like

I downloaded the log before restarting this time. While in all it is bewildering (seems to be continuously busy) it is a bit unnerving that it keeps importing music I have had for a long time and that I see dropped connections and stuff and restarting (normal?). I don’t see a way to attach the file here. How do I pass it on to the Roon support team?

Hi @Alan_Spool ,

Apologies for the slow response. I enabled diagnostics on your end and this is strange, your database seems to be running out of memory when it is not doing much activity.

I would like to ask that you send us your database so that we can pass it on to the QA team for further testing. Can you please use the below instructions to upload your database to our Database Uploader and let us know afterward? Thanks!

I uploaded a recent backup because I knew where to find that. I struggled to find the location of the working library. Where is it?
BTW I see in settings there is an option to Clean Up Library. Should I try that?
I also notice since I was just looking at it that there is a background process proceeding Background Audio Analysis and it seems to be stuck on 1086 out of 1118.

I figured out you needed to change a setting to exoose the Roon library on the SonicTransporter and I did that and have uploaded the real thing.

1 Like

Thanks for sending that over @Alan_Spool , I’ve forwarded it to the QA team to see if they can gather any useful clues from it.

In the meantime - can you please confirm, if you restore this database to a PC Roon Core, do you notice the same issue loading your database errors? Or does it only occur when the SonicTransporter is being used? To switch Cores:

  • Create a Backup of your current database
  • Open Roon on the other PC you wish to try as the Core
  • Roon Settings → General
  • Disconnect
  • On the “Choose your Core” screen, press “Use this PC”
  • If asked to Unauthorize, you can go ahead and do so. You are limited to one active Roon Core at a time but you are free to switch between them as often as you’d like
  • Verify if the same behavior occurs on the different PC

Before receiving this I decided to restore an older backup from December. I only had added items from Qobuz in the meantime and decided I ould take the loss. The backup failed for some reason. Anyway, after restoring the backup (and letting it update etc,) ny problem was solved. I may still try your advice on a different core (a macbook) just to see and to help you troubleshoot this issue, but it will be a few days before I get to it.

1 Like

After a good week of everything working well, the system reverted back to the old problem. Again, the backup is consistently failing. Other symptoms are that there seems to be ongoing Background audio analysis despite that fact that there is nothing new in the library. The re-scanning of my NAS drive also seems to take a long time despite the lack of new files. I also see “new” items added to my library afterward that are not new. I wonder if it hiccups and loses connection with the NAS and then treats it as new again?

The only other computer I have available is this mac-book which I wonder how it can work as a Core (can I close the cover or will that throw things out of kilter?). I suspect the database is somehow defective and thus the problem with backup). Should I try the mac-book as core with this apparently corrupt database or go back and restore an old one again?

Update: I went ahead and switched the core to the mac-book. I let it integrate my library, and when it was done, I made a backup. I then restored my last good backup from the other Core (end of January), let that update to the latest database version, made sure it was done doing stuff, and made a “clean” backup of that. Now I am running that database on the Mac-book Core and will see how that goes. Fingers crossed. If that works for about a week, I will try starting the other Core again from that backup.

I knoe the sonicTransporter has only 8 Gb of memory, and maybe a limit (100 K tracks) but I don’t think I am near that (I have <44K), unless Qobuz stuff I add, which I don’t think it counts, adds to the total. How would I know if I was bumping into a memory limit on that system?

I ran on this new MacBook for 13 days with no problem. The comparison is not really fair as the laptop was closed and therefore inactive most of the time, only opened when it was in use. I left it up all night last night. Also, this MacBook is much more powerful, has more memory etc., and of course it is running MacOS and not the Linux version on the SonicOrbiter. If you have, for example, some degree of memory leak in the latest code, the MacBook might be fine. Anyway, I have backed up the library successfully, switched the Core back to the SonicOrbiter, and am restoring the latest backup. Lets all cross our fingers…

Next wrinkle: After restoring the backup, I could not connect to the SonicOrbiter. I restarted Roon on the server, then restarted my MacBook Roon control program. I was then prompted to login to Roon again. Next I was informed that the databse had to be updated after the latest Roon Version, which seemed wrong. After that it was live, slow at first while it did a scan. Now it is up and we shall see if it lasts.

Next morning, it took a while to reconnect with the server which I found running a scan. Looking at the log, it kind of looks like the service restarted itself right when I tried to access it. I am using it now. However, checking Backups I can see that the automatic backup failed (bad sign). I am pretty confident this is going to go like it did before.

So is this a software bug, or is my old hardware running out of capacity? Only 44K tracks (should be good for 100K) but maybe that metric is not sufficient. Or is the old metric no longer good with the latest code (does it require more computing power/memory than before)?
4/3 update- On opening my ipad this morning, O had to wait a long time before Roon came up, as if it was restarting. It is also scanning my NAS again.It acts like it is adding a few albums that i have long had in my library. The symptoms have thus changed (since the last ROON update?) as it is no longer telling me that my library is corrupted, but it is still not working properly, requiring a long “warm up” before I can use it.

Database has been on my SonicTransporter for a few days now. I had one crash (claimed the database was corrupted) and I cannot back the database up. These are the symptoms I had before. On advice I did remove the backups from the watched folder and put them elsewhere, but that does not seem to have helped much. It is true that I did not have these problems on the macBook, but that is not a permanent solution. Please advise.
To give it a clean start, I restored the backup from my last good experience (right before I switched from my MacBook). It came up for only a few seconds before again telling me that my database is corrupt.
I have now managed to pull an earlier backup and get it working again. After a long period with a slow scan, I seem to be back up. I tried to vack the database up again manually, but while I didn’t see evidence of an error, i also cannot find a recent backup where I thought I put it.
It went through another round of scanning my drive, and after I tried to backup the database again. This time it gave me a clear error message (Backup failed, no reason given).

This morning I was back to the old “Database is corrupt restore a backup” message. I restarted ROON server on the Core, and surprisingly got the “The new version you installed requires a database update. This may take a while” message. Obviously no new version was installed since last night. Next it comes up scanning and barely responsive. It claims to be looking at ~5K tracks (there are many more on the drive). I wonder, is there any way for me to disable scanning until I know I have added something to the drive? It seems to me the scanning, not recognizing that nothing has changed since the last scan, is a symptom also.
After it had scanned again, I cleaned the library. After that I again attempted a backup. Not only did it fail, but the result was a report of a corrupted database again. At this point I restarted Roon, let it scan, and cleaned the library again. I guess i will not attempt another backup.
I think the only thing i would lose if i started a new library from scratch are my playlists. I’m pretty sure Qobuz remembers albums i have added to the library (since recent additions show up even when I restore older backups). If I could export those playlists, and then import them again after starting the new library from scratch, I would be willing to try this experiment.
I am thinking this may be related to the memory leak issues I have seen elsewhere in #support fora, and that my 8Gb sonictransporter can deal with those. So maybe there is no help for me but to wait for a fix? Please let me know.

Watching my system over days, I came to guess that the reason that ROON concluded my library was corrupt is that it was failing to backup each night. Now having deleted my automatic backups, for the first morning in many days, the system is live. I continue to notice scans changing the number of tracks, many deleted files when I go to cleanup my library, newly added albums that were really added long ago. I am waiting for some guidance from #support

My latest update cames after Roon’s latest update. I saw a very quick scan that made me think my problem might be fixed. I did a manual backup and it worked. I then hoped it was all fixed and reset automated backups. That night the backup failed, and I was back to where I started. I turned off the automatic backups again. As long as they are not being attempted, I do not get the library corrupted error message, and the system runs reasonably well, except for the churn I have previously described. i am still waiting to a real fix.

Hello Daniel,

I know it has been since time since you heard from me, and I apologize for that. Your comments in the meantime have been helpful, so I do want to touch upon a few things you mentioned.

I would expect 8GB to be sufficient for a library of this size, so do not think that RAM size is the problem.

Qobuz and TIDAL tracks do add to the total library size, but I don’t see the library size as being the issue at the moment.

Just to clarify here, you ran the SonicTransporter backup on the Mac without issue (not a fresh Mac database), and you were able to create a backup from it? This would suggest that the issue is not with the backup, but rather something local to the SonicTransporter.

Roon runs database validation right before a backup happens. If there is corruption in the library, then this is the most likely time that Roon will detect it.

This kind of intermittent issue has all the hallmarks of a hardware issue to me. When I looked at your Core logs last time, I noticed the out-of-memory issue. I am unable to check your SonicTransporter’s system logs for clues, but it is possible that your SonicTransporter’s SSD or RAM is failing.

Have you by any chance been in touch with SonicTransporter support staff? I would request them to do a health check on your system, perhaps they can analyze your system log, or at least help with the retrieval of the log. Do let me know your thoughts on this when possible, thanks!

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.