"This track is not currently available in Qobuz" but albums/tracks play fine from Qobuz app, blueos

Having an issue where multiple albums that show up in Roon from Qobuz but when I try and play them for each and every track I get “This track is not currently available in Qobuz”. But the same tracks/albums play fine from the Qobuz App, Audirvana, and BlueOs. A few examples:

Arvoles CD by Avishai Cohen
Flotsam and Jetsam CD by Peter Gabriel


No problems with Pete Gabriel over here (Belgium). Listening to it now.

That is what is weird is that it shouldn’t be a locale issue since I can play it fine on the Qobuz app as well as via BlueSound. . .just Roon is tripping on it.

Best to make a new topic in Support category

Thanks. .moved.

Hi @Adam_Crafton1,

Are these tracks from a previous existing playlist? If you search for them directly in Roon, are you able to play them that way?

No. They are not in any playlist. I added the album to roon. I did just delete it and re-add it and I get the same error.

Hi @Adam_Crafton1,

Can you please share a screenshot of the affected albums?

Here are a few. . .I am sure there are more but these I know don’t work. . .

![27%20AM|690x336] (upload://n9OqKaO0E6Cw3GqFAZXUwPTf3UC.jpeg)

Hi @Adam_Crafton1,

Thanks for those screenshots. I tried playing the two Flotsam and Jetsam Qobuz versions available on my end and they appear to be working as expected with a USA Qobuz account.

Can I please ask that you send me a direct link to the Qobuz tracks? You can get the direct link by:

  1. Making sure that the problematic track is added to your library
  2. Right clicking on the track
  3. In the top bar, next to “Play Now”, click the 3-dot drop-down menu
  4. Click on “View File Info”
  5. Click on “View on Qobuz” and post a link here

Also, can you confirm your country of residence and which country the Qobuz account was created in?

When I select “view on Qobuz” it just takes me to the Qobuz login screen (even if I am already logged into the web browser it opens a new screen and asks me to login). However, I log in and then find the track it is there and plays fine. As I said, I can play these albums / tracks from Qobuz, BlueOs, etc. Just not from Roon

My account is a USA account.

I did the “view on Qobuz” for tracks that play from Roon and it took me a webpage that displayed the song. For ones that don’t work it takes me to a log in page.

Any updates on this? Again, it makes no sense to me. . .I can play these songs/albums just fine from Qobuz, Audirvana, BlueOs, etc. . .just not from Roon.

Hi @Adam_Crafton1,

I too noticed the behavior of “View on Qobuz” taking me to the home screen for this album. I noticed that you tried playing this track on 12/17/19 at 6:54AM according to your screenshot.

I’m going to go ahead and enable diagnostics mode for your account and what this action does is automatically upload a set of logs to our servers for analysis. I’ll try to locate the Track ID using this method and verify if I am able to play this track on my end.

Hi @Adam_Crafton1,

I was able to locate the track ID in your Core diagnostics, but I can’t seem to locate this Track ID on Qobuz’s end. I have requested that our technical team take a closer look at this case, I will be sure to let you know once they have provided their analysis. Thank you in advance for your patience here!

I can send you more examples. . .

Hi @Adam_Crafton1,

Sure, I can gather some more examples for review.
Can you please let me know the following?

  1. Name and Artist of track
  2. Local time + date when you observed this behavior

Greatest hits by Queen - all tracks. Clicked on “The Great Pretender”. 12/20 - 1:57pm
Joy for Every Long Heart - all tracks. Clicked on “We wait”. 12/20 - 1:58pm
Everybody Digs Bill Evans - all tracks. Clicked on “Peace piece”. 12/20 2:00pm
Peace Piece by Bill Evans - all tracks. Clicked on “Come Rain or Shine”. 12/20 2:01pm

Hi @Adam_Crafton1,

Thank you for sharing those new timestamps. I can confirm that the diagnostics package has been received and attached to your case. We are now awaiting feedback from the technical team regarding these traces and as soon as I have some additional info I will be sure to let you know, thanks!

thanks. . and to re-iterate, all of these play just fine from all my other systems/devices from Qobuz (Desktop, web, BlueOs and Audirvana). . Roon is the only that has problems with them.

1 Like

Hi @Adam_Crafton1,

I appreciate your patience until I had a chance to consult with QA on this behavior. They have tried in the lab to play the tracks you were experiencing issues with and playback works as expected, has there by any chance been any change in behavior since we last spoke?

If the behavior is still the same, can you please provide more information regarding your network setup? What is the model/manufacturer of all your networking gear? Do you have any firewalls blocking Roon?