"This track is not currently available" TIDAL error message

I haven’t tried Roon for a couple of weeks, but an going to today. At the time when I stopped using it, this issue was not intermittent - it happened every time I tried to play a track.

EDIT: not sure if I mentioned this before, but Tidal worked fine as standalone during this time. i.e., Roon would repeatedly fail, switch to Tidal desktop app, it would stream with no issues.

I still this at regular intervals with my brand new Naim Uniti Atom. Using the inbuilt Tidal app on the device I have not had any issues,

I’ve been struggling with the same issues described here, so I was glad to find this thread, but really dismayed to find end here six days ago. For me, Tidal is becoming more trouble than it’s worth to use via Roon, and I’m going back to Sonos until there’s word it’s gotten sorted out.

The behavior I see a few times a day is that certain tracks refuse to play, or certain playlists won’t, or certain songs on certain playlists won’t. That’s what’s happening right now: I’m trying to listen to the “Daydreams: A Winding Adventure Through Moods of Yesterday” playlist, and Track 8 will not play past 3 seconds no matter how many times I try, same deal with track 9 & 10, but starting with track 11 it will play fine. This kind of thing happens several times a day. Sometimes it seems it seems i can clear it up by rebooting by laptop or my core (Rock/NUC) but maybe that’s coincidence.

Please let me know if I can be of further assistance in troubleshooting/replicating.

I too am growing increasingly frustrated. I know Roon support staff is working on this and they have politely reminded us of that periodically, but my patience is wearing thin. We still have no idea why this is happening, nonetheless an actual plan to fix it. I’m trying to stay positive, but this is a bummer.

Ditto. For me, the frequency of the error is up and down, but when in full force, it has rendered Roon unusable more than a few times over the past few weeks. Super annoying. Like the others, I’m being patient and still love Roon for all its merits, but an update would be appreciated and a fix in the near future would be cause to celebrate.

I’m fairly confident that my experience here is a bit unusual and certainly won’t be relevant to those playing exclusively Tidal content. However, in the spirit of sharing, I was also getting this same error routinely on a playlist that included local and Tidal content. It would often but not always occur on the same Tidal track, again often but not always before a local track.

Unrelated to this problem, I moved my library from a NAS to local USB drive on ROCK. The error ceased immediately after doing this and I have not experienced it since. I don’t really understand how my local library could interfere with playing Tidal content but there you go. Perhaps it may be of help or relevance to someone out there?

Just to clarify because I was confused in how you stated it; You moved your library FROM a NAS TO a local USB (thus removing the NAS from the playback chain) and the error went away. Or was it the opposite?

That’s correct. I happened to have an old USB drive kicking around and decided to give it a go. I also thought I heard a sound improvement by doing this…but then I’m more than happy to be told that was in my head :smirk:

Well, I don’t know of a sounds improvement but you’ve decreased network load by having the files local to the server.

Yeah, that was the intention, in an attempt to fix an entirely different problem, but I guess could potentially account for this. That said, the network should have been more than capable of managing the traffic, and of course the Tidal and NAS traffic wouldn’t have been active to any significant degree at the same time.

I guess my main reason for mentioning it was to flag up that, perhaps only for some very unusual cases, the fix may lie a long way from what one might expect, given the error message.

I’m having this problem right now, and I’ve ejected my local USB library, it’s got no afect on playback. I’ve also

The Tidal Playlist I mentioned before, “Modern Space: What Are You Listening to?” won’t play back the first three tracks. After a long delay, it plays the first three seconds of the first track, then gives the error, then a long delay, then two seconds of the second track, long delay, two seconds of the third track, and so on. Eventually it will settle down and start playing one of the tracks, sometimes #4, sometimes #7. One never knows.

Current time is 6:13:08 pm EST according to https://www.timeanddate.com

I have tried removing all of the variables I can think of: I’ve removed my wireless bridge, linear power supply, swapped network cables, shut down network devices, rebooted routers, everything I can think of.

@support just checking to see if you’re still watching this thread, thanks.

This has been my experience also. It bears noting this problem did not occur at all until a Roon update that was pushed out around the time these error reports started to come in (around/before the holidays in US).

What’s even more frustrating to me is that, before Tidal streaming through Roon got borked, it was absolutely flawless. It worked better than native Tidal streaming.

This is only my conjecture - my interpretation of the silence we’re hearing from Roon regarding this issue - but, my bigger concern is that the folks at Roon know exactly what the problem here is, and that it is perhaps due partially to changes in Tidal, or otherwise due to Roon issues that are not readily addressable/or that Roon staff are electing not to address. It’s hard not to suspect the folks at Roon have a handle on what this issue is, and for whatever reason, cannot or will not communicate its cause or prospects for resolution to users.

Again, this is my conjecture based on the paucity of information we’ve received from Roon regarding this issue.
I very well may be - and hope I am - wrong.

But, of course, not communicating anything sends it’s own message we’re left to interpret.

I am getting close to renewal day and this is making me contemplate letting it slide. Having Tidal integrated was the main selling point of Roon to me as its not working and I have other ways to play Tidal without issue I might as well use them and save me a few bob. This has been going on too long for a product this expensive.

1 Like

Hi folks,

I know this issue continues to cause trouble for a number of you, and I just wanted to let everyone know this is absolutely on our radar, and we have been working to resolve this since it was first reported back in December.

I want to give a little background here to ensure everyone has a sense of what work has happened so far, and what our team’s next steps are here for getting this resolved.

First, I want to mention something which can cause additional frustration, but I mention it because it’s important context for the issue: based on everything we know right now, this problem appears to be affecting a very small portion of users.

We have many thousands of people using TIDAL with Roon, and while this issue may have arisen following a change in Roon or a change at TIDAL (or both), for whatever reason it seems to mostly be persistently affecting the people in this thread, which points to some other common factor – something about your network, your Core, your configuration, your TIDAL account, etc. Lots of avenues for us to investigate.

Second, I want to mention that our QA team spent a lot of time looking into this problem over the course of December and January. As you might guess, a few members of our team have seen this error in passing, but no one inside Roon is seeing this consistently, which makes it very tricky for us to investigate and fix.

Over the course of the last two months, our QA team did identify some steps that seem to trigger this issue more often. It didn’t happen every time, but it happened enough that our dev team looked into the report further. While our developers were not able to reproduce the problem consistently, we had enough information to implement a number of changes we hoped would prevent these symptoms from occurring.

Unfortunately, that change went out in our most recent release, and obviously this issue is still happening for some subset of users. This is not hopeless – not by a long shot – but it does mean our investigation needs to move onto the next phase.

We’ve begun today reaching out to affected users today to get additional information about their setups. Most of you will hear from us over the next few days as our investigation continues.

Our hope is that we can identify a factor that’s not been part of our testing so far – maybe many of you have a different type of TIDAL account, or certain Core platform, or router, etc. This work identifying commonalities across affected users will also happen in parallel to additional testing by our QA and dev teams.

If you notice a way to consistently trigger this error, please let us know. Other common factors (like “the error always happens at night” or “it always happens with MQA content” etc) would also be great.

I am absolutely confident we can figure out what’s going on here guys. We really appreciate everyone’s feedback, and your patience.


We have to get to the bottom of this!


You can add me to the list and I have a friend nearby that has the same problem. The only things we have in common are that we both use Sonic Transporters and have the same Tidal accounts. There is an audio store in town that says they have the same problem but with just Tidal (not with Roon).

I don’t know what to tell you. Everything is better today. Yesterday it was nearly unusable. Today, I was listening to nothing but Tidal all day, and I don’t think I saw the error once.

Just now I cued up that same playlist I mentioned above, and I was able to start it up and listen to track #1 with no trouble, and it’s playing right through.

I don’t know if anything changed on your end or on Tidal’s overnight Monday to Tuesday, but I do know that I have changed just about everything I can think of on MY end over the past week in an effort to fix the problem. So now I’ll start rolling back those changes one at time to see if I can get the problem to start again, but I don’t think it will.

Thanks for the update @mike, good luck with everything.


they have the same problem but with just Tidal (not with Roon).


@Bill_Soukoreff Which problem is that specifically?

The problem mentioned in the title of this thread. :slight_smile:

Nothings changed in my kit since before this started to happen. It happens in both my listening locations. I just upgraded my endpoint to a new Naim Unitiy Atom and it still happens. It’s also at any time of the day it will strike there really doesn’t seem to be a pattern. I am using A Netgear r8000 router, QNAP for music storage and a custom built i3 pc for the core with 8gb of ram running Vortexbox OS with an SSD system drive. Nothing else runs on the core machine except Roon. My endpoints are connected to the router via tplink powerlne adaptors and they have more than enough bandwidth. I also tried via wireless and the same issue occured. It can no happen though for a while and then you will get it every album change or playing something from a different album. It’s also not always the same material. It also happens when playing their playlists.