TIDAL: a network or connection error is interfering with TIDAL playback

Hi Murray, Yes it does seem like we have the same issue. I find it frustrating and like you not sure what to do next. I have a 2015 DXe which is an older model than yours possibly but don’t think that would be the reason.

It was suggested to me to change the DNS settings:
https://developers.google.com/speed/public-dns/docs/using?hl=en
My router will not allow this and I’ve not attempted to do this in Linux, but may ask Antipodes for help.

All the best Patrick

Hi Patrick,I have just spent an hour with Tony from antipodes, he has had a good look at the streaming issue and has gone away to have a Talk with Mark J
Tony may step in here and give you a little more info as he is monitoring this thread.
Yes I have a 2015 Dxe as well but it was modified last year to the latest spec.
I have had MQA albums streaming this morning first time ever, but still very much hit and miss I am afraid.
Regards
Murray

1 Like

Volkswagen Dieselgate, anyone?

Thanks Murray, I’ll follow up with Tony later.
In the end I’m not too bothered about not getting MQA to play as there is so much music to explore anyway but would be nice to get to the bottom of this.

@support
I am using and enjoying the new build of Roon (1.3 - 208)
Is there any way to tell which albums are MQA by looking at album. I don’t mean how to find them as I understand how to do that. They don’t play on my system (not enough processing power). I can only tell when they start playing then stop after a few seconds, which is annoying if part of a playlist. A symbol on the album would be great then I wouldn’t select them or I would select an alternative redbook if available.

Hi,

Much more likely it’s some forum of broadband bandwidth limiting that you ISP is doing.
You can test if your local hardware is ok … by planning a 96K local file … if it plays ok then it does tend to point the finger towards your ISP.

Going back to your question, the only way I know of at the movement (and it not a perfect indicator) is to play the track and look in Roon signal path to see if it is streaming 48K/24bits.

For the Tidal Masters I have added to my lib, I’m manually tagging them with “MQA” I guess one could also add “MQA” in the version field … which would then show up on the album cover.

However, imho this are all work-a-rounds … Roon should support identifying/displaying/filtering MQA albums automatically … I guess it will come in time.

Thanks Carl

I have researched the non playing of MQA with the Antipodes people (see above in thread) and its to do with the processing power of my current server that is not powerful enough for MQA processing even though I can play local 24/192 flac files. The demand for streaming and processing MQA from Tidal is just too much.

Yes there are work arounds by manually locating the MQA albums and tagging, I was hoping there was a way to glance and see which ones are MQA in case I was missing something. I have them now peppered throughout my playlists so I will have to remove them. Hope as you say Roon will add a way to see which are MQA albums with a symbol or something like that.

If I could clarify re Patrick’s comment above …

I spent a little time comparing a Tidal MQA album with its FLAC equivalent (Aretha Franklin - I Never Loved a Man). This showed that during the first 5-10 seconds of a track the following track on the album was being cached, in the Roon cache. Further, each MQA track cached almost three times the size of the non-MQA track (26Mb vs. 9.2Mb, 42Mb vs. 15Mb, 30Mb vs. 11Mb etc.). Correspondingly, processor load during the cache operation for MQA tracks was 3-4 times that required for non-MQA. On earlier Antipodes server models (pre-2015) this CPU requirement for ~5 seconds was sufficient to cause dropouts and loss of sync. Once the track had been cached CPU usage dropped to 1/10th of that needed for the cache operation and there was ample processing power for handling playback of MQA tracks,

I received my Meridian Explorer 2 yesterday (3/10/2017) and everything was fine.Just now (3/11/2017 6:58 PM PST) I started getting this message while playing a Tidal Master album. I will switch to the Tidal Windows app to see if it happens there.

Thanks for clarifying Tony. The obvious question; is there a simple way to increase cache other than a major cpu upgrade i.e. with more RAM?

To put this in perspective in my system, I find it only a minor inconvenience not being able to play MQA tracks. The SQ quality from my own library (CD and high res) and the world of Tidal gives so much pleasure already.

It’s not a question of memory. The Roon Cache is on disk so there is a period of relatively (but not very) high disk write activity, involving multiple threads, and an associated CPU load.

An observation when playing one single track :

Streaming ‘CD quality’ from Tidal - a block of network traffic ~45Mbps for several seconds, then nothing, and the track plays until the end - unbroken.
Streaming ‘Master / MQA quality’ from Tidal - a block of network traffic ~45Mbps for several (more) seconds, then nothing, and the track plays until the end - unbroken.
Playing a local / ripped CD (from my NAS) - multiple repeated sawtooth peaks of ~5Mbps continuously, until the end of the track.
Playing a local / ripped MQA or other high-res file (from my NAS) - multiple repeated sawtooth peaks of ~5Mbps continuously, until the end of the track.

I’ve simply observed this by watching my ethernet traffic with Task Manager.

However, it suggests that Tidal ‘dumps’ the whole file to your computer in one hit, or as quickly as possible, whereas local streaming is more regular / shared / spread (for want of a better description - the networking experts are welcome to chime-in here !).

My simple observation could be wrong, but if it’s accurate or a reasonable interpretation of what’s going on, and if your router / local processing actually are limited in some way - could it be possible that streaming Tidal is overloading your system, due to the protocols / methods they’re using, and hence causing some kind of streaming error ?

Again, there are plenty of very experienced networking people within the community, so perhaps someone can hypothesise further…

A post was split to a new topic: Tidal has dropouts while playing 16/44

im having problem with tidal in roon it not connected and it gave me message they nrigt in the message error loding page please check your network conniction and its allready concted with the router succsesfully i ntry many thing like reboting the router and delete roon and download it again and i download roon servier also without any benfit please help me with that it really anoying

omar,

Hi Omar
Can you give more details? System, source and which features in Roon you are using? Are you trying to stream MQA? Have you checked all connections and rebooted? Is your internet working okay?

Im using Devialet 250 by usb source usually im streaming tidal from roon and it was working good i didnt chang any thing in roon sittings one time tidal its not connicting in roon ,they send me message chek your network connection and the connection was fine the intranet is working , im not trying to stream MQA i steam normal songs please help me i try everything thing

Do you have Devialet support? Contact them and ask to help. Also Roon and Tidal support. Add @support to your question here on Roon and they will reply.

I had a similar problem with not connecting and as I have an Antipodes server the Antipodes folk helped me to find the problem which was a software corruption. Takes patience and working through all the options. Also I have heard it claimed that your internet provider can limit Tidal streaming. Adding a fixed IP address for your server can also help.
Good luck as I know how frustrating this can be.

Hi @omar_ali ---- Thank you for the report and sharing your observations with us, both are appreciated. Sorry to hear of the troubles.

Moving forward, to help me better understanding what could be potentially causing this behavior to occur, may I very kindly ask you to please provide me with the following:

  • An expanded description of your current setup, using this link as a guide. The more information you can provide, the better.

  • Can you please provide me with the make/model of router you are implementing. Furthermore, is the device hosting your Roon core hardwired to the router or is it using a WiFi connection?

  • If you were to just use the TIDAL application, and not Roon + TIDAL, how do things behave?

  • Have you tried logging in and out of TIDAL, within in Roon?

-Eric

I now have this problem. No Tidal playback. Outside of Roon, things work fine with TIDAL. Running ROCK.

I got this message when playing tracks from Tidal too. A network or connection is interfering with Tidal playback. The solution for me was to reboot my NUC running the Roon Core.

1 Like