TIDAL: a network or connection error is interfering with TIDAL playback

I just tried a quick test with macbook pro laptop - playing MQA files from Tidal app straight to DAC. That works fine. MQA from Tidal through Roon on my music server does not work.

To save me re reading the whole thread, by Not Working do you meant the Blue light doesn’t illuminate or the audio actually doesn’t play?
If the blue light doesn’t illuminate then you are not bit perfect which cou;d be a setting in Roon or PC.
If you can play through the Tidal App your bandwidth is ok to that point.

Hi Patrick
MQA only needs about 1.6Mbps versus 1Mbps for regular 16/44 flac files…neither of these are considered large numbers by any means…but I’ve seen evidence elsewhere of ISP’s throttling streaming services, as they essentially want to “charge” companies like Netflix [in particular], Apple, Sky, Spotify and Tidal for using their Broadband infrastructure…and even if it was happening, they wouldn’t be throttling MQA files only [as they wouldn’t know what they were]…but they would typically limit the service to 1Mbps…which is still fine for delivery of most non-streaming services

In any case, this is now all moot…your MBP trial with the Tidal app shows that you can get Tidal at the required speed to play MQA tracks…so now the the Roon guys can use that to look elsewhere

Strange question I know, but do you use any switches anywhere in your internal network??

And just to answer your question about “MQA not needing high bandwidth”…compare the following and you will see that Tidal MQA is small by comparison to other requirements

Tidal Redbook…~1Mbps

Tidal MQA…~1.6Mbps

24/96 Flac Streaming…~6Mbps

Netflix 720p…~3Mbps [PC’s & Tablets]

Netflix 1080p…~8Mbps

Netflix 4k…~15 - 20Mbps

So, MQA doesn’t need high bandwidth compared to some of the above services

1 Like

Hey Patrick, having read your posts, I"m not sure what you mean by the files don’t play.
do you push play button and nothing happens and the file just sits there still queued,
push the play button and it looks like it is playing but no audio,
push the play button, and it skips to the next track?

1 Like

Well very strange, I just tried MQA again (that is through Roon from Tidal) and it worked - played perfectly- for several minutes only. See screen shot with purple dot.


Then it stopped again and jumped to the next track. This has been my experience ongingly and its now doing this again. Press play, plays for a few seconds, gives a network error and jumps to next track.

Also:
“Strange question I know, but do you use any switches anywhere in your internal network??”

No switches only a Virgin superhub router. I also use a powerline to get internet to rest of flat but its not used for audio

Thanks Ronnie, this is interesting.

I know it seems weird. But, I have seen situations where even having a powerline adapter plugged in caused network slowdowns. As a quick test, I would unplug the powerline stuff from your router and then test Tidal playback. Its a quick way of eliminating that as a possible issue.

1 Like

I run a computer sale/support company and so far one of the lessons we have learned is that both Mains networking and WiFi don’t work.

If it’s mission critical then use cat 5 minimum.

By this I mean while it may work now it will fail and on mission critical stuff failure is not an option.

3 Likes

Tried disconnecting the powerline which is connected to my router (and not used for audio). 24bit 48khz tidal tracks still do not play more than a couple of seconds before jumping to next track…
I don’t use wifi either for audio.

Hi Patrick, it appears you and I have the exact same issue, I also use an Antipodes DX music server.
I am connected to a fibre net running 100 bps,comes into a router and then connects to the DX via CAT6 Ethernet cable. I do have a Itona net isolated just before the DX. My issue is there weather this isolated is in or out.

I have had this morning for the first time MQA playing from Tidal through Roon, but intermittent, I like you can run Tidal on a pc on the same net and get MQA albums playing without the connection and stop starting issues.

I am at aloss as to what to try next. I have got volume levelling turned on, but turning it off makes no difference.

Regards
Murray
New Zealand

Hi Murray, Yes it does seem like we have the same issue. I find it frustrating and like you not sure what to do next. I have a 2015 DXe which is an older model than yours possibly but don’t think that would be the reason.

It was suggested to me to change the DNS settings:
https://developers.google.com/speed/public-dns/docs/using?hl=en
My router will not allow this and I’ve not attempted to do this in Linux, but may ask Antipodes for help.

All the best Patrick

Hi Patrick,I have just spent an hour with Tony from antipodes, he has had a good look at the streaming issue and has gone away to have a Talk with Mark J
Tony may step in here and give you a little more info as he is monitoring this thread.
Yes I have a 2015 Dxe as well but it was modified last year to the latest spec.
I have had MQA albums streaming this morning first time ever, but still very much hit and miss I am afraid.
Regards
Murray

1 Like

Volkswagen Dieselgate, anyone?

Thanks Murray, I’ll follow up with Tony later.
In the end I’m not too bothered about not getting MQA to play as there is so much music to explore anyway but would be nice to get to the bottom of this.

@support
I am using and enjoying the new build of Roon (1.3 - 208)
Is there any way to tell which albums are MQA by looking at album. I don’t mean how to find them as I understand how to do that. They don’t play on my system (not enough processing power). I can only tell when they start playing then stop after a few seconds, which is annoying if part of a playlist. A symbol on the album would be great then I wouldn’t select them or I would select an alternative redbook if available.

Hi,

Much more likely it’s some forum of broadband bandwidth limiting that you ISP is doing.
You can test if your local hardware is ok … by planning a 96K local file … if it plays ok then it does tend to point the finger towards your ISP.

Going back to your question, the only way I know of at the movement (and it not a perfect indicator) is to play the track and look in Roon signal path to see if it is streaming 48K/24bits.

For the Tidal Masters I have added to my lib, I’m manually tagging them with “MQA” I guess one could also add “MQA” in the version field … which would then show up on the album cover.

However, imho this are all work-a-rounds … Roon should support identifying/displaying/filtering MQA albums automatically … I guess it will come in time.

Thanks Carl

I have researched the non playing of MQA with the Antipodes people (see above in thread) and its to do with the processing power of my current server that is not powerful enough for MQA processing even though I can play local 24/192 flac files. The demand for streaming and processing MQA from Tidal is just too much.

Yes there are work arounds by manually locating the MQA albums and tagging, I was hoping there was a way to glance and see which ones are MQA in case I was missing something. I have them now peppered throughout my playlists so I will have to remove them. Hope as you say Roon will add a way to see which are MQA albums with a symbol or something like that.

If I could clarify re Patrick’s comment above …

I spent a little time comparing a Tidal MQA album with its FLAC equivalent (Aretha Franklin - I Never Loved a Man). This showed that during the first 5-10 seconds of a track the following track on the album was being cached, in the Roon cache. Further, each MQA track cached almost three times the size of the non-MQA track (26Mb vs. 9.2Mb, 42Mb vs. 15Mb, 30Mb vs. 11Mb etc.). Correspondingly, processor load during the cache operation for MQA tracks was 3-4 times that required for non-MQA. On earlier Antipodes server models (pre-2015) this CPU requirement for ~5 seconds was sufficient to cause dropouts and loss of sync. Once the track had been cached CPU usage dropped to 1/10th of that needed for the cache operation and there was ample processing power for handling playback of MQA tracks,

I received my Meridian Explorer 2 yesterday (3/10/2017) and everything was fine.Just now (3/11/2017 6:58 PM PST) I started getting this message while playing a Tidal Master album. I will switch to the Tidal Windows app to see if it happens there.