TIDAL - Album not found/Login issues

Just over a month ago a decided to try out Tidal’s 4 month offer, was loving the sound and discovering new music.

Now I just give up as half the time I get error messages about the album not being found and I have to go through logging in again on a remote headless Mac Mini. I won’t be paying for the service after the trial but I think this is more Roon’s fault than Tidal’s.

Hi @Julian_Fricker,

I noticed your post in the #roon software section and have split you out into a support thread.
If you are interested, we can certainly look into this issue as a support case, provide some more details regarding your setup by using this thread as a guide to get started:


Describe The Issue

When you start a thread in the #support category, Roon Support will need to know:

  • What’s not working

Getting information from Tidal.

  • How often the issue occurs

It can happen several times a day, normally it’s after I haven’t used Roon for a few hours.
It’s mostly a problem on my “remote” Roon running on my desktop Mac, if I vnc into my “core” Mac Mini it will sometimes be working there.
Sometimes hitting refresh on the core will fix it, other times I have to completely remove my login details and set up tidal again.

Describe Your Setup

It’s important that you include all relevant setup information so our team can get a clear understanding of the issue.

Your post should include:

  • Details on your Core machine (OS, Hardware specs)
    Mac Mini Mid 2011 2.3GHz Intel Core i5 8GB Ram
    Mac OS 10.13.6
    Main hard disk is 240GB SSD

  • Networking details (especially what hardware you’re using, how everything is connected, and anything notable about how it’s all configured)

Everything is connected via ethernet cable, no wifi

  • Audio devices in use


  • Library details (where your music is stored, whether you’re using a streaming service, how many tracks are in your library)

Library is stored on a 2TB external hard disk

Including these details in your first post helps us resolve your issues faster.

Hi @Julian_Fricker,

Thanks for sharing the above info so that we can start the support case.

Do you mind sharing a screenshot of what the issue looks like from the Remote? Do you have any other Roon Remotes (iOS/Android) and if so, do they have the same behavior?

You could try reinstalling the Roon Remote/Client app on your Desktop mac to see if this will help:

  • Make a Backup of your current Roon Database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location (on the Desktop Mac in your case - not the Mac Mini Core)
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App to generate a new Roon folder
  • Verify if the issue is the same

I’ve finally had time to do this. Immediately when I load Roon on my Mac Mini there is an issue with Tidal.
I’m trying to play songs from one of their playlists and it just skips the song I chose and plays the next one. I tried again and this time it skipped through 4 songs and stopped, no audio.
3rd time it finally played the song I wanted when I click on it.

Later on now I’ve tried to look at a playlist called Office Rotation. It shows me a message “This Playlist is Empty”. I’ve also tried logging into my Mini remotely and the Roon interface there shows exactly the same, so i don’t think this is an issue with me using my desktop mac to operate Roon on the Mini.

Quitting Roon on the mini fixes the problem this time. Earlier today I’d restarted the mini so this isn’t an issue of how long it’s been running.

It managed to get through about 5 songs, then played the start of next song then skipped, start of a second song then skipped and now it’s stopped. Used screen sharing to get to the mac mini, tried to start the playlist and it just kept skipping tracks until about 6 down and then starts playing. Tried again and now see the message “Too many failures. Stopping playback.” Try to force the one song again using the drop down “Play Now” and get “Playback was interrupted because a track failed to load.”

This is exactly the kind of behaviour I’m getting all the time.

Hi @Julian_Fricker,

Thanks for trying the reinstall of the Roon app on the Mac. Based on your new symptoms, I’d like to take a look at your Roon logs to see if I can gather more clues.

Can I please ask that you first reproduce the issue, note the exact local time + date + track that is affected and then use these instructions to access your Core logs (Under ~Library/RoonServer/Logs or ~Library/Roon/Logs on the Mac Mini) and send me a set?

If you have any issues accessing the logs or don’t have any file transfer services, just let me know!

Here’s a link to the logs on dropbox.

I emptied out all my logs before trying today so in these logs is the following behaviour.

Started roon on the Mini and got error message about not connecting to Tidal, I pressed retry 3 times and then it worked. I then moved to using Roon remotely from my Mac and was able to play about 5 songs from a Tidal playlist and then it started skipping and gave me an error message that it was stopping due to too many failures.
I then tried on the Mini and couldn’t get the Tidal interface to update at all so I shutdown the mini to get the log files. When I relaunched the mini I got a different error message about not being able to connect to Tidal, there were 2 boxes, a blue one where the content should be and a pink one with the option to retry. Even if I retried it wouldn’t connect. I shutdown Roon again so this failure was also included in the log files.

Here’s another one from today. Started using Roon on my remote machine and nothing was working on Tidal. Logged on to Mini and the interface titles and headings were shown for Tidal but there was no content. Messages telling me to reload but nothing worked.
Restarted Roon on Mini and got the same screen as I sent previously, “You aren’t currently signed into TIDAL”. I took a copy of the logs at that stage.
When I started Roon again I got a message telling me it would take longer to start as there was a new version rebuilding my database. This time it starts up correctly and I’m logged into Tidal and can see all the content.
I’m shutting it down again to send this as part of the logs as well.

Hi @Julian_Fricker,

Thanks for your patience here while I had a chance to review logs. Looking over them, I’m seeing a common pattern:

[Status=NetworkError, ErrorText=Error: SecureChannelFailure (Unable to write data to the transport connection: The socket is not connected.)]

This error typically occurs when there are networking errors or misconfigurations.

Please provide more details regarding the exact model/manufacturer of your networking gear and how everything is connected (direct to router or through some sort of switch / powerline)?

Our Networking Best Practices Guide provides some more in-depth suggestions for a properly working network.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.