Tidal and Qobuz Stopped Working

I am not sure if this is related to the update but…here is what happened yesterday:
I have ROCK running on an intel i3NUC, 8GB RAM and 128GB SSD.
The NUC is wired to my LAN, internet connection works at 100MB
Everything was smooth until yesterday, when both Tidal and Qobuz stopped working.
Both of them could load albums, select tracks, searches etc but none of them would start playing any track.
I got mad restarting all my devices, checking connections etc.
Then I decided to move to my old CORE, installed on a Mac Mini running Roon server and wired to the same LAN. That worked fine, no issues at all.

So I understood that the problem must be with the NUC…I tried changing the DNS from default value to and that made the trick. Now the NUC is back working smoothly.
However, I have not changed anything in my setup apart from the Roon update to 1.6.
How is it possible that a DNS change become necessary all of a sudden?

Hello @alessandro_niola,

If you had to change the DNS settings this could be due to a mis-configured network setup, does your setup meet our Networking Best Practices? Is everything still running smoothly?


Thanks Noris,still running smoothly, thanks
But I don’t understand why this happened, the DNS I was usong before has been in place since ages…and everything worked fine until 2 days ago

That’s certainly strange @alessandro_niola,

Might it have been that your ISP DNS servers were unreliable when you tried yesterday? Hard to say. If you want to try changing it back to see if things are still stable you can give it a go, although if everything is working as expected you might not want to go through that.

One thing I should mention, if you are using static IPs now for your ROCK, please be very careful as changing the network that the ROCK is on can cause you to lose communication. The ROCK will always try to go for the assigned IP and if the subnet is differnet you will not be able to access it, so I would highly suggest changing back to DHCP if you’re ever switching routers or moving the ROCK from one location to another.


I got the same problem after updating my ROCK (on a NUC) to 1.6 yesterday - Tidal stopped working.
But where do I change the IP for the DNS-server? That field on the web page for ROCK is just display-only…

You have to change from DHCP to Static IP, then you’ll be able to change the DNS value

OK, done!
And it actually got TIDAL back. Weird but good.

Thanks for quick support.

Hi Per
Well…it worked :slight_smile:
Enjoy your NUC,