Tidal content failing to play on macOS Monterey

Roon Core Machine

M1 Mac mini with 16GB RAM, running macOS Monterey

Networking Gear & Setup Details

Mac mini wired to Eero gateway using AT&T Fiber (1000Mbps)

Connected Audio Devices

iFi iDSD Signature

Description of Issue

When trying to play Tidal content from Roon the tracks skip and stop util Roon just refuses to play. This was working flawlessly on my Mac mini until I upgraded to macOS Monterey. Tidal Desktop App can play Tidal content (even MQA) without issues on the same machine and using the same iFi iDSD Signature DAC.

I have tried everything already, logging out of Tidal and back in, restarting the Mac mini, even restarting my router and gateway and the issues reapears after a little bit.

It seems this issue has been reported several times previously (see below) but the answer at the time was that macOS Monterey was still in Beta so Roon was not supporting it, but Apple has now released macOS to the general public and the issues persists.

Previous reports of the same issue:

Hi @JuanDG,

The next time the issue occurs try power cycling (restarting) the iFi DAC. Let us know how it goes.


This probably won’t be helpful but I had some issues when I upgraded to Monterey on an M1 Mac mini with 16GB RAM - not to do with Tidal (which I don’t use), but with last.fm integration. In my case turning off Private Relay fixed it. Might be worth a try if you have it turned on.


Thanks @John I have completly unplugged the iFi DAC to remove it from the equation and plugged in the speakers directly to the Mac mini. Unfortunately the issue persists, Tidal Desktop client can play music continuously without issues and Roon skips and stops mid-song until it refuses to play at all. Items from my local library (HDD) play continuously on Roon and it’s only Tidal that refuses to play.

Thank @DaveN you were spot on! Private Relay was on and as soon as I turned it off all of my Roon issues with Tidal went away. Thank you so much!

@John please take note of @DaveN solution so you can recommend it to all customers having issues with Streaming Service Integration on macOS Monterey


I’m glad it helped. I don’t know why Private Relay causes issues with network connectivity and Roon (last.fm integration and Tidal), when it seems to work perfectly well with all the other software I use, but there’s clearly something amiss. Hopefully this will be resolved at some point as I do think it’s a useful feature.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.