Tidal content fails to play and Roon hangs

Core Machine (Operating system/System info/Roon build number)


Latest Roon version.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

NUC on wired gigabit connection. End points on mesh WiFi

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

All end points affected. Ropieee, iPhone and Chromecast audio

Description Of Issue

I am seeing a regular issue where some tidal tracks fail to start playing. Roon spins forever on the track until I skip it manually.

For instance right at the moment I’m seeing it on the first track of the album Conditionally Yours by Tennis, and the third track but NOT the second track. I’m seeing the same thing on the first track of the album Any Random Kindnss by Haelos too.

But most other albums work fine, I have played a whole Pete Tong album this evening with no issues. Local content is unaffected.

This happens reproducibly at the moment on all my end points and from all controls.

If I switch to my tidal app all the affected content plays immediately.

I have tried restarting the core and the network gear. I have also changed DNS settings on the core.

Nothing works.

Please @support can you assist?

Hi @Tim_Rhodes,

I just gave this content a spin on my end and it worked okay. Can you confirm the region for your TIDAL account?

Hi @dylan

Thanks for the response. I’m in the UK.

I’m having the same issue with the same content this morning. I have had it before with other content as well.

Strangely most tidal content works fine but just every so often I find these tracks that just hang in Roon. And as I say it always plays in the tidal native app.

Been trying a few more things;

I logged out of TIDAL completely in Roon, restarted Roon Server on ROCK and then signed back into TIDAL again.

Made no difference, that content is still unplayable in Roon.

Whilst testing this I also have found some other content, that is playing, but is very slow to start (like 5 to 10 seconds before a track plays). In this case its the album TBNH by The Brand New Heavies.

Again this doesn’t happen with all TIDAL content, just some of it.

I have tried changing the DNS settings on ROCK. Google, Cloudflare and my ISP. It didnt make any difference.

Hi @Tim_Rhodes,

I just tried playing this album on my end and I’m not able to reproduce this behavior.

Would you by any chance have another PC around the house which you can use to temporarily host the Roon Core on? It would be interesting to note if this behavior occurs only when using ROCK as the Core. Although the database should be affected, please be sure to create a Backup of your database (for safe-keeping) if you were to make this temporary switch.

Hi @noris

I have temporarily moved my Core to a Windows 10 1909 laptop. Restored my backup. The behaviour is identical. I cannot play the first track of either the Tennis or the Haelos albums. Some subsequent tracks will play, others wont on the same albums.

Hi @noris, @dylan

I have found some more tracks that wont play;

Henry Green - Electric Feel (single)
Lil Wayne - Let The Beat Build (from the album Tha Carter III)

If I try and play either Roon spins indefinitely with the grey playing bar pulsing blue. This is happening too often for it to be a coincidence. Both will play fine from the TIDAL app.


Thanks @ged_hickman1, I tried that… it didnt work either. Those tracks still refuse to play at all.

@dylan @noris

I moved my Core back to the NUC but I have ditched ROCK in favour of Windows 10. The performance is definitely better, but it hasnt made a difference to this issue unfortunately.

1 Like

@support do you have any further suggestions on this issue please? It is still occurring exactly as described.

Hi @Tim_Rhodes,

I will follow up shortly via private message.

Hi @Tim_Rhodes,

I have tried to play the following tracks using your TIDAL account on my ROCK (build 511):

I have not noticed any strange behavior on my end, all tracks played as expected with no startup delay. The next step here would be to try with a fresh Core (no backup restored). Can you please try setting your current database aside by using these steps?

  • Make a Backup of your current database
  • Stop RoonServer from running in ROCK’s WebUI
  • Navigate to your Roon’s Database Location
  • Find the folder that says “RoonServer”
  • Rename the “RoonServer” folder to “RoonServer_old”
  • Restart the RoonServer in the WebUI to generate a new Roon database folder
  • Verify if the issue occurs with a fresh database in place


Thanks for the suggestion, I’ll give it a try. One question though, I’m now on Windows again rather than ROCK, so I assume I should just be renaming the /Database folder?

OK @noris I did as you suggested, but since I was running in Windows I renamed the /Database folder to /Database_old and then restarted Roon. It sync’d my TIDAL library, and I did not add my local content at all.

It still shows the same issue, on the same tracks. Here is a screen recording of the problem…


Hi @Tim_Rhodes,

If you wish to apply similar instructions, you would have to rename the entire Roon or RoonServer folder on Windows as well (not just the database folder). Just renaming the database folder can cause some strange behavior, so I don’t think this test was preformed properly here.

If I rename the whole folder I cant just restart Roon though correct? I need to reinstall it completely? The shortcuts will all be broken since they point to C:\Users\<user>\AppData\Local\RoonServer\Application\

EDIT: Actually never mind I’ll just remove the whole application and reinstall it. It’s just going to be quicker.

Hi @noris @dylan

So in order to rule out a database issue as far as possible I followed your advice and have carried out the following steps on my core machine;

  • Removed Roon Server completely from the machine and manually deleted any folders that were left behind
  • Downloaded Roon Server 64 bit for Windows and reinstalled it from scratch
  • Launched Roon control on another Windows machine and entered my account details and configured TIDAL (I did not add any local content and I did not restore my backup)
  • Waited for Roon to sync my TIDAL content completely
  • Attempted to play the affected content yet again…
  • … and it failed again :frowning:

New video;

This is starting to get a bit frustrating, mainly because I seem to be messing about with Roon rather than being able to listen to my music!

Do you have any more suggestions?

This is where the forum-based support falls down IMO. I have received one meaningful response per day at best on this issue. I have tried to turn around the suggested steps quickly which leaves a lot of not much happening.

In the absence of a reply, even one saying there is nothing more that can be done, I’m sitting waiting for something that may never come. My Roon config in a limbo state. Frustrating.