Tidal login failed warning

ROCK / Roon 1.7 / Build 571 / Roon OS 1.0 / Build 219

All devices run the latest Roon software.

My ROCK is directly connected to a Fritzbox 7590 modem with an audioquest ethernet cable. The Modem is connected to 100 Mbit DSL connection. IP address set up is on DHCP. I tried manually with google DNS but does not help.

I play my music on a Moon Neo Ace which is also directly connected to the Fritzbox via an audioquest ethernet cable. I control ROCK with an Ipad Pro, Samsung S10, Macbook Pro on Catalina and sometimes with a Surface Book 2 running Windows 10.


I am running ROCK on a NUC7 and have Tidal login failures every day for months now. My Rock gets restarted every day. The issue started somewhere early this year after a Roon update. I have tried all ideas for the forum but it never helped. How can I fix this issue?

Does it connect with retry? Or not at all. I see those occasionally but retry get its going.

Hi @anon99401871,

Just to confirm, when you click Retry do things work for you?

Our team is currently investigating this behavior which seems to be affecting some Roon users after TIDAL’s login process change. This issue appears to be stemming from slowness either on the Core machine directly or on the network, causing the login attempt to fail when it’s initially tried. We are investigating how we can make this process better for anyone experiencing this, but at the moment the best option is to investigate what might be causing the slowness.

Some things you can try:

  • Try using a different Ethernet cable — Is there any change?
  • Does Google DNS or Cloudflare DNS help here?
  • If you temporarily use your Mac as the Core machine is there any change in what you’re experiencing?

It connects when I retry. Rock runs normally afterwards. Even when I reboot Rock it still reconnect properly and I can use Tidal. When my modem reboots (every day) the login fails.

Changing the ethernet cable does not change, I used brand new Audioquest Vodka and Cinnamon ethernet cables. Changing the DNS to Google does not make a difference either, problem occurs. Will try changing the Core.

The login issue occurs every time when my modem restarts.

Hi @anon99401871,

Thanks for the additional details here and for trying those suggestions! As Dylan mentioned, we are still looking into this issue from our side as well, and this investigation is in progress. If we need any further details for the investigation, we will reach out, but for now we should wait for the investigation to be complete, and hopefully afterwards there will be an improvement in behavior. Thanks for your patience in the meantime!

Any progress on this one?

Hi @anon99401871,

This issue should have been addressed in build 610, apologies we didn’t notify you here!

Are you still seeing this issue after ensuring you have the latest build from Roon installed by navigating to Roon Settings -> About?

Do I have to clear some cache or something because I’m running 610 and still have the same issue.

Hi @anon99401871,

You can try a TIDAL cache clear to see if this helps:

  • Exit out of Roon
  • Stop RoonServer via the Web UI
  • Find and open your Roon database
  • Navigate to RoonServer/Cache
  • Move the contents of the /Cache folder elsewhere, like your desktop
  • Try restarting Roon and verify if the issue still occurs

If this still does not help, please let me know the exact local time + date of the next time you see this error appear.

Thanks for your help. Unfortunately the above, did not help. The exact login time of the error was 16.19 CET today from the Netherlands. Hope this helps.

Hi @anon99401871,

Thanks for letting me know the time of the failure! I’ve enabled diagnostics mode for your ROCK and what this action does is automatically upload a log set to our servers. I can confirm that the log report came in and I’m looking over it now and I’m seeing this:

10/02 08:11:02 Warn: Error in web request https://accounts5.roonlabs.com/accounts/3/login: NetworkError (Name or service not known Name or service not known)

This trace indicates that you are not having just issues with TIDAL, but logging into our login servers as well.

How did the test of using the Mac as a Roon Core go? Did you have the same issue there or just when the Core is hosted on ROCK?

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.