Tidal Login Problem


This is the third night that Roon tells me there is a login problem with Tidal, I have to restart Roon Server each time and then is ok, but, I think doing this every night is nonsense.

Can anyone help me or guide me?


I had this yesterday which coincided with me disconnecting my broadband as I had to rewire my internal phone wiring.
Just logged in again. Chris

Since you get access after restart it seems to be Roon-related and not with the TIDAL API. Or what do you say, @mike?

In fact, I close Roon’s Server App, then I open it again, and I have to Login to Tidal again (through Settings, Services, and then Tidal Login). And this is every time.

Probably @palbratelund you are correct, because all my Tidal apps (iOS, Android, OSX) are working fine, but I don’t know if there is a specific API for Roon.

I don’t have this in the Roon client. Is this limited to Roon Server?

I’m guessing this is either networking, or something specific to your setup and Roon.

If you’re seeing this so often, let’s grab some logs @Norman_Salazar and we’ll take a look at what’s going on. I’ll be in touch shortly via PM and we’ll go from there.

Sorry for the trouble!

@support: I’m getting used to this now, but it’s still annoying. TIDAL periodically fails to sign in. I can sign in on the web, on my iphone, on the desktop TIDAL app, but Roon won’t play. It’s happening way too frequently. Please fix. Thanks!

QNAP running core with ethernet to PS Audio DSD DAC, MicroRendu, with controllers on iphone, MacBook Pro and Airpad. Love my Roon! Fix my TIDAL. And let’s get this TIDAL Masters thing going in Roon, no?

Hi Folks!

Hope someone can help me with this irritating problem. I’ve been completely unable to log onto Tidal from Roon for a few days now (previous to that it has worked fine for about a year). Fails with this error:

Tidal app from Mac and iPhone work fine and I have re-entered acc/pwd in Roon settings several times, double checked tidal account status online, restarted Roon core etc.

Roon core is running on SonicTransporter, remotes on OSX & iOS.

Many thanks in advance!


Have you Re Started the core?

1 Like

Yes, per OP, but will do so again now.

That worked. Go figure! Many thanks Chrislayeruk. :blush:

It’s always worth another try, if all else fails. Congratulations…

I’ve started getting this too now. This is my third time. And i can never remember my password Grrr.

I am just setting up my system for the first time, and getting this Tidal login failure issue. When I first logged into Roon it was able to access Tidal no problem, and all was well. About six hours later, I got an error message in Roon that said “Tidal - there was an unexpected error, please check your account details.” Since that happened for the first time yesterday, I have not been able to access Tidal content in Roon.

I am able to log into Tidal OK on my other devices. This problem only happens in Roon.

My setup is a Sonictransporter core connected to a microRendu and controlled remotely via a Nexus 10 android tablet and by my iPhone 7P. When I initially set up and logged into Roon yesterday, both the Nexus 10 and the iPhone 7P were able to access Tidal content within Roon no problem, and then something happened and neither of them are.

Can someone help me? Thank you!

Have you restarted the Roon core?

Yes - that didn’t help unfortunately. Also rebooted the microrendu but no luck.

Hi Ben,

Try the restarting your RoonServer twice method.

If that doesn’t work, try to re-enter your Tidal log in user name and password. It’s located in Settings > Services > Edit next to Tidal.

Cheers, Greg

Thanks Greg. I went to sonicorbiter.com and rebooted the Sonictransporter twice in succession with a 15 second wait in between. Still getting the same error message - can’t login to Tidal within Roon. Did I do the restart correctly?

Hi Ben,

I don’t really know the SonicTransporter, but you want to restart Roon Server (twice), not reboot the ST.

I believe this issue is fixed in the upcoming Roon version 1.3 due out shortly. I can’t give you a time frame though.

Maybe someone with more knowledge on the ST can help you with restarting Roon Server.

Cheers, Greg

Thanks Greg. Just to clarify the nomenclature, since I’m new to Roon. In my setup:

Core = Small Green Computer Sonictransporter AP i5 with 2 TB internal SSD storage
Output = Sonore microRendu (not sure version # but it’s new)
Control = Nexus 10 with Android 5.1.1, and iPhone 7Plus with iOS 10.2

Sonore and Small Green Computer have a website called “Sonicorbiter.com” where I can reboot and power down both the microrendu and the Sonictransporter.

This morning I chose “reboot” for the Sonicorbiter twice in succession, with a 15 second gap in between. Then I went back to my tablet and was able to log into Tidal.

This issue appears to have been worked around. I look forward to a new software version which will address this permanently. I suspect that until it is released, I should get used to rebooting.