Tidal not working via Roon (headline updated 21 October 11:33 CET)

Roon Core Machine

macOs Monterey 12.0-beta (21A5304g)
iMac (Retina 5K, 27 tum, 2020)
3,8 GHz 8-Core Intel Core i7
16 GB 2667 MHz DDR4
Cora via either ethernet or WiFi (Ethernet gives ca 95 Mbps, WiFi +300 Mbps)

Networking Gear & Setup Details

RUCKUS Unleashed 200.9
5 wired APs
All music devices on wifi

Connected Audio Devices

Devialet Original d’Atelier via WiFi with “Excellent signal” which means well above Roon requirements.

Number of Tracks in Library

10 377 tracks

Description of Issue

I cancelled my Tidal subscription three weeks ago since Tidal didn’t work via Roon. Deleting Tidal_Account didn’t help for more than a few seconds each time. However, I realized that I missed some essential albums + playlists so I subscribed again. Tidal still won’t play in Roon, no matter the Core connection being Ethernet or WiFi. The blue line just moves forward and backward for minutes.

Since installing Tidal today, also Qobuz doesn’t work. It plays music for seconds or in best case one and a half minute then the music stops and I (sometimes) get the message that “Qobuz media is loading slowly. It may indicate network- or connection problems” (My translation)

The network is obviously doing fine. I don’t know what connection problems means really. However, until today I have experienced no problems with Qobuz (in any format).

Tidal has been problematic for months and now also Qobuz. Are there as many different errors as there are Roon users or can I/we expect a general solution soon? At least, please help ME in this situation.

Kind regards //Magnus

The problem you’re experiencing normally comes down to a networking issue, of one sort or another. From what you’ve said it seems like your LAN is fairly robust, but clearly something is going wrong.

The first thing you should check is that you’re using a good DNS service. Roon tends to recommend either Google (DNS: 8.8.8.8 and 8.8.4.4) or Cloudflare (DNS: 1.1.1.1 and 1.0.0.1), It’s probably also worth mentioning that you’re running a beta version of the Mac OS. I know Monterey is getting close to release, but this may also be a factor.

It would also be worth checking if you have IPv6 enabled on your network. If so, try turning it off as it has been known to cause problems with Roon.

I have a couple of Ropieee on WiFi. Rebooting them seems to always fix this issue for me, even if they appear accessible.

DaveN, thanks.
DNS service is 8.8.8.8. and 8.8.4.4.
The beta version has been working until today regarding Qobuz. But I have the same Tidal problems on other cores, both MBP and PC.
IPv6 not enabled.

What does this mean? Is Ropiee a player or similar?

Have you tried rebooting everything, including your network gear? It’s not an elegant solution, but I’ve often found that rebooting every device in the chain can help. If that doesn’t make any difference hopefully support will be able to help.

Ropieee is the software you can run on a RP4 to create a Roon endpoint.

Elegant or not, I do it frequently. In this case, however, I hadn’t. I have now and it got Qobuz working, so thanks @DaveN.

Tidal still dead, except for the moving blue line. @support, any suggestions?

1 Like

Magnus, does Tidal work in it’s own app on your control device?
And also, please log out of your Tidal account in Roon Controller, and re-authorize your account after that.
Please post a “masked” screen shot of your Tidal account settings dialogue?

Hi Mikael,
Tidal works flawless in all other setups than through Roon. Account re-authorized with no effect.
Are these the settings you ask for?

Hmm, no, I was curious about the dialogue from Roons Inställningar-Tjänster-Tidal.
Like this, but of course for Tidal;

Ok, here.

1 Like

Magnus, have you initially connected Tidal to Roon and had Master set as default?

I believe I’ve seen someone on here with a similar problem. Sadly can’t remember the thread.

Hi Raz, thanks for joining in. I think I know what thread you mean (with problems occurring after a downgrade) Downgrading Tidal HiFi to Premium - Roon frozen
Don’t believe that’s the problem here since it existed also when Master was default in my settings.

1 Like

Yup, that’s the one. Sorry can’t be of any help then.

Sorry Magnus, i cant see any obvious reasons to your troubles either.
It definently looks like some kind of network trouble though.
Let’s see what @support can find in your logs?

Magnus,

Maybe you should also post some screen shots of the signal path in Roon when you attempt to stream. Also your Roon audio settings.

Hey @Magnus_Grondal,

Thanks for the overview of the issue you’ve experienced so far and all the steps you’ve already tried. Thank you!

I believe it was @DaveN who suggested changing your DNS. I failed to see if you gave that a try. We think that should help :nerd_face:

@Magnus_Grondal I too am operating from Monterey beta. I’ve had similar issues with Tidal. Roon is not going to address the issues coming from beta software and Apple warns of the problems that can arise from beta use. I operate three Roon accounts and the only Tidal problems come from the one using the beta. Apple just released the release candidate today and final version will be out for sure on Monday. I’m hoping Roon will take a closer look when the final version is out.

1 Like

I changed Core to a Big Sur Mac and now Tidal works. Thanks a lot @RTaylor3rd, @DaveN and @beka :pray:

3 Likes